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Clive Huggan’s notes on Microsoft® Word 
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	These notes are a “living” document; I consult them frequently in my own work. For best accessibility, they are designed more or less as a dictionary. If you really want to get the best out of Word — saving time, doing things more simply, and taking advantage of Word’s advanced features — you’ll find useful ideas here. 

"Bend Word to Your Will" explicitly covers only Word 2004 and earlier. I did not move to Word 2008, because there was no business case to relinquish the macro capabilities and other elements on which I rely, so Word 2008 is not covered. 

I started on the long task of updating the document to cover Word 2011. However, the directions in which Microsoft has developed its Office suite — including substantial develop​ment of cloud facilities and the likely absorption of Office for Mac within the Microsoft Corporation into the PC Office structure — hint strongly that the next edition of Office for the Mac will be very much changed from Office 2011. This development prompted me to abandon work on a 2011 update in favour of a shorter document: Migrating from Word 2004 to Word 2011: retrieving the smart bits describes how I recovered my favourite time-savers from Word 2004 when I found they weren’t in Word 2011. It’s downloadable from the same page as this document (see the URL below).
The underlying capabilities of Word 2008 and 2011 remain almost the same as in Word 2004, despite some major changes in the graphical interface. Therefore, if you are using either of these later versions you will probably find it isn’t too difficult to infer the equivalent processes from these notes — if, depending on the subject, there is any difference at all. 


April 2013 edition

Made available free via the Microsoft MVP website:
http://word.mvps.org/Mac/Bend/BendWordToYourWill.html
To take advantage of features such as hyperlinked cross-references and the “Find” command, and to allow you to examine the document’s electronic structure, this is intended to be used as an on-screen Word document — not as a PDF or hard-copy print-out. 
It is probably best displayed at 125% or 140%, depending on your screen. 
It contains footnotes.

Bend Word to your will (or try to)
— Clive Huggan’s notes on Microsoft® Word on the Macintosh®
The Conditions of Use on the http://word.mvps.org website apply to this document in addition to the following provisions.
Disclaimer

This document is provided “as is”, without warranty of any kind, either express or implied, including but not limited to implied warranties for its quality, performance or fitness for any purpose. To the fullest extent permitted by law (including liability by reason of negligence), the author shall not be liable with respect to loss or damages caused or alleged to have been caused directly or indirectly by the information in this document or by the electronic content of the file itself, or with respect to any other form of liability. 

Copyright   

© Clive Huggan 2002–2013. This document is copyright in accordance with the provisions of the Copyright Act 1968 (Commonwealth of Australia) and amending legislation and, through international treaties, the laws of many other countries. All rights are reserved. Textual information in this document may be acquired, stored, copied, displayed, distributed, printed and/or otherwise reproduced — in whole or in part — provided that the information is not sold or used for a commercial purpose. Except as permitted under the Copyright Act 1968 or other applicable laws, or as permitted above, the acquisition, storage, copying, display, distribution, printing and/or other reproduction of text in this publication for any other purpose is prohibited unless prior written permission has been obtained from the author. No other exclusive right may be exercised by any person or entity without prior written permission of the author. 

Screenshots in this document are reproduced by permission of Microsoft Corporation. They are separately subject to copyright provisions determined by Microsoft Corporation. 

Trade marks

All products mentioned in this document are trademarks, registered trademarks or service marks of their respective owners, and are the property of their owners. In particular, Apple, Mac and PowerBook are trademarks of Apple Inc., registered in the US and other countries, and Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. 
IMPORTANT — PLEASE DON’T SKIP THIS!

Although these notes are about 200 pages long, you don’t have to wade through from start to finish to find what you need. After the introductory comments and until the appendixes, almost all the subjects are listed by keyword headings.  Just dip in where you need to!

If you spend a few minutes to grasp the structure and to read the introductory comments (pages 13 to 29), you’ll find it quick and easy to track topics down. 

Just remember: Except in the section on styles and a couple of small sections and appendixes, it’s best to consider this document as a dictionary, not a novel, and to remember that the table of contents shows its over-all structure.

Here is the document’s structure:

	Starting on page
	Main sections
	Notes

	6
	Table of contents
	Click on the page number in the table of contents to be taken to that page. (If this doesn’t work, your settings require you to hold down the Control key.)

	13
	“Welcome to my notes”
(shows where I’m coming from and how the notes differ from published manuals about Word; contains some important “how-to” comments and some warnings)
	Please read these pages.

	17
	“Please read this section before going further”
(important information in here will make these notes more useful and keep you free from some of Word’s traps)
	By all means skip the comments that don’t interest you, but be careful — some comments are important.

	29
	“Recommended modifications to Word’s initial set-up”, followed by “Further modifications”
	Not alphabetical, because in this section it’s much more useful to go through the recommended settings step-by-step.

	54
	“Modifications later on”
	In alphabetical order by main keyword.

	85
	“Styles and templates — the keys to consistency and saving time”
	This article is in a narrative (non-alphabetical) form, because this topic is fundamental to using Word effectively. Styles in Word invariably appear complex at first — until suddenly it all makes sense — so a “building-blocks” approach is needed. 

	120
	“Miscellaneous tips and reminders”
	In alphabetical order by main keyword.

	161
	Appendixes
	Non-alphabetical narratives of more detailed topics.


Theses note are more of an informal reference to some important features of Word than a progressive description of Word’s capabilities that you find in a manual, so you will not lose anything by jumping around the document. 

In the narratives, you will see many hyperlinked cross-references that take you direct to a topic just by clicking on them. 

Often the quickest way to find a topic is to use the “Find” command (key Command-f or in other words, hold down the [image: image2.png]


 key and type “f”). (If you don’t like using the mouse, you can repeat “Find” with a keyboard shortcut once you have clicked back into the document: Command-Option-y. Or you can choose your own keyboard shortcut, as described later on.)

Now please read the important notes on the next page about how to display this document correctly. 

Following that advice won’t take long, and it will save you a lot of anguish!

	ESSENTIAL:  IN THIS DOCUMENT, YOU REALLY DO NEED TO SEE WHERE THE HYPERLINKS ARE
There are many hyperlinks in this document, on which you can click if you want to go to the reference shown. For example, they are in the following table of contents (just click on a page number to go to that page). Many hyperlinks are also in the body of the document, either as titles of articles, page cross-references, or the words “above” or “below”. 

You’ll find it much easier to know what text is a clickable hyperlink and what’s ordinary text if you activate the setting that produces a grey background to these hyperlinks (on the screen only; it doesn’t print). 

If you see some grey shading behind the hyperlinked page number here ( “17” ( you already have the setting activated. If you don’t see any grey shading, you should click on the number (between the quotation marks and arrows) to go to notes that tell you how to change the setting.  Please note the number of the page you’re reading and do this now; you’ll find that it’s important. 
YOU MAY NEED TO UPDATE THE HYPERLINKS, INCLUDING PAGE CROSS-REFERENCES

If you see the words “Error! Bookmark not defined” anywhere, or if the hyperlinked page cross-reference numbers don’t seem right (e.g. all of them show the same number), you will need to update the links. This is done by keying Command-a (hold down the [image: image3.png]


 key and type “a”) to select the whole document then hitting the F9 function key at the top of your keyboard to do the update. 

( F9 is now taken by the Mac operating system: for a work-around, see page 21.)
( On a PowerBook / MacBook Pro or iBook you will need to hold down the “fn” key before hitting the F9 key, as for all the F keys.

Take the same action if you find the page numbers in cross-references are not quite accurate. 

If you live in the United States, you may prefer US Letter page size rather than the A4 size in which this document is paginated. (The page set-up makes no difference unless you want to print these notes — but bear in mind they aren’t intended to be printed, because the hyperlinks are an important element.) To change from A4 size, go to Page Setup on the File menu and select your preferred size. Then follow the instructions above to amend the table of contents and other cross-references. 

For more information on hyperlinks, see “Using hyperlinks in this document” on page 20.  


Remember: You can find topics quickly  in the table of contents 
by clicking here and using the “Find” (Command-f) command.

[If you’re an advanced user of Word, you may like, in addition, to apply the keyboard shortcut 
on page 196 that takes you to the table of contents from anywhere in this document. I use it in all my long documents — it saves a lot of time. If you don’t want to do that, it’s also quick to key Command-[Home key], which takes you to the front of this document, then click on the “Contents” hyperlink at top right.]
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Welcome to my notes!

Whether you’re fairly new to Microsoft® Word on the Mac, or you want to use Word more efficiently — especially with long documents — I hope you’ll find the ideas in these personal notes of mine are useful. 

Essentially the notes describe the ways in which I’ve been rising to the challenge of — as one Word expert said — “bending a sometimes obnoxious product to your will and making it do things that may surprise you”. I concentrate especially on the things that improve speed and efficiency — and importantly reduce the chances of document corruption — in long and/or complex documents. (Word usually remains free of corruption in simple, short documents, but can throw up significant problems in longer ones. On the positive side, Word has some marvellous features when you delve a little further, which can hugely increase your efficiency. These notes were written with both these factors to the fore.)

How you use these notes depends on your interests and level of expertise

Word is now by far the most complex software commonly used on personal computers, containing more than 30 million lines of code. It can be configured to an enormous extent to suit your needs, but finding out how to start off can be very daunting. Just leaving Word as it comes from the box — in its factory configuration — exhibits some features that many people find highly irritating and confusing, and some features that soon lead to problems. I cover these aspects too, since I’ve experienced those reactions in good measure! 

Of course, everyone has different expectations of their software. That’s what makes writing software books difficult. Even though these notes were mainly written for my own use, I had to bear this in mind in developing them further for my friends. The result is that you can use these notes in many ways, depending on your interests and your present level of expertise. For example: 

•
You could well be irritated by some of Word’s features that automatically cut in to give you “help” — the “I know what’s good for you and you’re going to get it whether you want it or not” factor. If you prefer to remove them and to specify a few other settings that suit you, the guidance on pages 29 to 67 will give you more control. 

•
If you want to gradually learn more about Word but not very intensively, you can use the “Find” command and the table of contents to find notes about the topics that interest you. Except in the section on styles and a couple of small sections, consider this document as a dictionary. It is more of an informal reference to important features than a progressive description of Word’s capabilities that you find in a manual — so you will not lose anything by jumping around the document. You will see many clickable cross-references that make it easy to jump to related topics; if you take the simple steps described on page 17 you’ll be able to easily see which of these cross-references you can click to go directly to the reference. 

•
If you want to focus on formatting long documents, making them quicker to format and less vulnerable to corruption, make sure you read the notes on styles. Word’s styles are extraordinarily clever; they boost productivity more than any other feature. Start at page 85, and read Appendix A: The main “minimum maintenance” features of my documents, starting on page 161. The topic of document corruption is covered in various places: first read page 127, then use the “Find” command to look for “corrupt”. 

•
If you want to use more of the huge range of Word’s features, dig in from the table of contents, use the “Find” command freely, and tap into the expertise available at the MacWord MVP newsgroup described on page 21. 

But irrespective of your needs, you should first read the important notes from page 17 to page 26. 

[If you are using Word 2001, read especially “Configuring your Mac to minimise problems in Word” on page 26. If you are using Word X or Word 2004, ignore the notes: OS X has completely different, automatic memory management that doesn’t need intervention.]

If you’re going to be digging into these notes in detail, perhaps I should tell you where they came from. I started to compile the notes for my own use when, in 2002, I changed from Word (for Mac) version 5.1a to Word 2001, and realised that I would need to keep track of the huge number of differences between the two versions. Then I decided to clarify the notes for some of my friends who weren’t very familiar with Word.
 

[There are footnotes in this document. They can be overlooked in Normal view, which — mainly because things work faster — is the view that most serious users of Word use most of the time when working on a document. But since you aren’t working on this document, you may well decide to view it in Page Layout view.
 (The recommended sizes for Word to be displayed are covered on page 17.) Whichever the view, you should be aware that you have just passed the first footnote reference marks. See the tiny “1” at the end of the previous paragraph? It looks just right when printed, but at 7 points it’s small on the screen. If you slowly roll your I-beam across the “1” and pause, a small window will show what’s in the footnote. Well, it should — but it won’t always, especially if you have already rolled over another footnote reference mark (to overcome that, click anywhere in the document’s text other than on the footnote and try again). And sometimes the first line of the footnote will be omitted from the text in the small window. Ho hum: Word is like that....]

Whether or not I wrote a topic into these notes has depended on:

•
how useful I have found a piece of new information in furthering the work that I do, and

•
how likely I am to forget the information (especially if I haven’t used a feature for a while).

In other words, topics have not been added “just for the sake of it”. I have needed all of them in fulfilling my primary task of getting work out the door. Their genesis was in very brief notes on topics in my own words that I wrote down whenever I needed to consult Word’s Help feature, or a manual, or a newsgroup. My main motivation was to counter my forgetfulness of minor details. With many topics, I added to, clarified or otherwise amended the notes every time someone further explained them on the Word newsgroups in which I participated (unfortunately now closed by Microsoft and replaced by a website that for the most part lacks continuity to discussions, hence not much opportunity for in-depth conversations), and I edited the notes as I went. At all times I tried to keep things as simple but unambiguous as possible — not an easy task, because shortening notes too much can make the information too cryptic to be useful. I ended up putting in much more effort than I thought I would, but I’ve ended up with notes that I find very useful. 

I’ve continually improved these notes for 2013 = - 2001 
12
 years. They are still a “work in progress”, in keeping with the philosophies of continual improvement that underpin my work as a management consultant. 

Until Word 2008 it hadn’t been necessary to make extensive changes when a new version of Word has appeared, because most changes to core features had been incremental, and new features have sometimes been “flaky” anyway, leading me to continue to prefer the previous reliable features. But very radical changes to the user interface were introduced by Word 2008, along with reduced features. This continued in Word 2011. Many of these features are not accessed much by casual users of Word, and the changed interface has been well received by most people. However, many of us who use Word intensively for a living need to stay in Word 2004, for reasons I mention in the green panel on the title page of this document. So Bend Word to Your Will does not cover Word 2008 or 2011. However, the underlying principles remain the same and if you derive useful information from these notes you will probably find it isn’t too difficult to translate if you are using Word 2008 or 2011.

These notes suggest approaches that are most suited to long documents in which the emphasis is on minimising document corruption, keeping the electronic structure simple, making global formatting changes quickly and easily, and maximising interchangeability between computers

I own copyright of these notes but I have waived all restrictions on non-commercial use. Please refer to the full copyright notice on page 2.

Importantly, I accept no liability whatever for any consequence — direct or indirect — of any person making use of these notes. Please refer to the full disclaimer notice on page 2. (Why do I bother with this? Because some people do things incorrectly, or they lose files they have not backed up, or files which incorporate many hours’ work become corrupt, and major problems can ensue. There is an increasing risk, in this litigious world, of action being taken against the person who gave them advice on using the software. A colleague of mine had this happen to him, and it was an ugly business before it was resolved several years later. With such complex software as Word, neither I nor anyone else can forecast the side-effects of some of the settings or practices under all possible scenarios — and this applies even if someone has followed these notes to the letter. Ultimately, maybe something in my notes is wrong, even though I have conscientiously tried to avoid that. And there are certainly omissions — otherwise the notes could well be 1,000 pages long, like some Word manuals. So I can’t, and don’t, accept any liability for anyone’s use of my notes, albeit I have written them in good faith. If you don’t think it’s reasonable for me to disclaim all liability, please do not read or use Bend Word to Your Will.) 

The reason I have brought my notes to a more finished state than I needed for my own use and have made them more widely available is to say “thank you” to some very kind people in the best forum that was available for advice about Word on the Mac: the microsoft.public.mac.office.word newsgroup, unfortunately now closed down. Countless warm thanks are due to John McGhie, Beth Rosengard, Daiya Mitchell, John McGimpsey, Paul Berkowitz, Elliott Roper, Corentin Cras-Méneur, Jim Gordon and other gurus who congregated there. In a completely voluntary capacity, and with great patience and understanding, these people revealed and explained so much of the inner workings of Word that was otherwise unavailable. Much of the content of these notes originated in their expertise, either as points that I edited into the notes or as the stimulus for my further ideas. During the period in which I developed these notes, these people added enormously to my initial understandings. 

Various things in these notes, such as spelling, reflect Australian usage, which is a variant of international English. This differs from United States usage, particularly, in some spelling and terminology.  Readers who use US English should note particularly that in international English, “tick” is used instead of “check”, although often I have used “select” as an alternative to “tick”. The page size for this document when downloaded is A4, not US Letter; notes on reconfiguring the page size are included in the next section. 

I mentioned earlier that the subjects in this document have been written and arranged so that they are fairly self-contained — “a dictionary, not a novel”, as my friend Steve Neilsen says. Knowledge of other topics in the notes is not assumed, since you won’t want to read the notes from cover to cover. That’s why some material (such as menu sequences as in “choose Format menu » Document …”) are repeated in full. However, some subjects may not be fully comprehensive and there may be a little unnecessary overlap between some topics. In part this is because the notes follow my idiosyncratic preferences derived from using Word since version 1 of the mid-1980s; and in part because these are informal, on-going notes, not a published manual.

I hope that my notes will encourage you to do many more “things that may surprise you” in your own version of Word!

— Clive Huggan
Canberra, Australia
April 2013

Before you refer to topics that interest you, 
please read the notes starting on page 17 

Please read this section before going further

… and if you haven’t yet gained an understanding about how Bend Word to Your Will is structured because you jumped straight to this page, it will really pay you to read pages 3 to 5. 
	IMPORTANT — MAKE THE HYPERLINKS VISIBLE
It’s possible you may not want to read the recommendations for setting up Word’s settings (as shown on the pages following page 29) just yet, although I recommend you do. If that’s the case, you’ll need to know to know which parts of the text in this document are hyperlinked (that is, text is formatted so that you can click on it to take you to what it’s referring to, as explained overleaf). That’s easily done if you make all the hyperlinks appear on the screen with grey shading behind them (they don’t print out as grey, though).

[The instructions below actually make all fields grey. In this document, all but a few fields are hyperlinked, shown by the pointer arrow changing into to a pointing hand.]

If the page number on the second line of this paragraph isn’t shaded grey already, do the following.

Go to the Word* menu » Preferences* » “View” » under the “Show” heading, set the pop-down menu under “Field Shading” at “Always”. While you’re in this window, I recommend ticking “Bookmarks” (especially so you’ll be able to see them in the document you are now reading; one is in the heading within this panel).

*
In Word 2001 and earlier, the menu sequence is Edit menu » Preferences — and the choices are arranged by tabs. On the PC, these settings are reached via Tools menu » Options. 


Fonts used in this document

In the interests of compatibility between computers, including computers using Windows® operating systems (PCs), the only fonts used in this document are Arial, Verdana and (for arrows etc in a few places) Symbol and Webdings. Sorry that it makes the typography boring! 

Displaying this document

The font used for body text (style “bt”) in this document — that is, the text you are now reading — is 11 point Arial. I choose this size, and a more open line spacing than single spacing, because I find it’s much easier on the eyes on screen and particularly in a page-wide column when printed. This font and size make it likely that the best percentage for this document to be displayed is 110% or 125% on a glass monitor. On a flat-panel display (iBook, PowerBook, MacBook, MacBook Pro, iMac or LCD screen) you may find 125% or 140% is best.  To achieve your desired size, go to the View menu » Zoom » key in the number in the “Percent” box » OK. 

[A toolbar button that you can click in future to apply your chosen zoom value is described on page 189.]

If you prefer a different font

If you prefer a serif font on screen such as Times New Roman (which also has a smaller font size than Arial for any given numerical value), do this:

•
Save a copy of this document, because you may want to return some time to it: choose File menu » Save As » nominate the desired name and location » click “Save” button. 

•
Format menu » Style » scroll to the style “bt” and click on it to select it » click “Modify” button » at the bottom, pop down the “Format” button » in the “Font” field, type or select “Times New Roman” » click OK » click OK » click “Close” button.

•
Save the document, which will now be in Times New Roman font.

•
You may wish to change the heading font to Arial, which is finer than Verdana.

•
If you want to further adjust some of the font sizes, first read the notes on styles starting on page 85, then take the steps nominated under “Modifying the styles only in the document you are working on” on page 100. 

If you use US Letter paper 

If you live in the United States or another country that uses US Letter paper, and you want to print these notes, go to File menu » Page Setup » select “US Letter”. Then, from Page Layout view (which will repaginate immediately, which will take 10–20 seconds), update the table of contents and cross-references by typing Command-a (to select the entire document) and pressing the F9 key (see the note on page 21 concerning OS 10.3 or later). A few seconds afterwards, the page cross-references etc in the body of the document will be correct for your page size. If you are in Normal view, you will then need to open the footnotes (View menu » Footnotes) and key Command-a and F9 again to bring them up to date. 

No other changes will need to be made, because I’ve used “minimum maintenance” formatting, described on page 161, which saves a huge amount of time if you work on long documents. 

If the first time you press an F key produces a dialogue box instead of doing what you expect, see “Function keys, if they don’t work in Word” on page 137. 

Why some headings in these notes are coloured

I like to know exactly where I am in a long document, so I initially use different colours for different levels of headings. The colours are especially useful in letting me know, subliminally, where I am without having to read the wording or assess the font size of the heading. This is of course important when leaping around a long document under development.

I realise the heading colours I’ve chosen for this document are not very aesthetically pleasing. That’s because the essential requirement is to have them very distinctively different from each other, so I can pick the heading levels unconsciously, especially during rapid scrolling. When printing a final document in colour or preparing a PDF, I do a “Save As”, then change the headings to pleasing colours. It takes about a minute when using styles, as described later in these notes. 

All the coloured headings in this document automatically compile themselves into entries in the table of contents. The black or grey headings are created in a special style that looks the same as comparable headings except for the colour. The difference with these latter type of headings is that, by design, they do not appear in the table of contents. As with the treatment of the headings I mentioned in the previous paragraph, it’s easy to quickly change these “nontoc” headings to a different colour, especially just before printing, if aesthetics are important. 

For further information, see page 85 under the heading “Styles and templates”. If the heading immediately below this paragraph isn't coloured, your computer has been set up to over-ride the appearance of default headings in this document: to correct this, see “Stopping other people’s styles over-riding yours when they receive your document” on page  116. 

The Command key

In these notes, the “Command key” means the key with an ornate “cloverleaf” [image: image4.png]


 (sometimes called a “pretzel”
) on it. It is different from the Control key, which is two keys further away from the space bar. People who also use Windows computers can find this confusing, especially because the equivalent of many “Control-[whatever]” commands on the PC is “Command-[whatever]” on the Mac. 

An apple symbol was also on this key on keyboards, leading many people to refer to it as the “apple key”. However, Apple Inc. has always referred to it as the “Command key” — for example when describing keyboard shortcuts — so for clarity “Command” is preferable. And since the apple symbol was removed from keyboards made in 2007 and afterwards, referring to the "apple" key may confuse people who have more recently come to the Mac. 

If you’re using a Windows version of Word

Although these notes are based mainly on Word 2001 and 2004 for the Mac, if you are using Word on the Windows PC platform it isn’t too difficult to make a few mental adjustments to allow you to get almost the same value from the notes as Mac users — just as they make adjustments when reading Windows-based Word manuals (which is quite common: the Word for Windows manuals are much more comprehensive). If you’re on Windows, you should start by familiarising yourself with the main differences between the Mac and Windows interfaces (on page 146) before reading the topics. 

Menus or keyboard shortcuts?

In these notes I usually say things like “Choose Edit menu » Find”, meaning “Pop down the Edit menu and select “Find”. In practice, this “Find” command is so frequently used that almost everyone simply keys Command-f (Control-f on the PC). However, if I were to give the default “keyboard shortcuts” for every action in addition to the menu sequence, the notes would become too cluttered. So I only mention the keyboard shortcut when it’s significant. 

You’ll have your own opinions about which standard keyboard shortcuts you want to memorise, which actions you want to assign your own shortcuts to, and which actions you’ll leave to the menus or toolbar buttons. I use keyboard shortcuts by preference for the actions I perform most often, because it saves time and disrupts my train of thought less than reaching for the mouse; but I occasionally need to remind myself of the ones I use less frequently — including those in the two tables starting on pages 69 and 76. Interestingly, Mac users of Word have been found to be significantly higher users of keyboard shortcuts than PC users of Word. 

Using hyperlinks in this document

In electronic form, this Word document has internal hyperlinks in the table of contents and in many cross-references in the body of this document.

To use a link in the table of contents, click on a page number against one of the entries: you will be taken immediately to that page. (In recent versions of Word on the PC, you may have to right-click or hold down the Control key to do so — but on the PC you can click on the words, not just the numbers to be taken elsewhere.)

In the body of this document, page numbers or heading cross-references (or sometimes the words “above” or “below”) have been hyperlinked. If you aren’t familiar with hyperlinks, you might like to try one now. Here are the steps: 

•
It’s best to have the hyperlinked cross-reference fields shaded grey on the screen, if only for this test (I leave them shaded all the time — it doesn’t show in the printed document). Choose Word menu (Edit menu in Word X and earlier) » Preferences » View. In the Field Shading box, select the option “Always”.

•
Print out or otherwise note the comments below before you follow them. 

•
Note that you are now at page 20 (the page number is at the bottom left of the status bar below). 

•
Roll the I-beam over the page number at the end of the next line of text and pause on it.

[Notes on configuring your Mac to minimise problems are on page 26.]

•
You will notice the I-beam changes to a hand with a pointing finger (well, it should — but don’t worry if it doesn’t). If you click once on the page number you will be taken to the cross-referenced heading on that page. 

•
To return to this page, key Command-g » 20 » hit the Return key.

Usually when you want to go back to a previous position in the document, you would use a very handy keyboard shortcut that rotates you back through the last three places in which you typed.  It’s Command-Option-z (i.e., hold down the Command and Option keys then hit the letter “z”, then release the Command and Option keys). But on this occasion you will only click the hyperlink, rather than type something, so Command-Option-z is of no use. (Shift-F5 does the same thing, but since I prefer keyboard shortcuts that I can perform with one hand, I don’t use it.)

If the hyperlinks do not work, or you see the words “Error! Bookmark not defined”, you will need to update all the links in this document. Type Command-a to select the entire document and press the F9 key (if you use OS 10.3 onwards, see the note in the following panel). If you have cross-references in your footnotes, open the footnotes window in Normal view and repeat.

To upgrade the table of contents only, click in the margin to the left of the first entry in the table of contents and press the F9 key (again, if you use OS 10.3 onwards, see the note in the following panel). 

	A note: Work-arounds for F9, now that it has been used by Exposé in OS 10.3 onwards

The F9 key is important in Word for updating fields — not only those in tables of contents but in cross-reference fields; and there are five variants involving F9 using different combinations with the Command, Shift and Option keys. But now, by default, the operating system takes precedence and allocates the F9 key to invoke one of the Exposé features. Here are some work-arounds: 

•
You can remove the allocation of the F9 key to the Exposé function, in which case it will again be available to Word X/2004. Since I prefer to retain Word’s defaults as much as possible for when I need to operate on other people’s computers or advise other users, I followed that option: I went to System preferences » Exposé » Keyboard and allocated Control‑F9 rather than F9 on its own (and similarly Control‑F10 and Control‑F11) to the Exposé functions. That left F9, F10 and F11 available to Word (F11 is also used in Word’s default set-up). 

•
Alternatively, you can devise any keyboard shortcut combination you choose (for example, Control-Option-Command-f, which is fairly easy to key, is available). Choose Tools menu » Customize » Commands » Keyboard. 

•
Or if you only want to update the contents of fields, you can just use Word’s alternative default, Shift-Option-Command-u, which — although clumsy to key — is also available in earlier versions of Word. 

A similar problem was introduced by the Spotlight keyboard shortcut (Control-spacebar) in OS 10.4; a discussion is on page 108. And again, F12 (Word’s default shortcut for Save As) is now over-ridden to open Dashboard — see page 109. 

And while you’re in the mood …

In Word 2004, since OS 10.3, the keyboard shortcut that is supposed to delete items from the work menu (Command-Option-[minus sign]) doesn’t work. Go to System Preferences » Keyboard and mouse » Keyboard shortcuts » Universal Access » de-select the Zoom tickbox (or if you want to have a keyboard shortcut for that command, don’t de-select it but click on the triangular arrow and assign another combination for Zoom Out). 

 


Sources of information on Word

Microsoft’s PDF in the Office folder

A PDF produced by Microsoft, "Discovering Microsoft Office", is included in the Office 2004 installation. It's located in Applications » Microsoft Office 2004 » Office » Help » Learn » Discovering Office. If you want to refer to it more than once (and you may not — it's only a very broad overview), it’s a good idea to make an alias of it and put the alias in a more accessible place. With the "Discovering Office" folder open, open the folder you've chosen to keep the alias in, then with the Command and Option keys down click on the "Discovering Microsoft Office" PDF and drag the alias to the latter folder. 

The Word MVPs’ website

I list this first as a source because it’s a very comprehensive website (http://word.mvps.org) run by the people who led the excellent Word newsgroups that used to be facilitated by Microsoft, and others devoted to Word on the Mac and Windows platforms. Among other things, it contains answers (at http://word.mvps.org/FAQs)
 to many frequently asked questions posed in the newsgroups. If you need comprehensive information on a problem, chances are that it’s at this website. 

Word websites

Microsoft’s website for Mac Office (http://www.microsoft.com/mac) includes a forum (http://answers.microsoft.com/en-us/mac/forum/macword?auth=1) where your questions can be answered — most likely someone else has asked them anyway.

The following websites also have good advice, and some have e‑mailed newsletters: 

Former Microsoft Office (Mac) MVP Diane Ross and MVP William Smith’s OfficeforMacHelp.com site (http://www.officeformachelp.com)

Daiya Mitchell’s website at http://daiya.mvps.org, which she describes as “A relatively random collection of articles and tips, eventually destined for the Word MVP FAQ site, and added to whenever the inspiration strikes me. A slight emphasis on long documents …”. Daiya’s article ‘So You Want to Write a Book with MS Word’ (http://daiya.mvps.org/bookword.htm) is excellent (even if you aren’t specifically writing a book).
Suzanne Barnhill’s website at http://wordfaqs.mvps.org — just remember that for most keyboard shortcuts, the Mac equivalent to “Control” on the PC is “Command”, i.e. the key with the apple and cloverleaf on it)

Shauna Kelly’s website at http://www.shaunakelly.com, and especially http://www.shaunakelly.com/word/concepts/introduction/index.html
the Editorium website (http://www.editorium.com)
— and back issues of their newsletter listed at: 
http://www.topica.com/lists/editorium/read/message.html?mid=1711556383
Charles Kenyon’s website at http://addbalance.com/word/index.htm
The Microsoft Knowledge Base

This is at http://support.microsoft.com, but the search facility will often not reveal the topic you want. It’s better to use Google Advanced Search (see below) and type this domain in as the URL to restrict your search to pages from the Microsoft Knowledge Base. However, it rarely has the answers I need.

	The main interface differences in Word on the Mac and on the PC

In considering which source of knowledge to consult, don’t be too concerned about the differences between Word on the Mac and on the PC; they are very similar. See the notes under “PCs and Macs, main differences in Word interfaces” on page 146.


The electronic Help feature

Most people find Word 2004’s electronic Help feature (see the Help menu) on the Mac is not very helpful because it is often brief to the point of being cryptic (and the Mac version hasn’t been nearly as comprehensive as the Windows version).
 But with Word 2011 it got much better. If you choose the online version you’ll get the benefit of continual improve​ments, whereas the inbuilt Help is only current as of 2011.

Because Word Help is underpinned by some advanced programming, it often gives more useful information if you key in, for example, “How do I insert bullets” than if you simply key “Bullets”. 

Books — Word/Office for Mac

Visual QuickStart Guide: Microsoft Word for Macintosh [year], Maria Langer, Peachpit Press is a good introduction at the basic level.
Macworld® Microsoft® Office [year] Bible, Bob LeVitus and Dennis R. Cohen, Hungry Minds Inc., is an example of a good reference book if you want to go beyond the “quick guide” level. 

In a similar vein is Office 2004 for Macintosh: The Missing Manual, Mark Holt Walker, Franklin Tessler and Paul Berkowitz, Pogue Press/O’Reilly Associates and, by the same publisher, Office 2001 for Macintosh: the Missing Manual, Nan Barber and David Reynolds. 

Books — Word for Windows

Books on Word for Windows are more comprehensive than Word for Mac books. There are not many major differences beyond the appearance of the interfaces (the most common differences are discussed on page 146), so I make good use of them.

The more detailed manuals available include Word for Windows manuals such as Que Corporation’s Using Word [year] series and Wiley’s Word [year] Bible series. The Word 2000 versions are better for Word 2004 users than the Word 2003 books. 

Word Pocket Guide, Walter Glenn, O’Reilly & Associates is an excellent, condensed, well-written, mainly question-based book for intermediate and advanced users of Word. 

Taming Microsoft Word is a good introductory book available in PDF form from the website of the author, Jean Weber (http://www.jeanweber.com/books/tameword.htm). Price is $15.00 Australian (about $10 US). Again, don’t be concerned that it’s for the Windows versions. Make sure you download the Word 2000 version, though, not 2002, if you’re on a Mac. 

At an advanced level, Word Hacks: Tips and Tools for Taming your Text, Andrew Savikas, has many good ideas. 

Bear in mind one disadvantage of most books about Word: possibly out of perceived or actual commercial pressures, they rarely discuss bad features, bugs and problems, especially ones that are persistent or wide-ranging in their effects. 

The working preferences and tasks that influenced these notes

I’m reasonably expert in Word, but not “super-expert” — just expert enough to maximise my productivity so that my company is more competitive in the market-place. Since the major part of my core business is preparing strategic plans and policies, which I develop collaboratively with other senior managers, the content of documents is the important characteristic. It’s essential that we develop these long documents with as little time wasted in formatting as possible, because our time is very valuable. Total cross-platform compatibility between Mac and Windows is also a very high priority. 

But I repeatedly interchange documents with colleagues who are not expert in Word, so I limit some of the things I might otherwise do — because many people are under-confident with the bells and whistles of the more recent versions of Word, and/or they do not have the time or interest to move much beyond using Word as a typewriter. So although I consider it well worthwhile to configure Word to my needs if that is going to save me time in future, I don’t make the documents themselves complex.

Several of my other working preferences are reflected in the notes. For example:

•
I prefer to configure Word to use the mouse, especially with menus, as little as possible — so I modify toolbars to my own needs, create new ones, and create keyboard shortcuts for frequently performed tasks. And since I use a trackball most often with my right hand (though I change to the left when using Word in a long session), my keyboard shortcuts lean towards using my free left hand. 

•
I use styles extensively because I create long documents and do not want to be bothered repaginating and re-formatting the document or compiling new tables of contents every time I send out a new version of the document. This is particularly important when you work between PC and Mac platforms and, even within the Mac platform, between computers with different printer drivers and settings. Furthermore, a document formatted mainly with styles is smaller and more stable than the same document formatted manually.

•
Similarly, I follow principles of “minimum maintenance formatting”, described in the appendix starting on page 161, to all but eliminate wasted time spent on re-formatting documents every time they are sent out — an important productivity factor. 

•
I like to have as much space as possible available on the screen for the document (usually with two pages side-by-side on a PowerBook with a 17-inch screen, and another two on a larger LCD screen connected to the PowerBook — but I use only the PowerBook when I’m away from my office). Therefore, I never use Word’s formatting palette (my tailor-made toolbars cover all that I need) and I normally limit the total length of toolbars to one row at the top and one at the bottom.

•
I don’t do any graphical work in Word documents (the screenshots in this document excepted), since Word is not optimised for graphics
, cross-platform graphic problems are endemic, and page layout software is designed for this purpose — so there is little coverage of this aspect. And I don’t very often incorporate Excel elements in Word documents.

•
My work does not usually require numbering of paragraphs, including headings, and since automatic numbering is a potentially major source of corruption I only use automatic numbering (hence automatic bullets) when I have to, and at the last possible moment. (The absence of automatic numbering in Bend Word to Your Will is one of the reasons it has been so stable, despite constant amendment and the presence of many cross-reference fields.)

In listing the foregoing examples, I’m not particularly advocating them (except for “minimum maintenance formatting”) — only pointing out that they underlie my personal use of Word, so that you have some insight into the factors that have shaped my writing of these notes.

Because the coverage of these the notes is not as broad as you will find in manuals, you may sometimes have to infer the reasoning behind some of my preferences. 

	If your working situation is different from mine — for example, you are in a tightly controlled corporate environment, or you don’t send many documents to people in other computing environments, or you don’t work on rather long documents — the priorities that shape your use of Word will be different from mine. Even in similar working situations, the configuration that people choose inevitably reflects their individual preferences — people use software to respond to very different objective and subjective needs. So I hope my ideas will prove most useful to you as thought-provokers and stepping-off points for your own ideas. The theme is: take your pick from what’s in these notes!


Configuring your Mac to minimise problems in Word

Word 2001

Part of the problem with recent versions of Word is that its file structure is indescribably complex, and creates dependencies from one part to another than grow geometrically with complexity of the document and the amount of editing that has been done. Many of the ideas in these notes seek not only to make the software more productive but to maximise its reliability in the face of this huge complexity. If you are in Word 2001, you can take some actions to reduce the problems, as follows (I’m not familiar with Word 98, but I do know that the memory requirements are much lower):  

•
Allocate more “preferred” memory to Word: the default setting of 10,000K (which is 10 megabytes) is totally inadequate for longer, more complex documents (especially with macros) and will almost inevitably cause problems. First check the amount of physical memory (RAM) in your Mac by clicking on the desktop and popping down the Apple menu to “About this computer”. Then quit Word if it’s open » go to the folder in which the Word application is stored » click once to select it » Command-i » “Microsoft Word info” window opens » pop down the menu next to “Show” and select “Memory”:

–
If you have 192 megabytes, or less, of physical RAM installed in your Mac, set “Preferred Size” to at least 24000K (that is, 24 MB) but preferably 48000K (= 48 MB). If you have more than 192 megabytes of RAM you can profitably set the preferred size as high as 80000K (= 80 MB). If you have, say, 512 MB or more of RAM and you work on very complex and/or graphics-rich Word documents, even 120,000K (= 120 MB) will be beneficial, provided you don’t operate other memory-hungry software at the same time.
 

–
Leave “Minimum Size” at 7000K — this is very important. 

•
Go to the Apple menu » Control panels » memory and ensure virtual memory is switched on and set at 1 MB more than the physical memory installed. 

•
If your Mac has file sharing turned on, it’s best to turn file sharing off if you are working on a document in which you may do more than 60 “Save” operations in the one session. After about 60 saves you may well get a “Disc full — cannot save …” warning (even though the disc isn’t full).
 

•
Reasonably often (every few days if you are using Word constantly), rebuild the desktop by holding down the Command and Option keys as you start your Mac (or by using software such as TechTool® Lite freeware by Micromat® Inc). Rebuilding the desktop that often isn’t necessary with other software, but some Microsoft Office settings files contain information from the system that can get lost from time to time, causing problems that can be quite difficult to diagnose. That’s why rebuilding the desktop figures prominently among the actions recommended to correct faults in Word — but you should seek to prevent such problems before they happen, so that they do not cause flow-on problems. 

All versions, including Word X and 2004

•
In the middle of your working day, quit Word and re-open it to refresh its settings files. Some experts recommend also quitting other applications and restarting your Mac, to refresh various other settings files. 

•
If you are using OS X, use Disk Utility to repair permissions now and then, and before and after installing new software, unless you have software such as Macaroni, which does it automatically and quite often. 

•
Never work on a document on a floppy disc or memory stick (“thumb drive”). Always drag such a document to your hard disc and open it from there. 

Not to do with Word’s complexity, but it’s so important that I’ll bring it up here: in Edit menu (Word menu in Word 2004) » Preferences » “Save” tab (in Word X and 2004 it’s Word menu » Preferences » “Save” button), make sure you de-select (i.e., remove the tick against) “Allow fast saves”. All experts make this recommendation very strongly, for reasons that will be covered later. 

The only other point worth mentioning about Word 2004 is that, because of the new ATSUI interface, which consumes huge amounts of computing power in complex documents, it is likely that 1 GB of RAM will be of benefit. This isn’t the amount of RAM you allocate to the application, as for Word 2001 and earlier, described above — in OS X that isn’t done — it’s the capacity of RAM in the memory chip(s) installed in your computer. 

There are other sources of problems in the more complex versions of Word that have been sold since version 5.1a — for example, with tables and Track Changes. Most are covered later in these notes — and usually with work-arounds. 

The notes

Recommended modifications to Word’s initial set‑up

	First step:  Back up the settings files immediately after installing Word

If you are reading these notes immediately after you have installed the Word software on your hard disc, you should save the Normal template and settings files described under the heading “Backing up the Normal template, other templates, and settings files” on page 49. That way, you will always have a copy of them in the form that they appeared during the first “out-of-the-box” installation. It’s good to know that in the event of serious problems occurring you can always return to these settings. This is discussed later in these notes.

I put the backup copies of the settings files in a folder I titled “MS prefs immed post-install” and to avoid confusion later on I renamed the “Normal” template to “Normal out of the box”. Then I copied the folder to an external hard disc and burned a CD‑ROM as well.
 

(If I knew then what I know now, I would also have saved a list of Word’s default keyboard shortcuts early on, for reasons mentioned in the panel on page 68.) 

Whether or not the above applies, when quitting Word after carrying out the modific​ations below, you should agree to save the Normal template. Then carefully read the notes on page 49. 


Increasing Word’s memory allocation (pre-OS X only)

If you are operating with Mac OS 9.2.2 or earlier and you haven’t done so already, the first action you need to take is to allocate more memory to Word, as described under “Configuring your Mac to minimise problems in Word” on page 26. 

To control Word, first dumb it down, then smarten it up

“Microsoft Word is like a pimply teenager that wears its hat backwards and plays music too loudly. One of you is going to be in charge. Your life will improve a lot if you decide that it’s going to be you.”
— Word guru, John McGhie
It’s widely recognised that, if you’re more than a casual user of Word, the first thing you need to do is to “dumb down” Word after you install it — “dumb down” only in the sense of removing most of the bells and whistles apparently put in by marketing people to impress first-time users. For most Word users, these features — such as offering to complete a date automatically by a process that isn’t quicker, or an animated paper clip commenting “It looks like you’re writing a letter. Would you like me to …” — are intrusive and unnecessary during regular use. 

The decisions you make in your initial setting-up can give you a good deal of control over Word. The extent to which you configure features will depend on how you prefer to use Word. Naturally, your preferences will change as time goes on — so it’s good that you can modify the settings at any time in the future. 

The next 10 pages contain my personal preferences for “dumbing down” Word’s default configurations to eliminate unwanted actions and activate features that add to your productivity. 

The huge advantage of Word is that it’s exceptionally configurable. Time spent on these features is usually a good investment in productivity, because you will benefit from them for a long time. Again, the features you find useful will depend on the ways in which you want to use Word.
 

Some of the modifications I have made to “smarten up” Word are listed along with the “dumbing down” modifications in the following pages, but most of them are described from page 54 onwards — in alphabetical order by main keyword, not in any order of perceived priority. 

Modify these settings to get Word to behave the way you want (well, partly)

As throughout these notes, my recommendations reflect my personal preferences for maximum control of Word — some of them based on advice by experts in the Word newsgroup at microsoft.public.mac.office.word. Feel free to make up your own mind as to which ones you choose. 

Important: First open a new blank document (Command-n) so that you can more readily save all of these configurations to your Normal template, Otherwise, you could inadvertently apply the configurations only to the document you have open, such as Bend Word to Your Will. You may prefer to print the next few pages — that means you can stay in the “Preferences” pane while you look through the recommendations, and you can write down what you have decided on where your preference differs from mine. 

	When you have finished making the changes you choose in this section, you should save the Normal template. You can do that by quitting Word (Command-q, not just closing the document or Command-w). You’ll be asked whether you want to save the Normal template unless you have opted otherwise. Or you can hold down the Shift key and choose File menu » Save All. Since you can do this at any time, and as often as you like, it makes sense to Save All a few times while doing the initial configurations suggested here.

It's a good idea to quit and re-start Word once you have finished your configuring, to ensure that your changes are written back and saved.


If you are setting up Word 2004, you’ll find there are some minor omissions in the following configurations. They are caused by having transferred my preferences from Word 2001 into Word 2004 rather than having set up Word 2004 from scratch. I’ll rectify this when I next set up somebody’s preferences. In the meantime, be assured that all the main preference choices have been covered. 
On the Word or Edit menu

	Word menu » Preferences, or Edit menu » Preferences, or what?

If you’re using Word X and 2004, choose Word menu » Preferences instead of the Edit menu » Preferences sequence shown in the following notes for Word 2001. On the PC it’s Tools menu » Options.


Edit or Word menu » Preferences » tabs (or buttons in Word X and 2004) as follows:

» “View” » under “Show” heading, tick Bookmarks ( [important for seeing bookmarks in this document], ScreenTips and Highlight, and set Field Shading to Always (allowing you to be always be aware when a field is a field, not ordinary text). Depending on whether you like non-printing characters to show or not, make appropriate selections under the “Non-printing characters” heading. Irrespective of your other choices, tick “Hidden text”. ( [important for this document.] Under the “Window” heading, make sure you de-select Live Word Count. This is an important though not self-evident choice — it is a rather memory-hungry feature that does not need to be on; you can always use Tools menu » Word count or make a toolbar button.
 

In Word 2004:

[image: image5.emf]
Incidentally, by far the most important of the non-printing characters is the “paragraph mark”. Whether you have them showing is a matter of preference, but you should be aware of the following. 

Paragraph marks contain up to 250 types of formatting information
. The last paragraph mark in the document sits just before the invisible “master section break”, which contains a huge amount of document-related formatting — including the file header (not to be confused with a “page header”), which contains the corruption. Often, if a document is corrupted, the corruption can be removed by transferring all but this last paragraph mark into a new blank document: see page 127. If you normally prefer to leave non-printing characters invisible but want to see the paragraph marks temporarily — for example, to make sure you don’t select the final one — you can always turn them on via the “Show/hide ¶” button, as shown on page 44. I normally key Command-a to select the document and then key Shift-[left arrow] to de-select the final paragraph mark.

» “General” » de-select all except “Background re-pagination”, “Include formatted text in Clipboard”, “Recently used file list” (9 entries), “WYSIWYG font and style menus”.
 (And you may prefer to de-select the latter as well, because at least in Word X there is a speed penalty. In that event, if you ever want to see the appearance of the fonts in the font pop-down menu, just hold down the Shift key before you pop it down.] I personally prefer not to have the Project Gallery open up at startup (it’s always accessible via Command-Shift‑p or by choosing File menu » Project gallery) — but it’s a matter of preference. 

Macro/customisation warning

The macro warning feature (see the “Warning” screenshot overleaf) was misleadingly called “Macro virus protection” until Word 2004. It is only a warning; it doesn’t provide virus protection beyond letting you disable any macro that might be present — which can, however, be useful, since a macro may or may not contain a macro virus. All it checks for is to see if the container that might hold customisations exists in the document; if so, the alert appears. The trigger could simply be a customised keyboard shortcut or toolbar, or there may be no customisations at all
; the macro warning tool doesn’t check to see what’s in the container.

If you have anti-virus software installed and frequently updated, it will have pre-empted any problem.
 My anti-virus regime is very high, because I need to be able to assure Windows-using colleagues at any time that I have not passed malware on to them.
 I can therefore comfortably turn this setting off. It would be a nuisance when working frequently on documents that contain macros — of which Bend Word to Your Will is an example. However, if I did not have this rigorous regime I would most certainly have it on, allowing me to opt for de-activating macros if I did not know the source of the document.     

In Word 2004, the setting for this preference is under “Security”:
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And this is the Word 2004 warning when you receive such a document:

[image: image7.emf]
( You may find this image has a light blue background; it’s a fault that has occurred recently in Word 2004.

	File menu » Properties allows a reader to see the location of the file, the name of the author and so on. In Word 2004 only, for a particular document you can enable “Remove personal information from this file on save” via Word menu » Preferences » Security » Privacy options. 

To go further than that, save the file as “web page” (not “web page filtered”), then set “confirm conversions on open” and re-open the file as Text. You can then read, and remove, any metadata you wish. Be sure to save it back as Text when you have finished. 

Another way of removing personal information is to create a PDF of your Word document.


De-selecting “Provide feedback with Animation” will speed Word up a little. “Provide feedback with sound” is a personal preference, as is “Show Project Gallery at Startup” (I usually start by double-clicking on an existing document or bring up a blank new Word document by keying Command–n, so I de-select “Show Project Gallery at Startup”. But this is an area in which people’s preferences differ greatly. I like it for looking up “recently” created or modified documents whose title I can’t remember for a Spotlight search — the “Recent” button in Project Gallery allows you to choose from “today” to “last month”, and earlier.) 

If you selected “Background re-pagination” at this stage, don’t expect to see it kicking in often in Normal view. Here’s the explanation: Microsoft disabled continuous background repagination as an over-arching preference for all documents in Normal view because it is too memory-hungry, and the aim with Normal is to be able to work more quickly than in Page Layout view. So repagination in Normal view occurs less frequently and often does not show accurately where the page breaks are. To repaginate accurately when in Normal view, I switch to Page Layout view (Command-Option-p or click the button that’s at the end of the horizontal scroll bar), wait for repagination to occur automatically (progress is shown in the status bar), and return to Normal view (Command-Option‑n). The pagination then shows more reliably. For a final check, Print Preview is the most accurate (for a description of both, see under “Print preview, advantage of” on page 148). 

In Word 2004:
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» “Edit” » de-select “When selecting, automatically select entire word” (I often select text from part-way through a word). Make sure you disable “Click and type” — it’s notorious for causing problems, especially with tables. 

In Word 2004:  
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Although I retained “Smart cut and paste” I de-selected all the options under “Settings”.]

» “Print” in Word 2004:
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[For some documents, I select the “Hidden text” box.]

In some circumstances I want the computer to update fields (e.g. the table of contents) and links before printing (the top two boxes above), but you don’t get any warning and usually I want more control of what happens. In any case, the settings can be changed when needed. 

» “Save” » Prompt to save Normal template. Some people find this prompt irritating, but even so I recommend this as an initial setting, till its significance becomes evident, since it may well alert you to something that would otherwise go undetected. I’m often glad of the opportunity to say “no” if I have botched up something I’ve changed. (If I change a style definition or AutoCorrect item I jot a note to myself that I’m going to be prompted, because it may be several days before I next quit Word.) But ultimately, it doesn’t matter much, does it? — because you will have recently backed up your Normal template, won’t you?  ;-)

Save AutoRecover info every 10 minutes. Whatever you do, make sure you do not tick “Allow fast saves” — this feature will probably cause document corruption and other problems, and with modern computers does not save the document more quickly in any case.

In Word 2004:

[image: image11.emf]
Make a note to do a “Find” command in this document for “Always create backup copy” — you may opt to follow John McGhie’s strategies, which would see you selecting this option.

» “Spelling & Grammar” » de-select “Check grammar as you type” (I find it’s more trouble than it’s worth, and it consumes a lot of memory). Select “Check grammar with spelling” if you prefer (I don’t — this also uses a lot of memory, and I prefer to correct spelling errors as I go, choosing from the options available by right/Control-clicking the word). Select “Ignore words in upper case” if you prefer (I don’t). 

In Word 2004:
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» Security: if you may not want to send out documents with tracked changes or comments, tick “Warn before printing, saving or sending a file that contains tracked changes or comments”.

If you require privacy in a particular document that you send to others, this is where — for that particular document — you would tick “Remove personal information from this file on save”.

On the View menu

If you have a PowerBook or iBook, you may want to make up for the lack of keys for End of Line (you have to use Fn + End), End of Document (you have to use Command + Fn + End) and similarly Start of Line/Document (ditto for Home). Choose View menu » Toolbars » PowerBook and a toolbar for these keys will appear.

On the Insert menu

Insert menu » AutoText » AutoText… » [but the resulting window is titled “Auto Correct”]: 

» AutoText » de-select tick-box “Show AutoComplete tip for AutoText, Address Book contacts and dates”. (Mainly because I find it annoying and the action to invoke the suggestion is usually no quicker than just typing the word, and especially because dates are not in the format I want.) 

(I make my own frequently used terms for Word to expand using AutoCorrect — see page 80.)

On the Format menu

Format menu » Style… » scroll to Normal and select » if the language that appears under “Description” isn’t what you want, click the “Modify” button » Format button » Language » select the language you want to use for Normal » OK » tick “Add to template” box, ensure “Automatically update” box is un-ticked » OK » Apply.  

If you leave the “Automatically update” box ticked, any change you make to a paragraph style will automatically be applied to all instances of that style — see page 152. There should be a warning because of the seriousness of ticking this option, but there isn’t. Notes on a separate but similar problem are on page 114.

[Not relevant to Word 2004]: If you don’t relish the prospect of the document being automatically re-formatted if you inadvertently key Command-Option-k, as I did once, you may like to remove this keyboard shortcut (the function still remains on the menu): Tools menu » Customize » Customize keyboard » from the “Save changes in” pop-down menu, select the template you want if other than Normal » “Keyboard” button » in the left-hand box, select “Format”; in the right-hand box scroll to FormatAutoFormat » in the “Current keys” box, select Command-Option-k » Remove » OK.

On the Tools menu 

Tools menu » AutoCorrect:

[Note that the AutoCorrect pane reflects settings for proofing tools for a particular dictionary language, in my case English (variants of English reflected in the installed dictionaries — for example, UK, US and Australian — are treated as the same language for this feature, although in most other contexts they are treated as different languages).] 

» AutoCorrect » de-select “Capitalize first letter of sentences”
 and possibly “Correct two initial capitals” (in some of the types of documents I work on, these are counter-productive — but if you only use Word to type letters etc these could be helpful, in which case you would keep the setting selected and nominate exceptions). Note that if you tick the box “Replace text as you type” (recommended — it allows you to nominate your own AutoCorrect terms later) you should be aware of the consequence of ticking “Automatically use suggestions from the spelling checker” box: if your vocabulary exceeds that of Word’s dictionary (including place names), words that are not in the dictionary will be changed without your being warned. The results can sometimes be hilarious — or tragic, depending on the end‑use of the document. I do not always have this setting ticked, even though it is convenient — but most of my work is checked several times before it goes out, so most of the time I make use of this feature.  

[At the time I originally wrote these notes in Word 2001, I had a fault — and so did some others in the MacWord MVP newsgroup — that caused a tick to be present in this box every time Word was opened. However, thanks to Beth Rosengard, one of the newsgroup experts, I established that the “Automatically use suggestions from the spelling checker” capability had not been re-activated, despite the tick having returned to the box. You can always test the situation by mis-spelling a word and observing whether Word corrects it or simply marks it as wrongly spelled. It may also be possible — though I never confirmed it — that you can correct this fault by quitting Word, finding the file “Word settings (9)”, removing it to the desktop and re-naming it, and either replacing it from a back-up from before the fault developed or (to cause a new default settings file to be created) re-starting Word. If the fault continues after that, you remove the new settings file and return the original file after restoring its name.] 

In Word 2004:
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This screenshot shows a few of the AutoCorrect ( [I type this as “autocorrect"] entries from those I have developed over time. Naturally, they reflect my own contexts. I started my customisations by deleting most of the entries that came “out of the box” — but first I preserved the original settings by taking the action described under “First step:  Back up the settings files immediately after installing Word” on page 29. Further details of the thinking behind my AutoCorrect entries (e.g. conventions I follow to upper-case frequently used abbreviations and expand keyed-in abbreviations to their full terms) are on page 81. 

» “AutoFormat as you Type” » de-select “Automatic bulleted lists” and “Automatic numbered lists” (I strongly prefer to have bulleting confined to certain styles, for reasons explained later). Also de-select “Ordinals (1st) with superscript” (this feature — as shown here: “1st” — may look fancy in dates but it looks ridiculous in other contexts, such as “the 20th step”; and it affects the line spacing). If you want to stop Word automatically hyperlinking to every web address you type, de-select “Internet paths with hyperlinks” (this is discussed on page 56). Over all, I prefer to leave only the “smart quotes” option selected. 

In Word 2004:
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» “AutoFormat »

Tools menu » Customize:

» Appearance » tick “Show shortcut keys in Screen Tips”. [“Show Screen Tips on toolbars” and “WYSIWYG font menu” should already be ticked. 

» Customize keyboard » under Categories, scroll to “Window and help” » under Commands, scroll to Word5Menus » remove Control-5 and Control-8 from the “current keys”. People sometimes hit these key combinations by accident and find their menus have changed, with such consequences as language options, the Formatting Palette and “break” options (on the Insert menu) being unavailable. 

On the Help menu 

If the cloying, intrusive Assistant is on and annoys the living daylights out of you, select “Turn Assistant Off”. Note that you gain access to Help via Help menu » Microsoft Word Help. 

If you have Adobe Acrobat, you should get rid of the toolbar it inserts in Word

Adobe Acrobat (not the free Acrobat Reader) installs a toolbar in Word which is unnecessary and which, in Acrobat 6 at least, has been reported as causing problems. Acrobat asks on start-up, if it doesn't find its add-ins installed in Office, if it can install them. One can click “No”, but the toolbars keep being re-installed (whether through user or program error).An excellent discussion and a simple work-around by John McGimpsey is at www.mcgimpsey.com/macoffice/office/pdftoolbar.html.
	Important action required now

If you choose for the moment not to alter the default toolbars or carry out other modifications shown in the following pages, make sure you do two things right now:

•
Back up the settings files — even though, if you are installing Word afresh at the moment, you will have backed them up in their “out of the box” form as shown on page 29. The instructions for backing the files up are titled “Backing up the Normal template, other templates, and settings files” on page 49. 

•
If you’re in OS 9 or earlier, re-build the desktop by holding down the Command and Option keys as you restart your Mac (or by using software such as TechTool® Lite freeware by Micromat® Inc). 


Further modifications

Language, default

Tools menu » Language… select language (e.g., in my case English (AUS)); click “Default” then confirm it.

For users of English other then American English: Notes on applying your default version of English to text received from another computer that has English (US) as the language are on page 142. 

Buttons, transferring between toolbars

Word has more than 1000 commands, but few of them appear on toolbars. In this section and the next, you’ll make decisions about which toolbar buttons you won’t need (which you’ll remove to save space) and which you’ll add to meet your particular needs.

	Why is it best not to alter the default toolbars?

Sorry I have to bring this topic up so early, before its significance becomes apparent, if you’re reading this for the first time. Unfortun​ately there’s no alternative, since you need to make a decision now, and the choice you make depends on how intensive your future use of Word will become and how efficient you want to be: are you always going to be content with what Microsoft has provided, or are you going to “bend Word to your will” and make it much more efficient? It’s a bit like buying your first computer — you don’t really know what you need until you’ve bought the computer and become familiar with it!

Word is enormously configurable. Once you’re aware of this, and how easy it is to alter the default version of Word to suit your personal needs, several subjects (including toolbars and styles) suddenly become very significant — and the effort you put into under​standing them will be well rewarded by reduced frustration and increased efficiency.

The suggestions in the following section cover two alternatives for toolbars. One is to modify the Standard toolbar, which Word displays of its own accord when a new document is opened, and any of the others you can open from the View » toolbars menu (I call these respectively the Standard toolbar and the “default toolbars”). You do the modifying by removing buttons you don’t want (to save space on the screen) and adding buttons that suit your needs better. (Word’s product developers and marketing people have made decisions as to what buttons are displayed, but inevitably they have to take account of a very wide range of users. At the very least you should consider saving space by getting rid of buttons such as copy, open and print, since keyboard shortcuts are quicker for these actions and are uniform across all Mac applications.)

The second alternative is to leave these default toolbars alone and to create new personal toolbars that contain the buttons you want — most or many of them being copies of buttons on the default toolbars. After creating the new toolbars you close the default toolbars and will never open them under normal circumstances. 

Both alternatives may seem to amount to the same thing — but there are two major advantages to the second option. First, at some future date you can easily transfer any personal toolbars you create to another template or document. That’s important because Word does not permit you to copy to a different template
 any default toolbars that you have amended (“customised”). So when you become comfortable with creating your own templates for special purposes (and if you work on long or complex documents and want to be efficient, you will), if you have modified the Standard toolbar and other default toolbars you will be unable to take advantage of the modification work you have done on them. More importantly, if/when your Normal template becomes corrupted (not a rare occurrence, unfortunately) you will have to re-configure the default toolbars from scratch. By contrast, it’s easy to copy your personal toolbars over from a bad template using the Organizer.

The second major advantage to creating new personal toolbars is that — even if you configure your documents to minimise corruption — customising and editing of commands, keyboard shortcuts and toolbars may well, in time, corrupt the Normal template. 
 

The only downside to creating new personal toolbars is that you have to learn a couple of new skills now rather than later. I didn’t discover this option until I was “well down the line”, and had to retrace my earlier steps. If someone had told me earlier, I would have done this straight away.

The following notes therefore describe the second option, of creating new personal toolbars and closing the default toolbars. The first option is covered in two yellow panels. 


When you make your own toolbar(s), there is no need to make the same differentiation between the default toolbars that Microsoft does — you can make any number and type that you want, containing any buttons you choose. I only kept some similarities because I sometimes have to use other people’s computers, and I then need to remember where something is located in the default version. After I made my own versions of the Standard and Formatting toolbars, all my subsequent toolbars tend to be differentiated by their specialised purposes. Therefore, so that I can choose which ones are relevant to the particular job I’m doing and still only take up a single row of toolbars at the top and bottom of the screen, the toolbars are many and small. 

A new Standard toolbar

The default Standard toolbar, from which we will copy buttons to a personal, “substitute” toolbar, looks like this (and will always retain this appearance because you have decided to copy the buttons from it, not remove them): 
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If this toolbar isn’t visible on your computer, choose View menu » Toolbars » Standard toolbar. If more than one toolbar is visible and you want to check which is the Standard toolbar, move the cursor over the Move Handle (Microsoft’s term for the title bar); you’ll see the toolbar’s title in the yellow Screen Tip that appears.

[Word X and 2004: Toolbars don’t show Screen Tips, so you have to go to the View menu » Toolbars, guess which it might be in the menu list, click on that and see whether the toolbar has disappeared. Repeat the action to make the toolbar re-appear.]

First, make a new toolbar and save it in the Normal template:

•
Tools menu » Customize » Toolbars. 

•
Click New. 

•
In the Toolbar name box, type the name you want (such as the initial of your first name followed by a space then “standard”)

(Note: I prefer to name a toolbar that I’ve attached to a template differently from one on the “Normal” template or attached to a specific document, so that I can tell where it comes from just by rolling my mouse over the toolbar’s “grab handle” (when a yellow “screentip” title appears) [not in Word 2004]. Since the significance of this won’t be apparent till later in these notes, suffice to say that even in a document based on the Normal template (i.e., any new blank document), putting your initial as the first element in a personal toolbar’s name is a good idea because it distinguishes your toolbar from a default toolbar.) 

•
In the Save in box, click the template you want to save the toolbar in (in this case it’s Normal).

•
Click OK. The new toolbar is displayed on the screen.

Then drag copies of buttons off the Standard toolbar on to this new toolbar:

•
In Word X or 2004, choose Tools menu » Customize » Customize toolbars and menus.

•
In Word 2001, just hold down the Option key and drag.

	If you decided not to make your own substitutes for the default toolbars as a result of the discussion on page 42, instead of the above actions you would choose Tools menu » Customize » Customize toolbars/menus, then drag off the default Standard toolbar any buttons covered by commonly used keyboard shortcuts (e.g., open, cut, save).



Vertical separator lines: Once you have put the new button on the toolbar, if you want a vertical separator line between this button and the one to the left of it, hold down the Command key and drag the new button a little to the right. If you want a vertical separator line between the new button and the one to the right of it, hold down the Command key, click on the “old” button and drag it a little to the right. To remove a separator line, hold down the Command key, click on the button to the right of the line you want to remove, and drag it a little to the left. (If you find it difficult to nudge the buttons the tiny amount required, use this method: hold down the Control key and click on the button to the right of where you want a vertical separator line » select “Properties” » tick “Begin a group” » OK.)

My personal substitute for the Standard toolbar looked like this after buttons were installed, before I went to the next stage, although I removed more later to make way for buttons I used more often:
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Clicking on the button that shows a pilcrow (which looks like a backwards “P” 
) will toggle (i.e., alternate between visible and hidden) the paragraph marks and all other non-printing characters in the document that you have set in Word menu » Preferences » View » Nonprinting characters. Command-8 achieves the same thing. 
The Zoom pop-down box (second button from the right) shows the size I used to prefer for displaying documents on my glass screens with body text in Times New Roman font. To display at, say, 110% in an open document, click in the pop-down box and type “110” and hit the Return key. 125% is also available as a default magnification. (Nowadays, LCD displays, especially on laptops, invite a larger magnification if you use Times New Roman, but not if you use Arial; see page 17.)

If you needed more space, you could remove the buttons between the Zoom pop-down box and the rightwards-pointing “Re-do” arrow, other than the pilcrow button. I’ve never used them. But many people do — and you should expect to replace lesser-used buttons with more frequently used buttons as your practices evolve.

I then closed the default Standard toolbar by clicking on the small square on the Move Handle, and have not used it since. 

The new toolbar, after buttons were added, is on page 47. 

A new Formatting toolbar

The default Formatting toolbar, from which we will similarly copy buttons to a personal toolbar, looks like this (and will retain this appearance because the buttons will be copied, not removed): 
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If this toolbar isn’t visible, choose View menu » Toolbars » Formatting toolbar. If more than one toolbar is visible and you want to check which is the Formatting toolbar, move the cursor over the Move Handle; you’ll see the toolbar’s title in the yellow Screen Tip that appears.

Make another new toolbar and save it in the Normal template:

•
Tools menu » Customize » Customize toolbars/menus. 

•
In the Save in box at bottom left, click the template you want to save the toolbar in (in this case it’s Normal).

•
Click New. 

•
In the Toolbar name box, type the name you want (such as the initial of your first name followed by a space then “formatting”). 

•
Click OK. The new toolbar is displayed on the screen.

Next, choose Tools menu » Customize » Customize toolbars/menus, hold down the Option key and drag copies of buttons off the Formatting toolbar on to this new toolbar. Click OK when finished. 

	If you decided not to make your own substitutes for the default toolbars as a result of the discussion on page 42, instead of the above actions you would open the “Ruler” toolbar, choose Tools menu » Customize » Customize toolbars/menus, then drag off any buttons you won’t have much need for.



My personal Formatting toolbar looked like this after buttons were installed from the default Formatting toolbar (I changed the order of the three left-hand pop-down menus in the process — just personal preference):
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I first kept the “Font Size” button on the toolbar for when documents obscured the Formatting palette, but now I don’t have the Formatting palette showing at all — I have all I need on my personal toolbars.

The advantage of having the Font pop-down (the one showing “Times” in the graphic above) on this toolbar rather than just using the main Font menu is that fonts used in the current document appear at the top of the list.

I closed the default Formatting toolbar, and have not used it since.

I then opened the “Ruler” toolbar
 (View menu » Toolbars » Ruler) and copied what I wanted off it — some line spacing buttons and a “No space before the paragraph” button. This was the result:

[image: image19.png]



I then closed the default “Ruler” toolbar.

( This and other screenshots of default and interim toolbars were taken when I used Word 2001. They differ subtly from the way they (i.e., exactly the same toolbars) now look in Word 2004. The toolbars above show Times (a Mac font) as the font for style “bt”. In Word 2004 and onwards, there are considerable advantages in having Times New Roman (a Microsoft font) as the default font; more information is in the section starting on page 136. But I’ve moved on: when screen resolutions became finer on Mac laptops I found it more comfortable to have Arial as my body text font.

The new toolbar, after buttons were added, is on page 47. 

Maybe there are other buttons you would like to add from other toolbars — you can do that now or later. Preferably, limit the length so that your personalised Standard and Formatting toolbars together occupy only one row. I prefer to make more (shorter) toolbars so that I can open only some of them at any one time — such as when I’m “on the road” with a 15‑inch PowerBook, which has less screen space than my usual 17" one. 

You may want to save the Normal template after you have made some of these changes. To do so, hold down the Shift key before pulling down the File menu, then select “Save all” — you’ll be prompted to save the template too. (If you forget, you will be prompted when you quit Word if you set the preference as recommended under “Modif” on page 30). 

I also copy any new toolbar that I produce to a “storage template” whose only purpose is to hold toolbars: Format menu » Style » click “Organizer” button » “Toolbars” » transfer by opening the appropriate file.

Now we’ll look at adding more buttons — ones that aren’t on other toolbars. 

Buttons, adding to toolbars from the Tools » Commands lists

We’ll add the remaining buttons to your new toolbars via the Tools » Commands menu. My suggestions are the buttons I have found handy over a period, as I have refined the way in which they serve my needs — but base your choices on your own needs (in the expectation that your needs will change too).

The following configurations suited the screens on my 15" and 17" PowerBook and MacBook Pro laptops. For smaller screens, consider further reducing the number of buttons on the toolbars so that they take up only one row at the top of the document. For recommended placement, see “Positions of toolbars” on page 48. (Putting the Dock on the side of the screen also saves valuable vertical space:  in the Finder, choose “System preferences” from the Apple menu then choose “Dock”.)

	For the three changes to the personal Standard toolbar and Formatting toolbar below:

Do this in each case

Split the screen (Command-Option-s) and move the Resize bar up so as to leave only the following paragraph in the top pane; leave it visible while scrolling through the specific modifications that follow.

Tools menu » Customize » Customize Toolbars and menus » Commands [make sure “Normal” is in the “Appears in” pop-down window at bottom left] » Categories: [scroll to menu that applies] » [scroll to appropriate command]. Drag button to appropriate toolbar and drop it.
 


Adding to personal Standard toolbar

Add “Word count” button: 

Follow the steps in the notes under the “Do this in each case” heading above. Actions in this case are as follows. In Category scrolling window: select Tools. Commands: select “Word count”, near the top of the list. Drag to the Standard toolbar and drop to the left of the “Tables and Borders” button.

If you want to be able to calculate selected numbers, as described on page 160, do the same for a “Tools Calculate” button, which is in the same location. 

My personal Standard toolbar now looked like this:
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Over time, my toolbars evolve by Darwinian selection. This is the current manifestation:
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( This is the first screenshot in this section of a toolbar from Word 2004; the earlier ones were taken when I made the changes described, in Word 2001

[The button with the “square + dots” icon opens the Borders and Shading window; “no break” invokes Table menu » Table properties » Row » de-selects “Allow row to break across pages”; “140%” and “125%” buttons invoke the most common viewing percentages, saving having to select from the pop-down at left.]

Adding to personal Formatting toolbar

Add “Format styles” button: [image: image22.png]



The existing pop-down menu has styles formatted as WYSIWYG; it takes time to scroll through it because of the formatting and being listed out of alphabetical order. To work around these disadvantages, we’ll install a button on the Formatting toolbar to go straight to the Style window. The button performs the action Format menu » Style … (I applied the keyboard shortcut Command-t to do this as well; I didn’t need it for the default “Hanging indent” because I always apply that by styles). When the styles appear in the Styles window that opens, you can either scroll or get to the style name more quickly by typing its first letter and — if necessary — using the arrow keys.

Follow the steps in the notes under the “Do this in each case” heading above. Actions in this case are as follows. In Category scrolling window: select Format. Commands: scroll to Style button (not the button with a pop-down window that appears immediately; scroll about 80% down and you will see “Style” with “AA” on the left); select; drag to the Formatting toolbar and drop it to the right of the styles pop-down menu. 

Add a “Reveal formatting” button (which allows you to see what formatting of text results from styles and what results from manual formatting without having to go to the View menu): 

Follow the steps in the notes under the “Do this in each case” heading above. Actions in this case are as follows. In Category scrolling window: select View. Commands: scroll to Reveal formatting button, 2nd from bottom, and select. Drag to the Formatting toolbar and drop to the left of the “Align left” button. I wanted to save space, so I changed the name to “Show format” by right/Control-clicking the button, and choosing “Properties”.

A keyboard shortcut can also be applied for “Reveal formatting” at this stage if desired (I use it frequently): 

Still in Commands pane » Keyboard … button » Category: scroll to View menu and select. Commands: scroll to Reveal formatting and select » consider any keyboard shortcuts shown in “current keys” field » if new keyboard shortcuts are wanted, put I‑beam pointer into field “Press new shortcut key” » I typed Control-Option-f (previously unassigned) » Assign » OK. 

My personal Formatting toolbar now looks like this:
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I then quit Word and agreed to save the Normal template. I immediately backed up the template.

	Now you have the hang of this, it’s only one more step to make other special-purpose toolbars — for example, to apply selected styles and formatting. By quickly configuring my own buttons, I save a huge amount of time. See page 183 for more information.

I have an LCD screen next to my PowerBook when I’m in my offices. One disadvantage of a second screen is that you have to make a lot of mouse movements to reach the toolbars on the PowerBook screen — albeit a Kensington Turbomouse, with a large ball that allows the cursor to be “tossed” over large distances, lessens the problem. Once I had shaken down the toolbars and buttons I needed in Word, I created a second set of toolbars, identical to those on the PowerBook, for the second screen — plus a button to hide them when I want more screen space. They automatically appear when a second screen is connected — very clever!  Further information is in Appendix D: Making buttons for formatting shortcuts.


Positions of toolbars

Because I often have two documents side-by-side on the screen, I prefer to keep my personal Standard and Formatting toolbars in one row across the top — with my Standard toolbar to the right. 

Similarly, I limit my other home-grown toolbars to one row at the bottom. Consequently, I tend to make additional toolbars (i.e., other than my substitutes for the Formatting and Standard toolbars) quite short, so I can close them and put other (equally short) toolbars in their place. That provides more flexibility.

Of course, you can put all or any toolbars at the top, bottom or sides. On the rare occasions I need maximum vertical space for a document, I put the toolbars at the sides after making them vertical by dragging the bottom right-hand corner clock-wise. 

For occasional operations specific to single documents, such as indexing, I put toolbars for those operations in the middle of the screen, next to where the operation is carried out.

Scrollbar, horizontal, and status bar, removing from view

If screen space is limited, try this: 

•
To reduce the size of the document window, drag on the bottom right-hand corner: [image: image24.png]



•
To remove the scroll bars and status bar (below the horizontal scroll bar), choose Edit menu » Preferences … » View » de-select them (but note in relation to the horizontal scroll bar that you will also lose the tiny buttons for normal view, online layout view, page layout view and outline view, and in relation to the status bar you’ll lose the ability to see the page number and to quickly check whether Track Changes is on).
 

You can also take this opportunity to specify a value for Style area width (e.g., 2.2 cm) if you decide to display the Style area — see page 109.

Menu item, adding to menu

This example adds “New Blank Document” to the File menu.

Tools menu » Customize … » Commands [make sure “Normal” is in the “Appears in” pop-down window at bottom left] » Categories: [scroll to menu that applies — “File” in this case — and click to select it] » [scroll to appropriate menu command — “New” in this case]. Drag the New item to the File menu in the temporary row of menus that has appeared above the document’s window. Drop it in the desired position on the menu (but if a separator line is wanted, move the button slightly down before dropping) » OK. 

Backing up the Normal template, other templates, and settings files

This is a very important subject. 

One of the bugbears of Word (Mac and PC) is that the code is now very complex indeed — too much for our own good, many users will say, but then, many of the extra features do take out the drudgery if you take the time to find them.

Which files to back up

Word 2001

Frequently back up these: 

•
the Normal template (Microsoft Office 2001 » Templates);

•
any other templates you may deliberately set up — which you’ll do once you realise the advantages
;

•
the following files in System Folder » Preferences » Microsoft
:

–
Word Settings (9), 

–
Microsoft Office settings (9), 

–
Proofing Tool preferences, 

–
MS Office ACL [English], 

–
the Custom Dictionary; and

•
the following file in System Folder » Preferences: PPC Registration Database.

Word X

Some of the following will apply, but I have no personal experience of Word X. See http://word.mvps.org/Mac/BackupYourWork.html and http://word.mvps.org/Mac/backupprefs.html

	Word 2004 

In OS X, file organisation relevant to backups is quite different from that of OS 9, which allows us to organise them to best advantage as follows. 

If you’re in a multi-user or corporate environment, however, some of these practices will need to be altered. 


Word 2004 settings files — keeping the default set-up

If you haven’t made any important changes to your custom dictionary/dictionaries or unformatted AutoCorrect entries since you last backed up, you may only want to back up your templates (that is, Normal plus any others you have created), because these files contain almost all settings. The default locations of these files are shown in the first two bullet points in the following list. 

The full backup comprises these files:

•
in [hard disc name]/Users/[your user name]/Documents/Microsoft User Data — the Normal template;

•
in [hard disc name]/Applications/Microsoft Office 2004/ Templates/My Templates — the location that you are most likely to have agreed to put any other templates you may have deliberately set up; 

•
in [hard disc name]/Applications/Microsoft Office 2004/Office/Startup/Word/ (and …/Excel/ and …/PowerPoint) — any templates you may have put there; and

•
in [hard disc name]/Users/[your user name]/Library/Preferences/Microsoft — at least the following files (display by Date Modified to make sure you select all the recently changed files):

–
the .plist files you’ll see there,

–
Custom Dictionary, 

–
Microsoft Office ACL [English]. ( And for any other languages you use
–
Microsoft Office settings (11), and

–
Proofing Tool preferences. 

Word 2004 settings files — after moving key files to a safer location   
The following involves a once-off move to a single, more convenient location (the Microsoft User Data folder) for the folders shown above. Having only one folder to back up reduces the likelihood of making a mistake if you don’t use automatic backup software, or if you want to do a manual backup immediately after making some major changes to settings.
 

First, quit all Office applications. After they are closed, close the Database Daemon using the Activity Monitor. Then carefully follow the actions in the following table …
Do this just once

	Go to …
	… then do this
	… then this
	… and this

	[hard disc name]/Users/ [your user name]/ Documents/Microsoft User Data folder.
After that folder has opened, key Command-n to open a new window; now navigate within it to [hard disc name]/Applications/ Microsoft Office 2004/Office folder.
	Select the Startup folder within this Office folder.


	Drag it into the Microsoft User Data folder (that is, the folder in column 1 that you first opened).
	Select the Startup folder in its new location and key Command‑L to create an alias of it. Then drag the alias to where the original was (that is, the Office folder in column 1 that you opened).

	[hard disc name]/ Applications/Microsoft Office 2004/Templates folder.
	Select the My Templates folder.
	Ditto.
	Select the My Templates folder, key Command‑L and drag the alias to where the original was.

	[hard disc name]/Users/ [your user name]/Library/ Preferences/Microsoft.
	Select the Custom Dictionary file.
	Ditto.
	Select the Custom Dictionary file, key Command‑L and drag the alias to where the original was. Delete “ alias” from the file name.

	Click back into Word, then choose Word menu » Preferences » File locations » User templates » Modify. 
	Navigate to [hard disc name]/Users/ [your user name]/ Documents/Microsoft User Data folder.
	Select the My Templates folder and click the Choose button.
	Click the OK button. 


Then do this for each backup

If you use automated backup software, the folders will be backed up when you nominate. But if you back up manually, you’ll find it easier not to have to dig down to the Microsoft User Data folder. This folder can be many megabytes in size, so the method for doing this may depend on what you are backing up to and whether the archiving process described in the following table (which reduces file size to about half) is relevant. Here are the alternatives:

1.
If the size of the backup isn’t a problem, create an alias of the Microsoft User Data folder in [hard disc name]/Applications so that you can right/Control-click on it to go direct to the original folder. A title with two spaces at the beginning, such as “  Alias of fldr for Word backup”, will ensure it stays at the top of the list.

2.
If you need to keep the size of backups down, create a new folder in [hard disc name]/Applications. In this folder, place aliases of the specific files in the Microsoft User Data folder that you need to back up. By right/Control-clicking on these aliases you can go direct to the actual files. 

3.
An alternative to method number 2 is to follow 1 and to apply colour labels to the files in the Microsoft User Data folder that you usually back up.  

Then tell Word to save new templates that you make into the new location by choosing Word menu » Preferences » File locations » select User Templates » navigate to the [hard disc name]/Documents/Microsoft User Data folder. 
If you have OS 10.3 or later, you can quickly create a compressed archive file

	Go to …
	… then do this
	… then this

	[hard disc name]/Documents/ Microsoft User Data
(or use the aliases described above)
	Select the folder » File menu » Create Archive
	Move the archived file that is produced (= name of the original item + “.zip” extension) to the backup location


	Backing up documents in OS X is easier than in OS 9
As a separate topic from backing up the settings files referred to above:  backing up your documents in OS X is easier than in OS 9 if you have stored all of them in the [hard disc name]/Documents folder. All you do is back up that folder in its entirety.


More about backing up

For many good ideas, see http://word.mvps.org/Mac/BackupYourWork.html (the article covers many of the following points; take your pick, but for your own good, follow it if you don’t already have a thorough backup regime). Also see http://word.mvps.org/Mac/backupprefs.html

You should back up the files mentioned immediately after you first install Word. With subsequent backups, you should ensure you don’t over-write them with more recent backups of the same name. That way, you will be able to go back to any configuration you choose — without having to rebuild your AutoCorrect entries, customised toolbars etc. I go to the file in the Finder (for example, in the Templates folder for the Normal template), then click once to select it, key Command-d to duplicate it (it’s then titled — for example — “Normal copy”), then I substitute today’s date for the word “copy” in the title before dragging a copy of that to the backup medium. Then I delete that [dated] copy from the Templates folder.

Here are the additional occasions on which you should back up straight away:

•
When quitting Word after carrying out modifications to the Normal template, you will be asked if you want to save the template — if you have put a tick in the box in Edit menu » Preferences » Save. Agree to save it. (If you want to save the Normal template immediately after you make such changes, you can do so by holding down the Shift key while choosing File menu » Save All.)

•
Then go to the Normal template and copy it to a medium other than your hard disc. (I add the date after the file title so that there’s no chance that I’ll over-ride the file during the subsequent back-up: for example, Normal 20071125). Do this straight away. Note that the Normal template on the Mac must not have a “.dot” suffix — if you do add one, Word will not recognise it but will generate a new Normal template, which at least will be confusing and at most, if you have customised Normal, will discard your changes. 
•
After making any unformatted changes to AutoCorrect, you should back up MS Office ACL [English].

In addition to the above, I back up all my templates and these settings files once a week.

Make sure you save the backups to something other than your main hard disc and store them well away from your computer, free from risk of fire and theft. In addition to daily backups I do weekly backups (using SuperDuper), which I store in a different building. When working continually on complex documents I back up to a memory stick every hour or less, and for major projects I simplify that by using the Martian Lifeboat application, which allows me simply to insert a memory stick (specifically dedicated to that project), let the application do its work, and eject.

If you haven’t backed up your Normal template and you need to rebuild one because of problems that have developed since you last backed up, you don’t have to rebuild the template from the beginning — see under “Transferring customisations from a damaged Normal template”, below. However, if Word’s settings become corrupted and you haven’t backed the settings files up, you may need to re-build the settings from scratch.

What the Normal template and settings files contain

Word creates each new document by copying the Normal template (which is essentially a scratchpad) unless you specify a different template to be attached to the document. Corruptions in the Normal template not only can make Word unstable, they can be passed on to every document you create. The Normal template (and any other templates you may have deliberately created) contains, among other things:

•
macros, 

•
styles, 

•
keystroke assignments (for keyboard shortcuts), 

•
custom toolbars, 

•
AutoText entries, and

•
formatted AutoCorrect entries. 

The file “Microsoft Office ACL [English]” (or “MS Office …” before Word 2004) stores unformatted AutoCorrect entries. 

“Word Settings ([number of your version goes here, such as 9 or 11])” files contain a small number of things like most recently used files, printer defaults, background save options, Work menu items, etc. (It also contains information from the system as well as information about Word, so you should rebuild your desktop quite frequently — see page 26 — to ensure that the file contains current information about your system.)

The PPC Registration Database file tells the Office applications at start-up where to find all the files they need, and contains many settings too. 

What to do if you have a damaged Normal template

Testing the template

To see if your Normal template has been damaged, quit Word, go to where the template is (see above) and rename it — e.g. to “Old Normal”. 

When you restart Word, a new Normal template will be created from the built-in default settings. If Word then runs normally, your old Normal template was corrupt. If the problem continues, you can delete the new Normal template, re-rename the old one and put it back.

Transferring customisations from a damaged Normal template

Unfortunately, you can’t transfer your personal keyboard shortcuts (page 76 refers) if the Normal template is damaged; that’s why it’s a good idea to make a note of them somewhere. Or consider having very few modifications to the Normal template — see “Some advantages of attaching a document to a template other than Normal” on page 104. 

Likewise, you cannot copy toolbars that you did not create. Neither will Word allow you to copy the built-in toolbars, because to do so would corrupt the target template. If you customise toolbars, you should always begin by creating your own (see page 42). 

However, you can transfer your customisations (toolbars, macros, styles) over from a damaged Normal template to a new Normal template (or anywhere else) using the Organizer. For instructions on how to do this, see the “Restoring Your Customizations” section of the article at http://word.mvps.org/Mac/MacWordNormal.html
See also the notes on page 42 concerning modification of toolbars.

You cannot delete some built-in styles because they are a required part of the Word file structure. You can overwrite them by copying over the top of them. 

Be careful copying macro project items: If you did not write a macro, and you do not recognise it, do not copy it. This is where some viruses store their nasties.  

Modifications later on (in alphabetical order by main keyword)

AutoCorrect

AutoCorrect is an excellent feature. I use AutoCorrect a great deal so that I can type some of my work in “shorthand” — for example, to save having to type long terms that you frequently use, to convert lower case terms to upper case, and to save keystrokes with other characters such as bullets and em dashes. A few of these terms are listed under “AutoCorrect ” on page 80. 

However, AutoCorrect can do some irritating things in its default configuration. Some suggestions are on page 38 under the heading “On the Tools menu”. 

If AutoCorrect does not work

AutoCorrect is specific to the particular language in use
. If your language is English (AUS) [ = Australian] or English (UK) and you find that AutoCorrect does not work, the most likely cause is that the text you are working on has been copied from somebody else’s document and it is manually formatted as English (US). To fix it, there are two options:

•
If all words in your document are to be in the same language, select the whole document (Command-a) » Tools menu » Language » scroll to the language you use » OK

•
If some words in your document are to be in a different language, key Command-Shift‑h
 » clear the top field of any text from a previous search then pop-down Format » Language » scroll to English (US) » OK. Then clear the bottom field of any text from a previous search then pop-down Format » Language » scroll to English (AUS) » OK. Click Find Next button » Replace as required. 

In Australia, if your document contains material from many sources, you may be surprised by the amount of US-English-formatted text you have in it! 

Date and time, changing format of in headers etc

To get the date (e.g. in headers
) to display in the form “xx December 2003” rather than “December xx, 2003”:

Insert menu » Date and time … » select the x December 2000 option. Click “Update automatically” to have the document display the date on which the document is opened (in Word 5.1a this was called “print date”, but in later versions a distinction is made between updating the date when a document is opened and updating when it is printed; see page 178 of these notes).

Document map

Using Document map isn’t recommended — see the notes on page 132. 

Headers and footers

Also see the notes under “Section properties” heading on page 59, e.g. for properties such as whether a section starts on a new page, has a different header or footer on the first page, or has different odd/even headers or footers (Format menu » Document …).

To set up headers and footers

View menu » Header and Footer » use buttons on toolbar that appears.

Important: If you want a header or footer to have wording different from that of the previous section’s, make sure “Same as previous” is removed before you type the new words. This is achieved by clicking the [image: image25.png]


 button on the Headers and Footers toolbar. Otherwise, the new wording you type will also be applied to the header / footer in the previous section — and it will stay there if you remove the “Same as previous” feature after the new words have been typed.

Page numbers in headers and footers

[Page numbers can be applied without using headers or footers (via Insert menu » Page Numbers …) — a text box is inserted instead.
 However, incorporating page numbering as part of the header or footer, as shown below, makes it much easier to control the formatting via styles, since this method inserts a normal page number field (the appearance of which can be changed globally via styles) rather than a text box (which can’t be changed via styles).]

To apply page numbers to headers or footers:

View menu » Header and footer » type up the header or footer and add the page number via the “#” button on the toolbar that appears.

Important: [Not applicable to Word 2004]: If you include the word “Page” before the page number, then after applying page numbers in the headers or footers, check in case the space between “Page” and the page number has disappeared. If the space has been deleted, this will be a consequence of having “Smart cut and paste” switched on (Edit menu » Preferences … » Edit). But smart cut and paste is so useful in other regards that it’s better to just check for this idiosyncrasy. 

To continue page numbering shown in the header or footer, or to re-start at 1

In Page Layout view, click in the section in which you want the numbering to apply or change, then double-click on the header or footer (or View menu » Header and Footer) to open the small Header and Footer toolbar. On this small toolbar, click on the “Format page number” button (the right-hand one of the three page-number buttons): [image: image26.emf]
Then click “Continue from previous section” radio button or specify the page number to start at » OK.

This is the window in which you can also specify whether the page number is shown as “i” or “1” and so on.

To put a portrait-position page number on a landscape page

See http://word.mvps.org/FAQs/Formatting/LandscapeSection.htm

To quote from the article: “The solution to this problem depends … to some extent [on] how much trouble you’re willing to go to (and what you consider trouble) and whether you need to keep the entire document in a single file.”

Hyperlinks: de-activating hyperlinks of web URLs and e-mail addresses

In Word’s default configuration, it can be a nuisance if you accidentally or purposely drop the insertion point in a website URL or an e-mail address only to find yourself transported to the Web. Some documents I receive are infested with many hyperlinks on some pages, such as a hyperlinks to organisations’ websites every time the organisations’ names appear. That’s not to say that hyperlinking aren’t useful; the link on the cover of this document (to where you can download the latest version) would be a good example. 

To turn off active formatting of a hyperlink, select the hyperlink by clicking outside it and dragging inwards or by putting the insertion point after the hyperlink, holding down the shift key and pressing the left-arrow to select it. Then key Command-k » click the “Remove link” button at bottom left. Or you can right/Control-click the hyperlink, which presents you with an Hyperlink » Edit Hyperlink option.

You can search for the next hyperlink by holding down the circular button on the document’s vertical scroll bar, rolling to the “{a}” area (fields) in the box that appears, letting the mouse button go, then clicking on either of the grey double arrows above and below the circular button. Keying Command-y will repeat the action of removing the link. 

If you want to stop Word automatically hyperlinking every web address you type, choose Tools menu » AutoCorrect » “AutoFormat as you type”. In the “Replace as you type” section, de-select “Internet paths with hyperlinks”. You can always reinstate this setting if you need to hyperlink web addresses in future. 

This macro automatically removes active formatting from all hyperlinks in a document:

Sub Main()

' Removes hyperlinks from document

' Macro written 1 Aug 2001 by John McGhie

 For i = ActiveDocument.Hyperlinks.Count To 1 Step -1

    ActiveDocument.Hyperlinks(i).Delete

    Next i

End Sub

Note that it works backwards up the document. That's because each time you delete a hyperlink, the collection re-numbers. If you go forwards, you delete only every second hyperlink.

For notes on installing macros, see page 185.
Hyperlinks: removing the blue underlined formatting from web URLs and e‑mail addresses

Word’s default configuration causes a web address or e‑mail address to change automatically to blue, underlined text that is hyperlinked to the address. You will probably see this formatting in documents you receive from others. This feature can be useful in some documents, but not in all. Many people find it visually intrusive (especially when printed — many people consider underlining is a form of typographical vandalism). 

To remove the hyperlink, see the notes above. To change the formatting (for example, the underlining), see the next paragraph. 

If you want to revert to formatting the hyperlink as black and not underlined, select the address (start outside it and drag inwards or Shift-arrow) then key Control-spacebar.
 If you want to simply remove the underline for aesthetic reasons but retain the blue colour (or impose another), you should change the definition for the default style “Hyperlink”: choose Format menu » Style » from “List” below the scroll box choose “All styles” from the pop-down menu » Hyperlink » Modify » Font » apply the formatting you want. You will probably also want to change the format of the style for followed hyperlinks at the same time. I usually return the settings to “Styles in use” after these actions. 

Keyboard shortcut for strikethrough, restoring as in Word 5.1a

By default, you can no longer format text as Strikethrough by keyboard shortcut and have to go via the Formatting palette or the Font dialogue box — but it’s not too difficult to do a work-around, as follows:

Tools menu » Customize… » Commands » Keyboard… » scroll the list under “Categories” to “All commands” » scroll the list under “Commands:” to Strikethrough » click in field under “Press new shortcut key:” and type Command-Shift-/ [in the default, this command is allocated to Show Help Tool, which I do not need.]  Make sure that “Normal” appears in the pop-down list titled “Save changes in:”

Macros

I’m a raw amateur where VBA macros are concerned, but they can save a huge amount of time. I’ve found that advice on making them is readily available — for example, in the microsoft.public.mac.office.word newsgroup.

Notes on making a simple macro (in two different contexts) are on pages 178 and 185. In addition to macro scripts that appear in the main body of Bend Word to Your Will, at page 188 I list some macros that I have found useful. 

	If you haven’t yet used macros, be aware that Office 2008 won’t have them

For document professionals and corporate entities that rely heavily on macros, this is a very serious shortcoming of Office 2008, and may prompt them to stay with Word 2004, or if they have an Intel-chipped Mac to run Word 2007 under Windows®, using Parallels. But if you have not become used to creating these marvellous time-savers you may prefer not to start.

Some macro capability can be replaced by AppleScript: see the article ‘Moving from Microsoft Office VBA to AppleScript: MacTech’s Guide to Making the Transition’, a magnum opus written by Paul Berkowitz and several fellow Mac Office MVPs at www.mactech.com/vba-transition-guide/index-001.html 


Ordinals, removing the superscripted 8-point font (1st)

Done in initial configuration. See notes under “On the Tools menu” on page 38.

Page numbers

See notes under “Page numbers in headers and footers” on page 56 and “Section properties” heading below.

Page numbers, re-establishing them when they don’t show during scrolling

Go to Page Layout view, scroll through the document, and return to Normal view. (Repagination kicks in quickly in Page Layout view, whereas Word only paginates in Normal view when it feels like it).

Section properties

To assign properties based on the section — such as whether a section starts on a new page, has a different header or footer on the first page, or has different odd/even headers or footers: 

•
Click anywhere in the text before the section break.

•
Format menu » Document … » click Layout » assign properties, especially Section start, Headers and Footers and Apply to (This section / Whole document / This point forward). Do not change vertical alignment from Top — that applies to vertical spacing of the text on the page, not the header / footer. 

A section break controls the properties of the section before it.

At some stage you may decide to add a section break before the start of each chapter so that you can do something like starting endnotes at “1” in each chapter. Once you have formatted one section break to do what you want, there’s no need to repeat the laborious process in each chapter — just copy the section break (best done in Normal view) and paste it at the beginning of the other chapters. 

To apply page numbers, including to headers or footers: see the notes under the heading “To set up headers and footers”, on page 55. 

Section breaks, like the final paragraph mark in a document (which is the section break for a single section or the final section) tend to harbour corruption. More details are on page 127. 

For comprehensive advice on sections, including the infuriating aspects, see http://word.mvps.org/FAQs/Formatting/WorkWithSections.htm

Style menu, alternative to formatted pop-down menu

To have an alternative to the formatted pop-down styles menu, see the notes for “Add ‘Format styles’ button” under the heading “Adding to personal Formatting toolbar” on page 47. 

This alternative is useful if you have retained WYSIWYG formatting of the style pop-down menu (Edit menu » Preferences… » General » tick “WYSIWYG font and style menus”; over-ride it when desired by holding down the Shift key before clicking the font menu). 

For other ways of applying styles, see page 98. 

Styles

See the major section starting on page 85. 

Tables

It takes a lot of time to configure tables from the Table menu. For a quick way to insert a table pre-formatted the way you want it, see page 121. 

The things to avoid with tables because they lead to instability, according to experts on the MacWord MVP newsgroup, include the following:

•
tables within tables;

•
merging or splitting table cells;

•
dragging text between cells (“you will still end up with a corrupt document if you do too much of this; it’s OK if you are sure that you only have text selected, but if you make a mistake and select a cell, there’s trouble ahead”);

•
dragging individual cells (but “it’s OK to drag rows or columns around”);

•
cutting and pasting in tables (“it will do it, but table corruption is likely to result sooner or later — although cutting and pasting or dragging and dropping whole rows is usually OK”).

Further, the more of the following you use, and the more often in a document, the less stable things become: text wrapping, automatically resize to fit contents, allow rows to break across pages, and nested tables.

One expert said that “if you do it properly, Word will handle a table of about 160 pages [without trouble]”. One tip he gave to speed things up and minimise problems while working on such a document was to choose Table menu » Split table (every few pages — no more than five) while editing, then when finishing the document remove the splits so the table re-joins itself. 

To remove corruption in tables (revealed by slowness of actions, caused by the need to use huge amounts of memory), select each table and use Table » Convert » Table to Text to turn the table into tabbed text, then without moving the selection use Table » Convert » Text to Table to convert it back to a table again. If that does not work, the document may be corrupt: see page 127. 

If a document has tables extending over more than a few pages and is slow, select each table in turn and for each table go to Table menu » Insert » Table and de-select “Auto fit to contents” if it’s selected. (Even if the tables don’t extend this far, turning off this characteristic will speed up Word when you work on the document: it no longer has to re-calculate and re-draw the table every time you type a character.)

If you don’t want text in a cell to break (i.e., some lines to carry over to the next page) select the whole table from the left margin and choose Table menu » Table properties » “Row” » de-select “Allow rows to break across pages”. A macro for a button to achieve this is in Appendix D: Making buttons for formatting shortcuts.

It’s useful to know that “Keep lines together” and “Widow/orphan control” have no effect in table cells if “Allow rows to break across pages” is enabled, and “Keep with next” applies only between rows, not between paragraphs in a single row. In general, it’s best not to apply these settings in tables, because they can prevent pages from breaking.

Good advice on table break problems is in http://word.mvps.org/FAQs/TblsFldsFms/ControlPgBrksInTables.htm

To put a table on the same line with text, put your insertion point in the table and choose Table menu » Table Properties » Table. Then under Text Wrapping, click the button titled Around. For more information, see the article with the heading “Text-wrapped tables and frames” at http://word.mvps.org/faqs/tblsfldsfms/TableBasics.htm (you may have to hit the circular Refresh button a few times if you use Safari).
You may find that a wristwatch icon appears when you work in tables in Word 2001; it did in mine, all the time. Despite having allocated 80 MB of RAM (out of 512 MB of physical RAM), there was nothing I could do about it. Many other people have found the same thing. I lived with it until I moved to Word 2004. 

	I never use “Table Style”  

I agree with John McGhie when he warns people very strongly never to use Table Styles. They create a number of problems, the worst of which is that there may be no "good" way to remove a formatting defect once it has been applied, short of converting the table to text and back to a table again in another style. John's says:

The person who designed table styles in Word completely misunderstood the use-case. What we got was an object that is a single "style" that attempts to format the text and borders of a table as a single style. Utterly useless. …

A Table Style is applied as a single “collection” of formatting: you either have a table style applied to a table or you have a different table style applied to the table. Once you have used a table style on a table, you can't remove it. 

You can, however, modify the Table Style, and add the Table Style to the template, then Update Styles in all the other documents to flow the change through. For example, you could modify the paragraph properties of the heading and body rows of the table style you are using, to give yourself more space above or below the text.

Table Styles are a mess: they're the exact opposite of what we need.

I avoid all this by applying styles based on body text (my “bt” style), which I titled “table text,tt” and “table heading,th”. Their characteristics are described in Appendix B: Specifications for some of my styles — especially to reduce the chances of changed appearance on other computers, starting on page 169. 

In practice I rarely think about these problems because I almost invariably insert a table already pre-formatted the way I prefer, via a three-letter AutoText entry as shown on page 121. And it’s so simple that way. 


Table of contents, compiling

You can compile a table of contents virtually automatically if you have used heading styles in the document. (The ability to compile a table of contents so easily is one of the many advantages of the built-in characteristics of Word’s heading styles — although it’s possible to compile them, with more work, using other styles or via “TC” fields.
)

At the spot you want to have the table of contents, drop the I-beam and press Return for a new paragraph mark, then apply the default TOC 1 style (Format menu » Style » scroll to TOC 1 » Apply). Then choose Insert menu » Index and tables » Table of Contents tab » Formats » From template » choose the format you want » OK. A table of contents will appear. 

There is an advantage in having a blank paragraph mark above the table of contents fields, and one below — both set to “Normal” style. This avoids a number of potential problems that can occur — for example, if you have a table of figures (or other set of fields) following the table of contents, or a section or page break. 

To upgrade the table of contents at any time, click in the margin to the left of the first entry in the table of contents and press the F9 key (see the note on page 21). Don’t delete the table before doing this — it can eventually lead to corruption. 

So that the “Contents” heading does not appear in the table of contents itself, I format this heading in a nontoc heading style (an example is on page 21) or a manually modified body text style (as on page 6) — in fact, anything other than a heading style. 

For an easy way to get to the table of contents from anywhere in the document, see page 196. 

For more information about tables of contents, see: http://word.mvps.org/FAQs/Formatting/TOCSwitches.htm

Table of contents, formatting of

A table of contents will normally be formatted quite well by the default setting, or at least by variations that you can make either via Insert menu » Index and Tables, or by amending the style — for example after a table of contents has been compiled initially. 

One instance of changing the style of toc entries would be to prevent text from getting too close to the page numbers before starting a new line. You can do this by moving the right-hand indent in, as shown here (the right-hand tab stop shows where the page numbers are right-aligned, just before 15 cm on the ruler; the right indent marker (blue triangle) shows the maximum extent of text before I want it to go to a new line):  [image: image27.png]PRI




Another impetus for changing a style in tables of contents would be when I want the Level 1 entries (style TOC 1) to be in all upper case, even though these headings in the document itself are not in upper case, as in this document (i.e., Bend Word to Your Will). I simply changed the definition of TOC 1 style to be bold and upper case (and countermanded that for TOC 2). 

One instance of amending a table of contents manually would be to disembolden the page number and leader (e.g., dotted lines) for each TOC 1 entry so that only the words of TOC 1 entries are emboldened. These are the steps: 

•
get rid of emboldened leaders:

–
click above the table of contents

–
key Command-Shift-h

–
key “^t” ([don't include the quotes] in the top field and at the bottom choose Format » Font » Bold

–
in the lower field, do the same but choose “Not Bold”

–
click on Find next and Replace till you leave the table of contents.
•
get rid of emboldened page numbers:

–
click above the table of contents again
–
key Command-Shift-h
–
key “^#” in the top field and retain the “Font: Bold” setting
–
make the lower field blank and retain the “Font: Not Bold” setting
–
click on Find next and Replace till you leave the table of contents.

John McGhie does some elegant fine-tuning of the leader dots between the table of contents entry and the page number, for when the document is published in print directly from Word:

To stop the leader dots colliding with the page number, set a Left tab to occur half a centimetre before the page numbers, and a Right tab to occur where you want the right boundary of the page number. Put leader dots on one, and none on the Right tab.  Your leader dots will now end perfectly right-aligned before the page numbers.

Having done this, you will be struck by the fact that Word's leader dots are far too big. To deal with that, after compiling your table of contents, search for ^t^t and replace with ^t^t and set the Format of the Replacement to replace with 8 pt font. Your leader dots will shrink to ¾ size.  I often turn them medium-grey at the same time.

Subsequently, for all the format fine-tuning just mentioned, if you update only the page numbers in the table of contents when you key F9, your formatting will be preserved; but if you nominate “Update entire table” you will find that the emboldening appears again, because Word has compiled a complete table of contents afresh. That’s why I only do such manual formatting (if at all) on the final version of a document for publishing from Word. 

Table of contents, index or other table — updating

Click to the left of the table of contents or other table — this will select the fields. Press the F9 key (see the note on page 21). 

Table of figures, compiling

To compile a table of figures based on a style applied to the headings (“figure heading” style), Insert menu » Index and tables … » Table of Figures tab » Options … button » select “figure heading” style (don’t select “table entry fields” » OK.

Track changes, turning off

If, like me, you send out documents to others and receive comments or amendments back from them that you consider for inclusion in your original document, you probably become nervous about what the other people can do to the document. Many people use Track Changes for that. Others keep such a close eye on “dotting the i and crossing the t” on their colleagues’ writing that they can lose sight of the higher-level impact of the writing. It’s important to avoid that in my work — but many people find Track Changes too tempting to turn off. 

That issue aside, my main objection to Track Changes (shared by most people I know who develop long or complex documents) is that it tends to corrupt the document. I don't mind if someone has tracked changes in a fairly simple document (I always initiate “Tools menu » Track Changes » Accept or reject changes” when I receive a new document anyway), but I become more nervous the more complex the document. 

Where can the problems occur? The Track Changes function can wreak havoc with automatic numbering (which includes automatic bulleting). It can interfere with deleting footnotes. Tables especially can become corrupted. Further, when tables have been modified with a change in font size and “Accept Change” or “Accept All Changes” has been nominated, these changes are not accepted and stay visible in the document when viewed as Final Showing Markup — you have to “select all” in the tables (and text boxes, etc) to have them approved. There are more potential problems in relation to merged documents. And there can be problems associated with paragraph marks.
 At the lower end of the inconvenience scale, you will often find spaces removed or unwanted spaces added. 

The MacWord MVP newsgroup experts agree it’s particularly unwise to allow more than one layer of Tracked Changes to exist in a document.
 

If you must use Tracked Changes, see “Always remember this” on page 66 — but with long or complex documents developed collaboratively, consider first whether you can encourage everyone involved to keep this feature off and do a comparison on a “Saved As” copy of the document. I'll describe that option now. 

The following procedure produces the same results as Track Changes, but doing it on a Saved As copy of the document allows you to evaluate the changes before deciding how to handle them:

•
After getting my document back from colleagues, despite having asked them to leave “Track changes” off I always make sure it doesn’t contain tracked changes (failing to do that confuses the upcoming comparison). This is done by opening the document and choosing Tools menu » Track changes » Accept or reject changes » Accept all. 

•
Then I verify that Track Changes is off (see below).

•
[In Word 2001, at this stage I would create a new folder called something like “Compare temp” and Option-drag into it a copy of both my original (earlier) document and the new document (thus leaving the two originals untouched). This isn’t necessary in later versions.]
•
I open the newer document and verify that it doesn’t contain tracked changes. 

•
I do a “Save As” so that the original document cannot be affected. 

•
At this stage I convert the contents of all fields to plain text (Command-a to Select All then Command-Shift-F9) to avoid problems such as endless repagination when printing. The fields include the table of contents (and index if there is one). Reason: the size of change resulting from recalculating a field (e.g. a table of contents field) is limited to 750 characters, after which Compare Documents can become unreliable. 

•
I choose Tools menu » Track changes » Compare documents » navigate to the older of the two documents » Open. Changes will then be tracked. (In practice, because I do so much comparing I create an alias of the older document in the Finder by Command-Option-dragging before I take this step. I drag the alias into a folder set aside for this purpose. Then, when I initiate “Compare documents” the alias is in the window that opens and I don’t have to navigate around.) 

•
Tools menu » Track changes » Accept or Reject Changes » Find.

•
Using the Find button (or in some documents by quickly scrolling through) I then skim through all the changes to see which way is best to incorporate them. 

•
My next step depends on the extent of the changes. They are reasonably efficient and, more importantly, eliminate the chances of corruption: 

–
If there have been very few changes, I just key them into the original. 

–
If there are many changes I just have to go through the full “Accept / reject” process. 

–
If there aren’t too many changes: in Word 2001 I used to display both versions and simply dragged the amended text across to the original. 

In Word 2004 this does not work, because the strikethrough/underline formatting is retained when you drag the text over. The quickest solution applies if there are no deletions in the text: copy the changed text and paste it in as plain text (Edit menu » Paste Special » Unformatted text — but I use a macro-based keyboard shortcut that makes this easy; it’s described under the heading “Paste unformatted text / plain text” in Appendix D: Making buttons for formatting shortcuts).
 

Otherwise, copy a sentence or paragraph that has been changed, then paste it into a new blank document and accept all changes, then copy that and paste it into the original. 

In Word 2001 and earlier, if you experience problems because Word won’t show some changes (e.g. in some tables, or where a long table of contents stops the Compare Documents sequence), just compare a plain text version of each document: save both the original and new documents as plain text, then compare those two with each other. The Compare Document function works reliably with such documents no matter what their length. It will mark the plain text with the exact changes, which you can then quickly find in the originals by eye. 

Track changes, important settings for

To see whether changes are being tracked, look at the status bar at the bottom of the document: if Track Changes is on, the green “light next to “TRK” will be on: [image: image28.png]



I always check a newly received document to see whether Track Changes is on. There are four ways to turn off Track Changes:

•
double-click the “TRK” button so that it turns grey;

•
 key Command-Shift-e (this toggles the setting off/on); or

•
go to Tools menu » Track changes … » de-select options in window that appears; or

•
on the Reviewing toolbar, click Track Changes button so it is not pressed in.

If the Track Changes button is unavailable on the Reviewing toolbar, the document may be protected for change tracking. On the Tools menu, click Unprotect Document. If the document is protected with a password, you must know the password before you can unprotect the document and turn off change tracking.

The next step is to go to Tools menu » Track Changes and check the setting of Highlight Changes. It should be like this:
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Some users set “Highlight changes on screen” off when they meant to turn off “Track changes while editing”. This results in every edit they make remaining permanently in the document, but they can’t see it. The document grows progressively more and more complex until Word gives up. Leave “Highlight changes on screen” permanently on so you can see at a glance whether a document actually contains tracked changes. When you want to turn change tracking off, do one of the four alternatives shown above. 

At the end of each review cycle, get other users of the document into the habit of saving the document to a new file and Accepting All changes.

Track changes, using — if you really can’t use “compare documents”

Make sure you read “Track changes, turning off”, on page 63, for details of what can go seriously wrong with Tracked changes, and the related footnotes for why.

If you can’t do the preferable “Compare documents” procedure shown on page 63 and must use Track Changes, your document will last a lot longer if you do these things:  

•
Start each new round of edits by “Accept All” on previously existing changes.

•
If you have more than one editor working on a document, use “Merge Changes” rather than allowing multiple users to chew at the same document.

•
Don’t make any tracked changes within tables or next to section breaks — and insist that the other users do likewise. 

•
Finalise all changes before beginning a new round of editing.

Always remember this if you are tracking changes

If you have to use Track Changes, remember this:

•
Try not to allow more than one layer of Tracked Changes to exist in a document. 

•
Be very careful around tables. Using tracked changes within a table is particularly likely to cause trouble.  

•
Automatic numbering may be corrupted. Obviously the significance of this depends on the amount of automatic numbering in your document. 

•
Be very careful around paragraph marks. Doing a tracked change that deletes a paragraph mark when the following paragraph has a different format is the source of many glitches. So keep non-printing characters turned on when working with tracked changes to ensure that you can see what you are doing. 

•
Check for unwanted deletions of footnotes. 

•
Starting with the original pristine document, back up frequently so you can retrieve the situation if problems occur.

•
When you receive a document, start by choosing Tools menu » Track changes » Accept or reject changes » Accept all — even if there is no visible evidence of unresolved changes.

Excellent information on Track Changes is at http://shaunakelly.com/word/trackchanges/HowTrackChangesWorks.html
(it’s written for PCs, but not to difficult to extrapolate to the Mac).
Work menu, documents and commands on

To put documents on the work menu, save your document then, on the Work menu, click Add to Work Menu.  

	In OS 10.3 onwards …

… you’ll find that the keyboard shortcut that is supposed to delete items from Word 2004’s Work menu (Command-Option-[minus sign]) doesn’t work. If like me you frequently add and remove Work menu items, go to System Preferences » Keyboard and mouse » Keyboard shortcuts » Universal Access » de-select the Zoom Out tickbox (or if you want to have a keyboard shortcut for that command, assign another combination for Zoom Out).


To put items on the Work menu: Tools menu » Customise Toolbars and manus» Commands » from scrolling “Categories” list, select appropriate menu » in “Categories” scrolling list, scroll to desired command » drag to Work menu (or any other menu, for that matter).  

To take documents off the work menu: as long as the Mac OS hasn't hijacked the command (see green panel above), press Command-Option-[Minus key on main keyboard]. The pointer turns into a black minus sign (which may disconcertingly disappear while you pop down the Work menu). On the Work menu, click the document you want to remove. 

Like some other people, I experienced an inability to remove items from the Work menu via the keyboard shortcut even though I had re-configured the Universal Access control (see green panel). I overcame it by adding a "Remove from Work menu" command to the Work menu:

•
Choose Tools menu » Customize » Customize toolbars/menus » click the "Commands" button at the top » OK. 

•
At bottom left, Save in: Normal. Scroll to "All commands" under "Categories" and "ToolsCustomizeRemoveMenuShortcut" under "Commands". 

•
Drag the command from its position in the scrolling list to “Work” on the temporary “customising” toolbar and place it in the position in which you want it to appear on the Work menu (a dark horizontal bar will help you to place it accurately). I placed it so that it wasn’t next to “Add to Work menu”, to avoid a wrong selection. 

•
The command will currently read “Tools Customize Remove Menu Shortcut”, which is rather long and obscure.
 To change the wording of the menu item — e.g. to “Remove from Work menu” — stay in the “customising” toolbar, select the item and right/Control-click on it, select “Properties” and type in the desired name. Finally, OK.
If you like to use the Work menu regularly, you’ll find some good ideas at http://word.mvps.org/Mac/WorkMenu.html

You can no longer sort items on the Work menu as in Word 5.1. However, you can add a document again to the menu to put it at the top. 

The Work menu dynamically updates itself, which I find very useful since it can be catastrophic to work on the wrong version. If I’m working on, say, version
 2c3 of a document and I decide to keep that version for archival purposes (i.e., a snapshot of the document as it was at version 2c3), I close the document (often I type an “x” on the first line just in case I’m interrupted and open up the wrong document subsequently); then I click in the Finder, key Command-d to duplicate the file, and drag the copy’s icon to my external hard drive to back it up then and there. Then I upgrade the title of the original version to “[whatever] v2c4.doc” in the Finder. Once this document opens, I choose it from the Work menu: it shows the previous version number on this first occasion, but subsequently the new version number shows in the Work menu.

I refer to Bend Word to Your Will often, so I have it on my Work menu.

Standard keyboard shortcuts in Word

It’s worthwhile compiling a document of all keyboard commands, as shown below, before you make your own keyboard shortcuts, because then you can always distinguish between defaults and the ones you have created. I didn’t, and I got confused when advising my friends (until another friend printed a list for me from a brand-new Word installation).

You can compile a document of all keyboard shortcuts, except those assigned to macros, by doing the following: 

Tools menu » Macro » Macros… » pop down the “Macros in:” menu to Word Commands » scroll down the list until you see ListCommands, then Run » click Current menu and keyboard settings » OK.

A new document will be produced that lists Word’s default menu and keyboard settings (unless you have changed any of them) and any that you have created. This list is about 16 pages long; if you choose “all Word commands”, it will be about 33 pages. 

I titled my document “Menu & keyboard settings [date]”.

If you consult Windows-based Word manuals or you do a lot of cross-platform work and your PC-based colleagues are in the habit of asking you about using Word, it’s handy to have the equivalent document for the PC. It’s simply a matter of asking a colleague with a Windows computer to e‑mail you one; the procedure is the same as above. 

To print a list of all the keyboard shortcuts you have prepared (“user-defined”) — hard copy or PDF — see page 76. 

To find out the keyboard shortcuts you assigned to macros, choose Tools menu » Customize » Customize keyboard » under “Customize in”, scroll to “Macros”. You'll see all your macros in the list on the right, and when you click on any of them, you'll see the keyboard shortcut below. 

In practice, I find it more convenient to include the keyboard shortcut for a macro as a preamble to the expression of the macro, in VBA. While I'm at it, I add a summary of what the macro does. For example:

' Reduces the space below the para by 2 points

' Keyboard shortcut Option-Control-Shift-DownArrow

Changing keyboard shortcuts

The easiest way to assign a keyboard shortcut to any menu item is to choose Tools menu » Customize » Customize keyboard. At the left, under “Categories”, you’ll first see Word’s menus listed, and below them some categories such as macros. Click the menu under which the item you want to shortcut is listed (or the appropriate category) — for example, File menu. Then select one of the items listed under “Commands” in the right-hand list — for example, FileSaveAs. If there is an existing keyboard shortcut, it will appear in the “Current keys” box below.  Press the new shortcut keys combination » Assign. Before clicking OK, check that the pop-down menu at the bottom left — “Save changes in” — reflects what you want (most likely “Normal”).
Assigning a keyboard shortcut to a button

Just hold down the Control key and click the toolbar button, even if it’s greyed out (or right-click if you have a two-or-more-button mouse). In the contextual menu that appears, select “Properties” » click the “Keyboard” button. You can also shorten or change the button’s title while you’re there.

My most often used default keyboard shortcuts 

These are the default keyboard shortcuts I use most often, in alphabetical order.

	
Command
	
Keyboard shortcuts
	
My cue
	Notes; equivalent keys in Word 5.1 

	Align:
left

right

justify

centre
	Command-l ( “L”
Command-r

Command-j 

Command-e
	
	Command-Shift-l, which previously left-aligned, now produces List Bullet style, with bullets; Command-Shift-e toggles on Track Changes.

	AutoText, replacing name of AutoText entry with the entry itself
	Command-Option-v
	Very useful
	See “AutoText” item on page 120. No need to select the text. “AutoText” was “Glossary” in Word 5.1. 

	Bullets and List Bullet style
	Command-Shift-l  ( “L”
[Note that this default “List Bullet” style applies characteristics that include “based on: Normal” and “automatically update”. Neither is desirable.  I modified these characteristics, in keeping with the notes on pages 96 and 152; that is, I based the style on “bt” and removed the “automatically update” characteristic.  In practice I use style “sb” (described in the table in appendix B, which starts on page 169) because it’s applied via Command-Shift‑s as for any other style, but there’s no particular reason not to use Command-Shift-L.]
	
	At the time I wrote the first of these notes, when I was in Word 2001, Quark XPress and Adobe InDesign did not recognise these “non-keyed” bullets. Similar problems had been reported in convert​ing to PDF. But in Word 2004, Print » Save as PDF transfers over the “non-keyed” bullets.

In situations in which there could be a problem (e.g., when I must avoid possible corruption via automatic number​ing), I retain keyed (Option-8) bullets. To simplify keying, I have an AutoCorrect entry (“bb”) for keyed bullets — see page 81.  

	Change case (cycles between cases)
	Shift-F3

Command-Option-c
(Command-Option-c can be keyed with one hand — I use it often when moving clauses to the start of a sentence, for example.)
	
	No longer includes sentence case unless there is a full stop or colon (see notes on page 154), but to change the case of a single word it’s only necessary to have the insertion point in it — it does not need to be selected. 

	Close up paragraph
	Command-0 ( zero
	
	Defaults to zero/12 points before. For example, if you had 10 points before, the first iteration will produce 12 points before and the next will produce zero points before — which is what I’m after.

	Comment, insert
	Command-Option-a
	
	I don’t often use Word’s Comment feature. Instead I apply a distinctive character style to comments written in the running text, as described on page 125. 

	Cross-references, table of contents and other fields, update of
	[If appropriate, Command-a to select the whole document; otherwise have insertion point in table of contents; then (] 

F9

[If you have cross-references in footnotes, you need to update them separately from the main document text. In Normal view, choose View menu » Footnotes » click in any footnote » Command-a to Select All » F9.]
	
	F9 is now taken by the OS. For work-arounds, see the note on page 21.

	Documents, open, cycling between
	Command-F6
	
	

	End of document
	Command-End
	
	To select from an insertion point to the end of the document: Shift-Command-End

	End of line
	End key
	
	To select from an insertion point to the end of the line: Shift-End

	Field, convert contents to plain text
	Command-Shift-F9.
	
	

	Field, show scripting
	Shift-F9
	
	This keyboard shortcut is now taken by the OS, as with F9. See the note on page 21. 

	Font, display of in pop-down menu in the Formatting toolbar
	Command-Shift-f
	
	Selects in the font pop-down menu, ready to type in the name of the font.

	Font dialogue box
	Command-d
	
	

	Footnote, insert
	Command-Option-f
	
	This inserts a footnote reference number — so don’t use it to simply look at the footnotes window. For that, see “Footnote, close area (pane)”. 

	Footnote, close area (pane)
	Control-Shift-c
	
	There is no default keyboard shortcut for opening it, but it’s easy to make your own: see “Open (and close) footnote area” on page 81.

	Go back
	Command-Option-z
	
	Rotates through the last four places where text was typed; in a newly opened document it [usually] goes [only] to the last position of the insertion point before the document was last closed. 

	Heading style, apply to paragraph
	Command-Option-[number] 
[n=1, 2 or 3: does not work for 4 onwards]
	CmO[n]
	If you have headings listed as “Heading 1,1” it is easier to type Command-Shift-s » 1 [Return], which works for all levels of headings.

( I could use Word’s shorter, standard keyboard shortcut for headings (Command-Option-1 and so on), but since I have added a suffix to almost all my styles, it’s easier just to key Command-Shift-s » [suffix] [Return] in all instances. 

	Hidden text, applying that format to text 
(show / hide)
	Select text » Command-Shift-h
	
	If paragraph marks are not visible, text will disappear after keyboard shortcuts are applied, and text cannot be made visible by apply​ing the command again (need to go Edit » Preferences » View » Non-printing char​acters » hidden text).

	Hyperlink, toggle active formatting on/off
	Command-k
	
	You can also convert it to plain text — see page 57. 

	Increase font size
	By one point: Command-] 
(to shrink use [ )

By default sizes: Command-Shift-> 
(to shrink use <)
	Imagine the ] as a forward arrow
	

	Insert column
	Table menu » Insert » Columns …  
	
	

	Insert row
	Control-Command-v
	
	

	Normal style, apply to paragraph
	Command-Shift-n
	
	Command-Shift-p

	Normal view
	Command-Option-n
	
	Same

	Outline view
	Command-Option-o
	
	

	Paragraph command
	Command-Option-m
	
	Command-m

	Print preview
	Command-Option-i
	
	

	Reduce font size
	By one point: Command-[ 
(to increase use ])

By default sizes: Command-Shift-< 
(to increase use >)
	Regard the [ as a backwards arrow
	

	Repeat typing or action
	Command-y
or Option-Return
	
	

	Replace (as in “Find and Replace”)
	Command-Shift-h to open the “Replace” pane; then keyboard shortcuts for each of the options within the pane: see ““Replace” pane — useful keyboard shortcuts” on page 149.
	
	

	Restore character format to that of the underlying paragraph style (e.g. in Normal style to plain)
	Control-spacebar
	
	Control-spacebar was allocated to Spotlight in OS 10.4. A work-around is discussed on page 108.

	Restore paragraph style — remove manually applied paragraph formatting (not characters in the paragraph) to revert to the underlying style.
	Command-Option-q
	
	To restore formatting of characters in the paragraph to that of the underlying paragraph style, see page 108. 

	Select word to the left of the insertion point
	Shift-Option-left arrow
	
	Very useful if you lose sight of where the insertion point is! To return the insertion point to where it was and de-select, follow with Shift-Option-right arrow. 

	Show all (non-printing characters such as ¶ paragraph marks)
	Command-8
	
	

	Spelling: next mis-spelling
	Option-F7
	
	

	Split the screen 
(also de-splits)
	Command-Option-s
	
	You can’t split if Document map is open. To open a second version of the document on screen, select “New window” from the Window menu. 

	Split screen, cycle between
	F6
	
	Goes to your previous insertion point in the other half of the screen.

Also see “Windows, cycle between”.

	Start of document
	Command-Home
	
	To select from an insertion point to the start of the document: Shift-Command-Home

	Start of line
	Home key
	
	To select from an insertion point to the start of the line: Shift-Home.

	Style


	Command-Shift-s
	As before
	Selects in the styles pop-down menu, ready to type in the full name of the style (e.g. “comment in text”) or, if you name your styles with an abbreviation following the full title (“comment in text,ct” or “Heading 1,1”) just type the abbreviation. Then hit the Return key.45 

	Views
	Normal view: Command-Option-n

Page layout view: Command-Option-p

Print preview: Command-Option-i

Outline view: Command-Option-o
	
	

	Windows, cycle between
	Command-F6 cycles via the next window.

Command-Shift-F6 cycles via the previous window. 

(You can use Option instead of Command).
	
	Also see “Split screen, cycle between”.

	Work menu, removing items from
	See the note on page 21. 

Press Command-Option-[minus sign]. The pointer turns into a black minus sign. 

On the Work menu, click the document you want to remove.
	
	Works on other menus too. 


Examples of keyboard shortcuts I’ve assigned

Two main factors apply here. First, keyboard shortcuts that you allocate, such as the ones below, can’t be transferred (e.g. from a corrupted Normal template to another) via the Organizer — so they have to be re-keyed instead. Second, I don’t like changing (as opposed to supplementing) the default features of Word too much because I get confused when I’m asked for help on a client’s computer. For these two reasons I’m conservative about allocating too many of my own keyboard shortcuts — and certainly about re-allocating a default keyboard shortcut to something else.

If there is already a button for the function to which you want to assign a keyboard shortcut, the procedure is simple — see “Assigning a keyboard shortcut to a button” on page 69. 

Otherwise: Tools menu » Customize » Customize keyboard. 

First, at the bottom right of the “Customize keyboard” window, make sure “Save changes in” reads “Normal” unless you want to invoke the keyboard shortcut only in the document you have open. ( Easy to overlook.
When you scroll in the left (“Categories”) scrolling window and click on a category, the commands accessible under that category appear in the right scrolling window. Most commands are under one of the menus, but others (e.g. the Reveal Formatting command) appear to be listed only under “All commands”. It may take some exploring to find some of them (in column 2 in the table below I show the name of the commands for the ones I have allocated when they appear against “All Commands” — which is near the end of the left-hand scrolling window). 

[image: image30.emf]
Having scrolled to the command in the right window and clicked on it, note the description at the bottom of the window (this is important, since some commands — e.g. those to do with Style — are similar in name but quite different in function). Then look in the “current keys” window and note any shortcuts listed; take them into account as appropriate. Click in the field next to “Press new shortcut key” » press the desired shortcut key » Assign » OK. 

(Yes, it’s very Windows-like, and it took a particular genius, devoid of customer focus, to come up with it.)

I find the most convenient keyboard modifiers, in the absence of a lead from the standard set to do otherwise, are Control-Option-Command. This combination doesn’t seem simple when you see it on paper, but in effect all it amounts to is “hold down your first three fingers, touching each other, on the keys to the left of the spacebar”. I use it with the keyboard shortcuts for some of my macros, one example of which is shown in the table below. 

These are the keyboard shortcuts I have assigned — but they reflect my highly individual way of operating, so don’t be surprised if none of them interests you!  (Also, I should point out that I don’t use some of them except when I’m working on particular types of work. I’ve listed the ones I use most at the top.)

	Command
	Description in the right-hand scrolling window when “All Commands” is selected in the left
	Keyboard shortcut
	My cue
	Notes

	Change case (cycles between cases)
	ChangeCase
	Command-Option-c
	
	I added this to the default Shift-F3 because it can be keyed with one hand.

Hmm, maybe this was a default. Must check one day…

	No proofing [of selected text]
	[Not applicable: this shortcut applies a simple macro that I made, which applies Tools » Language » No proofing — see page 189.]
	Control-Option- Command-n
	No proofing
	I use this if I want to suppress wiggly red lines under words (e.g., surnames) that I don’t want to put into my dictionary and don’t want to appear when other people view the document.

	Add or subtract two points of paragraph leading
	[Not applicable: the keyboard shortcut applies one of four simple macros]
	I use either of two shortcuts for adjust​ing leading above the paragraph, and either of two for below: see ‘Add or subtract two points of paragraph leading’ on page 191.
	
	These commands nudge paragraphs closer to, or further from, other paragraphs or design elements when positioning is important.

	Insert cross-reference
	InsertCrossReference
	Control-Option- Command-x
	“x” stands for “cross-reference”
	

	Keep with next paragraph
	ParaKeepWithNext
	Control-Option-k
and 
Control-Option-Command-k
	Keep with next
	Most often used to glue a paragraph to a following list of bullet points without having to use a special style.

	Keep lines together
	ParaKeepLinesTogether
	Control-Option-Command-t
	Keep lines together
	

	Style (as on the Format menu)
	FormatStyle
	Command-t
	Same as in Word 5.1
	Replaces default shortcut for hanging indent, which isn’t needed if you use styles.

	Reveal formatting

	RevealFormatting
	Control-Option-f
	Reveal formatting
	I use this most often when I need to check someone else’s formatting, to see what has been manually applied. Option-f is more logical but is unavailable. Control-f is the Find command on Windows, which I need to reserve. 

	Open (and close) footnote area
	ViewFootnoteArea

Note: selecting this command via “All commands” in the left-hand (“Categories”) box did not produce a workable shortcut; but it worked when I selected the same command against “View” [menu] in the “Categories” box.
	Control-Shift-Command-f
	
	This command toggles between opening and closing the footnote pane.

	Calculate
(see page 160)
	Tools Calculate
	Command-[equal sign]
	Same as in Word 5.1
	A brilliant command!

Replaces default shortcut for Subscript

	Show/hide Formatting Palette
	ViewFormattingPalette
	Control-~ ( tilde
	
	I never use this now, since I never use the Formatting palette (all my customis​ations are on small toolbars instead), but others use it more.

	Redefine style [based on selected text]
	RedefineStyle
	Command-Option-d
	Redefine style
	Replaces default shortcut for “copy as picture”.

You can’t redefine Normal this way in Word 2004 — though that doesn’t bother me, since I never use Normal style.

	Strikethrough
	Strikethrough
	Command-Shift-/
	Same as in Word 5.1
	Replaces default shortcut for showing the Help tool


If you want to print a list of all the keyboard shortcuts you have defined, choose File menu » Print » look for the pop-down menu that shows “General” and pop it down to “Microsoft Word”. In the resulting window, look for the pop-down menu that shows “Document” and pop it down to “Key assignments”. Press “Print”. (You can also get an electronic copy this way by printing to “File”, which produces a “.ps” file that can be converted to a PDF.)

AutoCorrect — a great time-saver

Note: Formatted AutoCorrect terms are stored in the Normal template (or another template if you so choose). Unformatted AutoCorrect entries are stored in the settings file “MS Office ACL [English]”. For Word 2004, it’s in [hard disc name]/Users/[your user name]/Library/Preferences/Microsoft (earlier versions were: System folder » Preferences » Microsoft). Back up any changes immediately. Also see the important notes under the heading “On the Tools menu” on page 38. 

AutoCorrect is an excellent feature. I use it frequently as “shorthand” — for example, to save having to type long terms that I frequently use, to convert lower case terms to upper case, and to save keystrokes with other characters such as bullets and em dashes. 

I also use AutoCorrect to correct terms that I sometimes mis-type.

	Before I made my first AutoCorrect entry, I deleted nearly all of the default terms in the original AutoCorrect list because they did not really apply to my work and I wanted a shorter list so I could scan through terms I had assigned. Deleting them took me about half an hour, if I recall correctly, but the consolation was that I only ever needed to do this once — because I backed up the settings file “MS Office ACL [English]”.


To add a term to the AutoCorrect list, choose Tools menu » AutoCorrect... » AutoCorrect tab » [type the abbreviated and full terms] » Add » OK. 

I often find I’ve typed the full term in the document before I decide I want an AutoCorrect term for it. In that case, I drag across the term to select it (without a space after it); this results in the complete term appearing in the right-hand field in the AutoCorrect window when you open it up.

Ensure that in this window the tickbox “Automatically use suggestions from the spelling checker” is de-selected if you do not Word to correct terms that you do not want corrected (I usually want to be in charge, as you may have guessed by now, but if you’re trusting....)

AutoCorrect is specific to a particular dictionary language, so you will see that the window is titled “AutoCorrect: English ([whatever variant you are using])” or whatever other language you are using. However, in AutoCorrect, variants of English reflected in the installed dictionaries — for example, UK, US and Australian — are treated as the same language for this feature, although in most other contexts they are treated as different languages.

Examples of AutoCorrect items I’ve assigned

Note: AutoCorrect terms are highly individual. I have included some of my terms only to demonstrate the types of use I make of this feature — namely typing “shorthand” terms and correcting a few of my mis-keying habits. As described on page 49, I always back up Word’s settings files to ensure that my work on things like AutoCorrect is not lost.

These terms are not case-sensitive. However, adding “-ed” to the word or using the plural, for example, will stop the root word from being amended, so you need to make a separate entry for these forms.

	Abbreviation
	Term that will be inserted

	,==

( In effect I am typing “<==” here, but without needing to hold down the Shift key to produce the “<” (see next column)
	(
The arrow at the right end of this line, here: [image: image31.emf]
is a screen shot of the arrow that should appear above, just in case it does not appear the same on your computer.

The character that is typed when you hold down the Shift key and type a comma is “<”. I think of this as the tip of the arrow. I think of the “==” as the shaft of the arrow.

( For right-pointing arrows I used “.==”
( For upwards-pointing arrows I used “6==”
(because the upper case of 6 is ^)
( For downwards-pointing arrows I used “v==”

	aus
	Australia

	ausn
	Australian

	autocorrect
	AutoCorrect

	bb
	•   ( This is an Option-8 bullet inserted in the font size of the sentence, in this case Arial 11 point. Usually I follow the “bb" with the tab to invoke the bullet. Because Word’s Bullets and Numbering mechanism is one of the most common causes of corruption in Word documents, especially those worked on by more than one person, I personally prefer to key bullets manually if that means I can avoid invoking automatic bulleting — that is, if the document is not otherwise required to have automatic numbering in it.)

	biz
	business

	bizs
	businesses 

	cgov
	corporate governance

	cmobile
	This types in my mobile (cellular) phone number. I know what it is, of course; AutoCorrect simply ensures that I never key it in wrongly. Similarly with my other telephone and fax numbers, and my e‑mail address (“cemail” — “c” signifies “Clive”). And likewise with those of family members.

	comm
	communication

	comms
	communications 

	concenr
	concern (My brain is hard-wired to mis-key this!)

	concenred
	concerned

	dash followed by equal sign -=
	— (an em dash)

	dec
	Dec (I customarily use the abbreviated date form “25 Dec 08”)

	ddec
	December

	ddec8
	December 2008 (For example, typing "25 ddec8" produces "25 December 2008". If you use US date formats, this won’t make sense; it’s just something the rest of the world does. Then, this AutoCorrect item is very useful   :-)

	december
	December

	dont
	don’t

	eeg
	for example (As with other abbreviations, I repeat the first letter to trigger the full term. "Eeg" will upper-case the first letter: "For example". See “eg" entry for the abbreviated term)

	eg
	e.g.

	email, emails, emailed 
	e‑mail, e‑mails, e‑mailed (I typed the hyphen as non-breaking — that is, Command-Shift-hyphen — so this is done as a “formatted text” AutoCorrect entry)

	envt
	environment

	envtal
	environmental

	envtl
	environmental (because I often forget which way I have abbreviated this one, I entered both)

	ffri
	Friday ( and similarly with other days and months — the principle is that the full version is triggered by repeating the first letter

	incg
	including 

	incl
	include 

	incld
	included

	incls
	includes

	nnrm
	natural resources management

	nnsw
	New South Wales

	nsw
	NSW

	para
	paragraph

	paras
	paragraphs

	rad
	R&D 

	remeber
	remember (I always mis-key this)

	two dashes without space --
	en dash –

	wrdc
	WRDC [Note that if “wrdc” is in this organization’s website name in lower case you will have to manually correct it — see notes following this table.]

	wsa
	WSA 

	wwrdc
	Widget Research and Development Corporation 
(note the distinction from “wrdc”, which simply changes the letters to upper case; my standard practice for all abbreviations, if I want the term in full, is to repeat the first letter, as shown here and with the “wsa” / “wwsa” examples).

	wwsa
	Widget Services Australia (see “wwrdc” comments)


Sometimes you may need to type a term but not have it expanded or amended via AutoCorrect — typically when typing an organisation’s web address, which has to be in lower case (as an example, “www.wrdc.com” from of the abbreviations in the list above). AutoCorrect will dutifully upper-case “wrdc” as soon as you type it. The easiest work-around is to key Command-z as soon as the AutoCorrect occurs. An alternative (especially if the term will be copied to other documents) is to type the first few letters followed by a space, select the letters (only) and apply “No proofing” via Tools menu » Language — then when I type the final letter, AutoCorrect will not operate. 

Using AutoCorrect to prevent Word from nominating text as wrongly spelled

During spell checks, Word will highlight any words that are not in its dictionaries — either the main dictionary plus custom dictionary, or the main dictionary only if “Suggest from main dictionary only” is ticked in Spelling and Grammar preferences. 

The following example covers a particular problem that occurs when terms comprising the same two words in succession — such as in some place names — aren’t in the main dictionary. Word will not accept these entries in a custom dictionary, so the second word is always highlighted as discrepant because it is a repeated word. 

The work-around is to get AutoCorrect to replace the discrepant term, immediately you type it, with the same words — but with a “No proofing” formatting instruction included in the new term.

The same work-around can be applied to a single word that is highlighted as discrepant.

Example: to make Word accept “Wagga Wagga”

In a Word document, type in “Wagga Wagga” and select it (without a following space). 

Go to the Tools menu » Language » scroll to the top of the options to select “no proofing”. Click the “OK” button to close the window — but leave the text selected. 

Now go to the Tools menu » AutoCorrect. In the right‑hand field, “Wagga Wagga” will be present. Click the “Formatted Text” button above the right-hand field. Click in the left‑hand (“Replace”) field and type “Wagga Wagga” in it. Press the “Add” button, then the “OK” button. 

Now, every time “Wagga Wagga” is typed it will be replaced by the non‑proofing version that will not be seen by the spell checker. 

To stop the spelling checker highlighting instances of “Wagga Wagga” that have been typed in previously, select a word in the document then » Tools menu » Language, and note the language shown » Cancel. Then Edit menu » Replace. Type “Wagga Wagga” in the upper field » click “More” button » Format » Language » select the language you noted down » OK. Then type “Wagga Wagga” in the lower field » Format » Language » select “No proofing” as the language » OK. Then find and replace the term wherever it appears. Sounds long-winded, but you only have to do it once to a previously typed document. However, if there are only a few such instances, I simply drop the insertion point immediately after the last character of the term, type a space (which instigates AutoCorrect) then the Delete button to delete the space.

Styles and templates — the keys to consistency and saving time

Unlike most other topics in this document, this section is a continuing narrative rather than dictionary-style entries. This is because Word is fundamentally based on styles and an understanding of styles is therefore essential to creating long documents — or at least, to start with, an understanding of the simple concepts underlying styles. 
	The following notes were recorded only as an aide-memoire while I was learning Word 2001’s styles, having used styles extensively in Word 4 and 5.1a. Although I have since added many notes for other people’s understanding, they aren’t uniformly comprehensive and are no substitute for the guidance about Word’s styles obtainable from various manuals. 

For an introduction to styles, choose the Help menu » Microsoft Word Help » Search (across the top) » key in “About formatting text by using styles” » click Search button » click the underlined blue “About formatting text by using styles” » read the text and follow the hyperlinks. Be aware, however, that some of the information will recommend approaches — such as use of the Formatting Palette — that are inconsistent with the recommendations in these notes for working on long documents. Also, the dangers of enabling “Automatically update styles” are not mentioned in Word Help. For more comprehensive information on styles, see “Good articles on styles” on page 98. 

Please bear in mind that the following notes inevitably reflect my working preferences and the intended uses of styles in my documents. Here are some examples:

•
Many of my documents are circulated to others and I often prefer to apply styles that will retain the characteristics I have specified rather than possibly be over-ridden by Word’s default styles on other people’s computers. (I often make it easier for my colleagues by attaching a customised styles palette, so they only have to click on the palette to apply the document’s styles — an example is in the appendix starting on page 183.)

•
Sometimes I need to adjust text (expand or contract the vertical spacing) to fit in a table or textual element on a page. This is achieved very quickly by adjusting the leading that is initially a characteristic of a style. It can’t be done if you use a blank paragraph mark between paragraphs of text (i.e., if you hit the Return key twice at the end of a paragraph). 

•
I like to know exactly where I am in a document, especially if I’m unfamiliar with it because someone else created it — so I incorporate different colours into the styles for different levels of headings. The colours’ relationships to certain levels of heading soon become intuitive, even while scrolling through the document at high speed. (It’s very quick and easy to change these styles to black, or a corporate colour, when necessary.) 

•
I have created heading styles that look exactly the same as “Heading 1” (et seq.) styles when printed but do not appear in the table of contents. (Since I do not base these styles on heading styles, the table of contents compiler ignores them — hence their name, “nontoc” heading styles.) They are distinguishable on the screen from my ordinary heading styles by being dark grey. You can see them in this document, such as on page 21.
 


What are styles?

Word’s styles are a named collection of formatting that is applied simultaneously, saving time and providing uniformity. Styles are at the core of Word — that’s the way Word has been designed. If you don’t have at least a basic understanding of them, you’ll be mystified and troubled by some of the things you see in other people’s documents or by the results you get in your own documents. 

As Bill Weylock once said in the microsoft.public.mac.office.word newsgroup: 

“Take 20 minutes or so and read up on styles in Word. Yeah, yeah, the knowledge should be available in pill form and the jerks at MS should long ago have introduced telekinetic formatting. For now, though, you’re working in Word, which is a cool program if you grasp styles and infuriating if you don’t.”
Do I need to bother with styles?

Statistically, it’s a fact that most users of Word around the world don’t use styles. Many don’t need to, because all they type is short letters, memos or notes. Their documents will almost certainly be formatted with text in the default “Normal” style, and characteristics such as emboldening of headings will be applied manually: in essence, using Word as a typewriter. That’s the only type of formatting available with some other, more basic word processors. 

Some people work on longer, more complex documents but don’t move to styles-based formatting because they are too busy to invest the initial effort to understand styles. That’s understandable: when you don’t know anything about styles and what you see of them seems complicated, the commitment to learn about them seems rather open-ended, especially when you don’t know what the benefits will be. Therefore, many people “soldier on” well beyond the point at which it would make sense to switch to styles-based formatting. And clearly you can get away with never using styles if you only prepare a long document occasionally — and you’re prepared to check very carefully for consistency in the way you have formatted headings and body text (including checking that there aren’t any headings on the bottom line of a page), and you don’t need a table of contents to be compiled automatically, and won’t be sending the document electronically to anyone else’s computer, and … but I’ll stop there. However, if you prepare long documents more often than “just occasionally”, and want to format them quickly and consistently, applying styles is the only way to go. Word is essentially a styles-based word processor. In my work, I save a huge amount of time by using styles, my documents are consistent in appearance and more stable, and I can make global changes to the whole document’s appearance in seconds. There are about 10 other advantages that will be mentioned later, too. 

Before you decide whether it’s worth investing time in studying styles, I should tell you that I haven’t come across anyone who has done so and regretted it. The amount of time you spend gaining knowledge of this subject is, of course, up to you. For some people, learning what styles are and how to apply Word’s default styles is enough. At the other end of the scale, people who work on long documents all the time will find themselves drawn to learning much more, so they can tap into the huge productivity benefits that come from competent use of styles. But irrespective of how far they have decided to get into styles, the usual reaction of people on discovering how effective styles are, is one or another variants of “Wow!”. And that’s almost always followed by “If only I’d known earlier …”.  

Actually applying styles is very easy indeed (it’s described on page 89 and more briefly — paragraph styles only — on page 98). The major effort is conceptual — in coming to grips with what goes into styles and, after that, how to make maximum use of them through features such as applying styles via keyboard shortcuts, inserting tables of contents that compile themselves automatically, and getting a strategic picture of the document through outline view. 

If you decide to look into styles, be aware of one thing: it would take too much of the rest of your life to discover everything about them from first principles. It’s best to benefit from other people’s experience whenever you can (for example, from the sources on pages 98 and 21). After you grasp the underlying principles, you’ll find there are some excellent tips on the previously recommended websites for saving timing and achieving consistency, which you will gradually take on board depending on your particular needs. From experience, I find that most people who start to use styles — once they get their brain around the underlying principles, which I admit can be a bit painful — really enjoy adapting them to the way they work in Word. Most people who get through the initial confusion say styles and their side-effect benefits are the most enjoyable aspects of using Word at its best — taking advantage of the huge potential for configuring Word the way you want it to be, and not having to use what you get out of the box, which is designed to “average out” the needs of millions of other users. 

The three sets of styles in Word

There are three sets of styles in Word: default, built-in and custom: 

· Styles in the default set are required as part of the document structure.  You cannot remove them: if you could, Word would no longer be able to read the file. Among these are the “Heading” styles — that is, Heading 1 to Heading 9.

· The built-in styles are the remainder of about 150 styles that are pre-defined in Word.  They do not exist in the document unless you use them, but they do exist in Word, so you cannot create a new style of the same name.

· The custom styles are the ones you create yourself.  The cannot have the same name as either a built-in or a default style.  You can delete them.
Some advantages of using styles

The main underlying advantage of using styles is this: once you have formatted your first few documents or templates in styles, you constantly draw on that investment thereafter. Documents have better electronic structures (greatly reducing the likelihood of corruption), look better, and take up much less preparation time. 

When you apply a style, you apply a whole group of formats in one simple step. You can do the same manually in more steps, as in this example of the front-page title/heading of a document. 

	Step no.
	Formatting manually
	Formatting with a style

	1
	Select all the words that will become the title.
	Click anywhere in the paragraph that will become the title (don’t bother to select the words).

	2
	Embolden the selected text keying Command-b or mousing to the "B" toolbar button. 
	Apply “Title” style (by keying Command-Shift-s » “Title” » Return key, or clicking a toolbar button, or selecting from the Style pop-down menu).45

	3
	Apply Arial font (from Font pop-down menu).
	

	4
	Apply 16-point font size.
	

	5
	Centre the title.
	

	6
	Move the insertion point and press the Return key for spacing before or after the heading.
	

	7
	If you want to avoid an “orphaned” heading (on the last line of a page), now or in future: apply “Keep with next” to the heading and subsequent blank paragraph(s) (via Command-Option-m shortcut or Format menu » Paragraph » “Line and page breaks” tab).
	

	

	Useful spin-off features:
	Nil.
	13 others deriving from using Word’s heading styles, described in the bullet points below. 

	Time:
	30 seconds.
	3 seconds.

	Number of above actions:
	12.
	2 or 3, depending on method. 


Multiply these actions by the number of headings in the document and the time-saving is noticeable. More importantly, a style can be applied without really taking your mind off the text or reasoning while you are developing the document. 

[If you’re just skipping through this section, jump now to the next heading, “How styles are applied”.]

In long documents, apart from the huge amount of time that styles can save compared with manual formatting, styles have other advantages as well:

•
Formatting by styles ensures consistent appearance without having to check the document. 

•
Styles are easy to change throughout the document, in one action, permanently or temporarily, by changing their definition (either one style or the style that underlies others) — for example, changing all headings in the document from Arial to Verdana takes only one step.

•
By using heading styles, tables of contents can be compiled and updated automatically — in seconds. (You can construct an “automatic” table of contents your own way, but it’s more difficult.)

•
Long documents are less liable to corruption if based on styles. This is unlikely to show up in a simple styles-based document compared with the same simple document formatted manually, but if a few corruptibility factors are present (see page 166), this factor can become significant. 

•
When you want to set up hyperlinks in your document, it’s by far the easiest to link to text formatted in heading styles. 

•
If you have to use Word’s automatic numbering feature, it’s easier — and the numbering is much more stable — if you apply numbering to Word’s built-in heading styles or sub-paragraph styles. 

•
Heading styles allow you to gain a strategic look at a document’s structure, and to modify it, via the Outline view. (In this view, you can choose the level at which any style will appear; but if you use the built-in heading styles it’s all done for you.)

•
Importing text from Word into page layout and web authoring applications, and PowerPoint, is much easier. 

•
Creating clickable “bookmarks” that help you to navigate through Acrobat® PDF files is easy when the Word document uses built-in heading styles. 

•
If you want to number pages with chapter included (for example, “2.3” or “2-3”), and want to have the chapter numbers appear in the table of contents, the only way to achieve that is via the built-in heading styles.

•
If you want to number captions for figures and tables with chapter included (for example, “figure 2.3” or “table 2-3”), the only way to achieve that is via the built-in heading styles. 

•
If you want to include automated cross-references to captions (for example, “see figure 2.3 on page 9”), it’s easy to achieve that is via the built-in heading styles (doing the same via bookmarks is more difficult).

•
If you want to re-start the numbering of captions etc. after, say, every instance of Heading 1 (e.g., as chapter headings), you’ll use a SEQ field. The switch for doing this needs a built-in heading style. 

•
If you’re crazy enough to attempt to use Document Map (see the notes on page 132), you’ll find it re-formats your document less if you have used the built-in heading styles. 

The usefulness of some of these features may not become apparent until you are further down the track, and perhaps never — but if/when the time comes, it’s easy to pick up the extra knowledge to make use of these features. 

How styles are applied

Just to put styles in context, there are four types of formatting that you can apply to text in Word:

1.
Formatting words manually. Applied by selecting characters
 and applying characteristics — such as bold by keying Command-b. Best applied when there is only a small number of such instances in a document and there is very little likelihood of the formatting needing to be changed in future. You’re using Word like a typewriter, and in this context there is no particular advantage in doing otherwise!

2.
Formatting paragraphs manually. As above, but the whole paragraph is selected — for example, by clicking in the margin to the left of the paragraph, or by triple-clicking. Not worth doing in long documents because you can’t make any global formatting changes in future, but in documents only a few pages long — go ahead. 

3.
Formatting words by character styles. [Skip this and go to “4. Formatting paragraphs by styles” if it’s your first read-through.] Better than formatting manually if there are more than just a few words or groups of words that need formatting in the document. Applied by selecting the characters and keying Command-Shift-s followed by a the name or abbreviation of a character style, then hitting the Return key.45 Word’s default styles named “Strong” (bold) and “Emphasis” (italic) are applied this way. I have modified them to “strong,b” and emphasis,i” (note that everything is lower-case) so I can key the styles quickly — “b” stands for “bold” and “i” for italic. For emphasis I tend to use bold in on-screen work and italics for hard-copy output. It takes only a minute to globally replace the one character style with the other — that’s the great advantage of formatting by character styles rather than by direct formatting, since a change from manually applied bold to italics would pick up all headings. Of course, you would not use character style “emphasis,i” to format words that should always be in italics, such as book titles and legislation. 

On page 125, I give an example of one way in which I use character styles (a style for comments that I make in running text). 

[In practice, you can apply a paragraph style to selected words in the same way as for a character style. In Word 2001 it makes no difference except that you can’t search for the style applied to the words, which can be a nuisance if you want to make global changes later. That’s why I favour using character styles this way. More importantly, if you ever share a document with someone using Word 2002 or later, you will have introduced the significant “char char” problem, which will be unwelcome! (for details, see “Paragraph styles and character styles — what’s the difference?” on page 99). So the moral is: apply paragraph styles only to complete paragraphs, and only apply character styles to parts of paragraphs. 

4.
Formatting paragraphs by styles. This is the most frequent application of styles. It’s very quick — you just click anywhere in the paragraph and apply the style in any one of several available ways, the quickest being via a Command-Shift-s keyboard shortcut — see page 98 for the others.45 

Word has about 90 default or built-in styles available to be applied. The ones immediately available in your document are visible in the Styles pop-down menu (that is, the one showing “Normal” on the Formatting toolbar on page 44). Hold down the Shift key while you click on the Styles pop-down menu and you will see all the styles available. (Do this on a blank new document to see your default styles; do the same in this document for comparison.)

[If you’re just glancing through this, skip now to the heading “The minimum you need to know about styles” on page 92.]

In practice I never use the Styles pop-down menu, because a much faster menu access is available via Format menu » Style. (For even quicker access I use a keyboard shortcut — I allocated Command‑t — to bring up this Style window.) Once you get into the Style window, you have a choice of viewing styles in use, all styles or user-defined styles (the latter is not a totally accurate description), via the pop-down menu under “List”. It’s a “sticky” selection — that is, it will stay as you set it in future. To reduce the number of displayed styles in the scrolling list, I usually opt for “Styles in use”, as shown in the following screenshot from this document. Note that the styles I have created are all in lower case; Microsoft’s defaults, including the Heading styles I’ve modified, are in title case.
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In this scrolling window, the great advantage is that styles are all listed in alphabetical order, and are therefore more quickly accessible. To further speed things up, once you are in the Style window (and without needing to make a mouse-click) you can select a style in this scrolling list by keying the first letter of the style, which takes you to the first style beginning with that letter, then operating the down arrow key if necessary. To apply a style you’ve selected in the scrolling list, you press the Return key; to close the window you key Command-[Period]. This is all very quick, and you don’t have to use the mouse — try it!

For styles that you use very often, an alternative is to make a special toolbar, as described on page 109, and/or to allocate keyboard shortcuts, also described on that page. If you send documents to other people who work on them, you can attach a toolbar to the document displaying the main styles you have used, so that any changes can be easily formatted by them. 

If you are an intermediate or advanced user of Word you may well prefer to design your own styles rather than use the defaults — perhaps because these defaults are typographically amateurish (some people describe them as “ransom note typography”) and are used by literally hundreds of millions of other Word users. Perhaps you seek to meet the specific preferences of users of your documents, which will result in differing formatting requirements, or perhaps (if you do a lot of work that goes to other people) you don’t want your styles to be over-ridden by Word’s default style formatting when someone opens your document on another computer (as discussed on page 116). It’s quite easy to build styles based on your own specifications, and you can keep different types in different templates. Once you have defined the styles you need (which doesn’t take long anyway), they stay that way for good, so you never have to think about their formatting again unless you decide to develop them further.

In addition to being stored in documents, styles are stored — along with other things — in templates (outlined on page 101). Unless you decide otherwise, Word will store them in the Normal template. People who deal with a variety of long documents usually create separate templates on which to base each type of document; there are many advantages of doing so. 

Whether you store your styles in the Normal template or a template you design (as outlined later in this section), always back up the template immediately — see “Backing up the Normal template, other templates, and settings files” on page 49.

When to use styles and when to format directly

Here are the recommendations of Shauna Kelly, a most distinguished Word MVP; they are consistent with the practices in these notes (my comments, in blue, are only peripheral to Shauna’s advice):

“For all templates or any kind document other than a quick throw-away document to be created once, printed once and probably never opened again, use styles for all formatting, except the following:

•
bold, italic or underlining where you’re formatting only some words within a paragraph (e.g., ‘The history of the Titanic’ would have Titanic in direct formatting italics)

[Clive’s comment: For aesthetic reasons, I never use underlining. With documents that will be on the Web or computer screen and on paper, I prefer to apply any formatting that’s used for emphasis via character styles, so that I can switch quickly between italic and bold by temporarily redefining the emphasis character style (see previous page). But that exception aside, my preference is to apply direct formatting to text that should always stay in italics, such as in the Titanic example.]
•
when the particular paragraph or character formatting appears once only within the document (i.e., if you use the same formatting twice, create a style)

but ...

•
use a style when the paragraph has a particular structural role, even though it only appears once (e.g. the title).

Here are some practical applications of this rule:

•
If you use a particular format to indicate words that appear in a glossary (e.g., they’re in italics or green or bold or all three), then create a character style called, e.g., ‘glossary terms’. [Clive’s note: so that I could use a quick keyboard shortcut, I’d call it ‘glossary term,gt’ — i.e., I’d add a suffix as described on page 93]
•
If you have a standard body text style with space after the paragraph, but you don’t want the space after the paragraph when it’s introducing a bulleted list, create a paragraph style called, e.g., ‘body text bullet intro’. [Clive’s note: I’d call it ‘body text bullet intro,btbi’, for reasons described on page 93] 
•
If you mark off major portions of the document with a border or a rule, create a style with the border or rule.

•
If you add page-width inline pictures or graphics to your document, create a paragraph style called, e.g., ‘pictures’ to hold them.

Three hints:

1.
Name your styles for their purpose (e.g., SubTitle), not their formatting (e.g. don’t name a style BoldBlue). [Clive’s note: I’m a slow typist, so I don’t use upper-case in style names.]
2.
If you’re creating a template to create documents requiring several styles, set up a special toolbar in the template that holds menus and buttons for all the styles that users will need. If you make it easy for users, they will use styles consistently.

3.
If a style is always or often followed by a paragraph of another style (e.g. every Picture is followed by a Caption), then set the ‘Style for the following paragraph’ appropriately. This helps users to do the right thing.” 

The minimum you need to know about styles

If you aren’t ready to get deeply into styles yet, there are two things you should know and apply in long documents. Here’s the first. 

Use heading styles in long documents; don’t embolden Normal text

If you need to format long documents, the direct formatting habits described above will soon add up to a lot of wasted time. Many of the documents I receive from clients — before I guide them towards styles if they are interested — are the proverbial “dog’s breakfast” of manual formatting, including manual modification of styles that Word has applied to the document.
 Often my colleagues have given up trying to achieve a consistent, professional look to the document. And the electronic version is much worse than the printed version. 

Here, I’ll confine the discussion to heading styles. 

	If you don’t want to look closely into heading styles just yet…

… Then the main message is: use Word’s default heading styles for all headings, because they have a whole raft of properties pre-defined that fit them for their intended purpose. Don’t use Normal style and change it manually (e.g. by emboldening). 

If you don’t like the fonts or some other feature in the default headings, it’s easy to customise these styles so that they suit your preferences exactly. The huge advantage is: you only ever have to do it once, as shown below. 


A short note:  you’ll see I recommend amending style titles by following the numeral in a default heading style (e.g., “1” in the style “Heading 1”) with a comma, no space, and the numeral again. Hence, the default “Heading 1” becomes “Heading 1,1”. Similarly with body text styles — such as “comment para,cp”.
 This is to make it easier to apply a style by keyboard shortcuts. To apply a “Heading 1,1” style I simply key Command-Shift-s » “1” » Return key.45 On the PC it’s Control-Shift-s (and Enter key). It’s very quick.    

# CH: Fix footnote ref above and add new text from “New text for style keyboard shortcuts.doc”

For long documents, it’s better to have headings whose levels are immediately apparent from the font size and font treatment such as All Caps or Small Caps, roman or italic. It’s much quicker to select a “Heading 1” style than to have to remember the manual formatting that you have been applying to that level. In addition to having characteristics similar to the Title style described on the previous page, a heading style should also glue the heading to the text that follows it. I add a couple of other characteristics as well. Let’s look at how this applies to the styles I designed for this document. 

If, while this document is open, you choose Format menu » Style » scroll to “Heading 1,1” you will see that it’s formatted with ten characteristics shown in this table (if you want to print out a list of specifications for styles in this document — including Heading 1,1 — see page 169).

	Characteristic of “Heading 1,1”  
	Reason / discussion

	Based on: no style
(this is the topmost option in the “based-on” list in Modify » Style based on)
	Not basing the style on Normal minimises problems with automatic (non-keyed) bulleting and numbering and minimises the chance of a recipient’s definition of Normal taking over. 

Basing Heading 1 on “No style” creates a break in the inheritance list that isolates the Heading styles as a group. As a consequence, automatic (non-keyed) bulleting and numbering works more reliably, such as when re-establishing a numbering sequence after it is interrupted by non-numbered text. 

For further information, see both “Numbered headings; outline numbering” and “Numbering, automatic” on page 145, and “Bullets” on page 153.

	Font: 20 pt, bold, colour dark red
	I prefer my headings to show their level on-screen by their colour. It’s effective in showing me, subliminally, the level I’m reading at, including when I’m scrolling through at high speed. Quite often I change them to a corporate colour just before I send the document off; it only takes a couple of minutes. 

	Font: Verdana
	When I used Times New Roman as the body text, I used Arial as the heading font. I changed the heading font to Verdana when I changed style “bt” to Arial for most of my documents after laptop screen resolutions became finer. 

	Space before 0 pt, after 20 pt
	This spacing results from my using “Heading 1,1” only as chapter headings. 

(Therefore, I could also include “page break before” in the style definition — but this has confused some of the people with whom I share documents, so I omit this.)

	Kern at 18 pt
	A typographical improvement. 

	Keep with next
	Stands for “Keep with next paragraph”, i.e. “glue yourself to the paragraph that follows”.

	Keep lines together
	Stops a two-line heading splitting between two pages if it appears at the bottom of a page. 

	Don’t hyphenate
	I don’t like unnecessary hyphenating, especially because much of my work ends up being laid out by other people in Quark XPress or InDesign, which will be hyphenated in its own right. I don’t like too-liberal hyphenation rules anyway, and since I almost always left-align body text (easier to read), not much hyphenation is needed. I can always hyphenate manually in exceptional circumstances (including using an optional hyphen, which will only appear when the word would otherwise carry over to the next line: the keyboard shortcut is Command-hyphen).

	Level 1
	The heading level — important for viewing in outline view and compiling tables of contents etc. 


Note: For specifications of other styles I frequently use, see page 169. 

If you click on the Modify button, you’ll see “Style for following paragraph: bt”. This means that when you press the Return key after typing the heading, the next paragraph will be formatted in style “bt”. 

Now click “Cancel” and scroll to “Heading 2,2”. Since these headings are based on “Heading 1,1”, only the differences are shown. Continue down to “Heading 5,5” if you wish.

Usually I only go down four levels in a document, but I sometimes use lower-level headings for special purposes. These lower-level headings need not become smaller and smaller. For example, headings 7, 8 and 9 might be used for appendixes to take advantage of some automatic features of heading styles (see www.ShaunaKelly.com/word/numbering/NumberingAppendixes.html). 

What if you are using a font in these styles but want a different font in a copy of the document being sent to others? This often occurred in Word 2001 when I wanted to send my document, created in Times (a Mac-only font), to a Windows computer — which would definitely have Times New Roman installed (similar to Times, but didn’t look so good on screen in Word 2001 or earlier, which is why I didn’t use it until Word 2004.
 All I would do was to change the definition of style “bt” to include Times New Roman. All styles based on it, including the headings, change in the blink of an eye. And the same applies if I wanted the headings to be in a sans-serif font such as Arial, or Verdana — by changing the font that “Heading 1,1” is based on, all the other headings will automatically change over. (If you want to do this frequently, consider a macro on a toolbar or in a keyboard shortcut — see page 183.) 

	Font appearance in Word 2004 is very different from that of previous versions

Word 2004 allowed Unicode fonts to display and improved cross-platform compatibility. Profound changes were needed to do this. They are outlined on page 136. 


Think about this for a moment: if you want to change the appearance of your entire document, or all headings, it just takes a few mouse movements (or the click of a button with a macro on it — see “Creating buttons on toolbars to apply selected styles and formatting” on page 109). That’s one of the powers of styles. 

If the detail of styles terrifies or mystifies you right now (I well remember that feeling!), what should you do? Well, just read enough to understand the concept of styles, then format your document with heading styles — even the default ones. You can always change them to a more aesthetic appearance when you become more ambitious. 

To apply a format with heading styles, drop the i-beam in text that you want to format as a heading (you shouldn’t select the text). Then either pop down the Styles pop-down menu and select “Heading 1,1” or whatever, or pull down the Format menu and select Styles (I assigned a keyboard shortcut to do this), then scroll to the heading you want (typing the first letter gets you close and you can arrow-key from there if you wish) » OK. Quickest of all is via a simple keyboard shortcut on its own, as described on page 114. Voilà! — all formatted! To format other headings immediately afterwards with the same style, click anywhere in the text you want to format and key Command-y to have Word repeat what you did; then move to the next one and repeat again. 

There are other advantages to formatting headings with styles. They include being able to look at the document strategically and alter its structure via Outline view (see page 146); compiling and updating a table of contents virtually automatically (page 61); and formatting long documents for “minimum maintenance” (page 161). 

An advantage of using styles when preparing a document is that if you select words in one paragraph and move them to a paragraph that’s formatted with another style, they will automatically assume the appearance of the new style. (Make sure you don’t include the paragraph mark when moving such text — if you want to select a complete sentence quickly, the best way is to hold down the Command key and click anywhere in the sentence, dragging if necessary to include other sentences.)

To illustrate this, suppose you select some text in the heading below, hold down the Option key to peel off a copy of the words, and drop them into say a “bt” paragraph. The blue 10.5 point italics will instantly change to 11 point roman black. Similarly, I often peel off some body text within a paragraph as the starting point for a heading above it. To undo your action, key Command-z. 

Use a body text style, not Normal, in long documents

Here is the second thing you need to know as an absolute minimum about styles. 

There are several reasons why, in long or complex documents, you should avoid using Normal as the style for your body text — and preferably for anything else in your document — as mentioned in various places in these notes. (I know almost everybody uses Normal style for body text, but if you want to increase your document’s stability and your power to quickly and easily amend your document’s appearance at a later stage, it’s worth using a style other than Normal.)

For body text — that is, the text you are reading right now — you have three choices:

•
You can simply apply Body Text style from among Word’s defaults (it’s Normal + 6 points after). 

•
Or you can copy someone else’s (such as my substitute for the default Body Text style, called “bt”, as used in this document). For notes on how to transfer them, see page 106. 

•
For more control and side-benefits you can design your own. 

	Specifications for style “bt” and other styles used in this document

I use a style that I created myself — “bt”, standing for “body text” — which will not take on a different appearance on someone else’s computer (not a problem for many people, but essential for me, because I distribute my strategic plans to many colleagues while we develop them). I find it easy to apply the style by keying Command-Shift-s » bt » [Return] rather than selecting the style by one of the other methods. 

I describe how I set up this “bt” style, and others based on it, on page 169. You only have to change this base style, bt, to change all the others — as when wanting to change all of a document’s non-heading text to another font.

I also discuss the advantages of incorporating blank space above and/or below paragraphs, as part of the style, on page 169. 

If you’re someone who uses Word intensively and/or wants to achieve the time and efficiency gains that can be achieved by really mastering styles, you might like to download “Ideas for style specifications in Word documents.doc” from http://word.mvps.org/Mac/Bend/BendWordToYourWill.html. It provides detailed information on the structure of the most common styles I’ve evolved over more than a decade, whereas Bend Word to Your Will only provides such information in respect of styles “bt” and “Heading 1”.


Why is it best not to use Normal style? Here are the four main advantages: 

•
With only a few mouse movements you can change the appearance of body text in the entire document (but avoid changing other text).

•
Other people’s settings are less likely to take over yours if your document goes to another computer (see “Stopping other people’s styles over-riding yours when they receive your document” on page 116). For example, the default Normal style in Word 97 is 10 point, whereas in other versions it’s 12 point. That produces major changes in pagination and appearance on a computer with Word 97. 

•
You can specify a line spacing tailored to body text (as I have, because I prefer a slightly more open look). 

•
If you like to use automatic numbering (go ahead — live dangerously!) and you share documents, you can avoid problems of broken numbering sequences by not using Normal style or basing other styles on Normal — see the notes on page 96.

Not enough reasons to change an old habit? Here are four more, then: Because you have specified leading (x points after or before the paragraph) which does away with the need for double paragraph returns between paragraphs, headings can easily glue themselves to the body text; you won’t have blank lines at the top of some pages; you can manually close up or open out paragraphs on a page to make text fit if need be; and consistency in your formatting will be subtly, probably unconsciously, evident to the reader. 

To apply a body text or heading style:   

•
if you prefer to use the Formatting Palette (“Task Pane” in Windows versions), search in Word’s Help for “Apply a different style”;

•
if speed is of the essence, key Command-Shift-s followed by the name of the style (this is where the abbreviated suffix, as in “heading 1,1”, described on page 93, comes in very handy — I always use this);

•
choose Format menu » Style … (I have applied the keyboard shortcut Command-t to do this as well — when the styles appear in the Styles window that opens, you can either scroll or get to the style name more quickly by typing its first letter and — if necessary — using the arrow keys; or 

•
pull down the Style pop-down menu. 

For more information about the context for the above, see page 89. 

A few more ways to format documents better

See the notes under the heading “To avoid having to manually alter your formatting” on page 163.

Good articles on styles

As John McGhie said: “You are not going to learn [the full story on styles] by trial and error — you won’t live long enough.” Here are some useful sources. 
The more comprehensive Word manuals often have good material. 

A very good article on templates, styles and typography by John McGhie, Word MVP and guru extraordinaire, is at http://word.mvps.org/FAQs/Customization/CreateATemplatePart2.htm
 (If you download “CreateATemplate.zip” from that page, the resulting Word document covers styles from page 18 onwards. Or to see the coverage of styles on the MVP website, go to the bottom of the opening web page from which John’s article can be downloaded and click “Styles”.)

The books tend to have a more step-by-step approach than John’s article (or for that matter the notes you are reading now). 

If you know little of styles, it would be much better first to consult Shauna Kelly’s excellent tutorials (http://www.shaunakelly.com/word/concepts/introduction/index.html), including one on styles (http://www.shaunakelly.com/word/concepts/styles/index.html). 

Other articles on the Word MVPs website are as follows:

What do Templates and Add-ins store?:
http://word.mvps.org/FAQs/Customization/WhatTemplatesStore.htm
Mac Word Normal Template:
http://word.mvps.org/FAQs/WordMac/MacWordNormalTemplate.htm
Install a Template on Mac: :
http://word.mvps.org/FAQs/WordMac/InstallTemplateonMacContent.htm
Creating a Template — The Basics (Part 1) :
http://word.mvps.org/FAQs/Customization/CreateATemplatePart1.htm
[Part 2 of this series is referenced above]

Creating a Template (Part 2): Other things:
http://word.mvps.org/FAQs/Customization/CreateATemplatePart2/OtherThings.htm
Creating a Template (Part 2): File properties:
http://word.mvps.org/FAQs/Customization/CreateATemplatePart2/FileProperties.htm
Paragraph styles and character styles — what’s the difference?

The distinguishing features of paragraph and character styles are described in sub-paragraphs 3 and 4 under the heading “How styles are applied” on page 89. 

The upshot is that paragraph styles are designed to be applied to paragraphs and character styles to one or more words within a paragraph. In styles lists (Format menu » Style, or in the pop-down style menu), paragraph styles are accompanied by “[image: image33.png]


”and character styles by “[image: image34.png]


”. 

A paragraph style can be applied to selected words in the same way as for a character style, but you can’t search for the style applied to the words, which can be a nuisance if you want to make global changes later. That’s why I favour using character styles this way. More importantly, if you ever share a document with someone using Word 2002 or later, you will have introduced the “char char” problem, which will be unwelcome!

What’s the “char char” bug? In Word 2002 on the Windows platform, the style name that’s shown for any paragraph that contains a second paragraph style applied to part of the text will be followed by “char” — e.g. “Body Text char”. Some people using Word 2002 have been getting up to a dozen or so “char” additions to the style name. I got one recently from a Windows colleague with 17, i.e. “Body Text char, [+ 16 more “char”]. The latest Windows edition of Word has “fixed” the problem by masking the “char” additions — as does Word X — but I’m told they remain nevertheless. At first they were considered harmless, but now they are being regarded as associated with certain types of document corruption. If you receive a document with the “char, char” problem, the simplest way to eliminate the additional words is to use the Organizer to copy across a style with the same root name (e.g., “Body Text”). Word will ask you if you want to over-ride the former style with the latter. If you answer “Yes”, all instances will be named “Body Text” only. 

The simple conclusion is: use a paragraph style when all of a paragraph is to have that style; use a character style for selected words. An advantage is that you can do a Find command for the character styles, whereas you can’t if you have applied paragraph styles to words. And it’s therefore much easier to re-define and apply a different appearance to the style on some future occasion. 

An example of applying a different appearance to the style is important if you develop documents that will be used equally in both printed and on-screen form. If you want emphasised text to be easily read on screen, bold (or coloured non-bold) is better than italic. But in print, italic looks much better than bold. It only takes seconds to change the bold text to italic if the emphasis has been applied as a character style. As your starting point, you might like to use the default character style “bold” or “emphasis”.

I give another practical application of when to use a paragraph style and when to use a character style under ‘“Comment” feature, a simple substitute for’ on page 125. 

Managing styles

There are several ways of managing styles:

•
You can choose to add or modify the styles only in the document you are working on.

•
You can store the new styles or changes in the Normal template, which stores styles (and settings like margins) that are most frequently used. These styles or changes will be available to all documents based on, and linked to, the Normal style.

•
You can create a template
 to cater for special requirements for a particular type of document (for example, you may want the style you use for body text in that type of document to be different from that style in other documents). 

•
You can transfer styles from one document or template to another via the Organizer.

•
You can create toolbars — if necessary specific to a particular document or a particular template — that contain buttons for invoking selected styles.

[This can be useful if you send documents to colleagues who work on them and return them. You can create a toolbar specific to the particular document, make it very convenient for the colleague to know which styles should be used when developing the document further.]

•
You can apply a style via the Styles pop-down menu, or with the keyboard shortcut Command-Shift-s followed by the style name, as in Word 5.

These processes are outlined in the notes on the following six pages.

Modifying the styles only in the document you are working on

To change the font for, say, Heading 2, apply Heading 2 style to the text, select the text and change the font. Then click in the Styles pop-down menu on the Formatting toolbar. The name of the style will be highlighted. Press Return. When the “Modify Style” window appears... 

[image: image35.emf]
... press Return again to update the style. Now all instances of the Heading 2 style in the document will have changed to the new font. 

Make sure you don’t tick “Automatically update the style from now on”.

[Note that when this dialogue box appears in other contexts and you want to select the second choice (i.e., reapply the formatting of the style), keying Command-s selects the lower radio button. Command-u selects the upper radio button — but usually there is no need to use that keyboard shortcut since it relates to the default setting which, as in the example above, is enacted by hitting the Return key to activate “OK”.] 

See www.ShaunaKelly.com/word/styles/ModifyAStyle.html for a good discussion about modifying styles. 

Templates — convenient places to store styles and other formatting

	What is a template?

Word uses a template to create every new document — either the Normal template, by default, or another template to which you have deliberately attached your document instead. A template is a different type of electronic file from the usual Word document. It provides tools for shaping a final document — apart from storing styles, templates can contain text or formatting that’s the same in every document of the same type; AutoText entries; macros; menu and keyboard shortcut assignments; and toolbars. 

Many people always create a new document by simply copying an existing document on the desktop (Finder), renaming it, opening it and amending it from there. That may be fine for short documents, but for a long document that you have invested much time in perfecting, you need to avoid inheriting any corruptions that could well have been caused to earlier versions by all the “chopping around”. To start from a pristine beginning, it’s far better to open a blank document based on the template. 

One advantage of using a customised template is that you can make it Read-only, so that it cannot be inadvertently changed. You cannot do this to a Normal template. But there are many other advantages to using a customised template if you want to increase your efficiency in developing and managing documents, including generating documents with different structures and/or styles. 

Many people (including me) follow the titles of template files with “.dot”, especially if they share the templates with PC users — it draws attention to the fact that it isn’t a Word document — but on the Mac it’s essential not to add “.dot” to a Normal template, for reasons mentioned on page 52. 


Why create a template? 

Whenever you want to have a special toolbar or a style that will look different from others of the same name in other documents, you should seriously consider creating a new template and attaching it to your document. For example, in this document (Bend Word to Your Will) I wanted the level 1 entries in the table of contents (style TOC 1) to be in all upper case, even though these headings in the document itself weren’t upper case; and I wanted the level 2 entries (style TOC 2) to be bold. These changes made the structure of this particular table of contents much clearer — but would not be appropriate in other documents. If I had altered the TOC entries manually, they would have reverted to the styles in the Normal template the next time I updated them, since the Normal template is the default. 

If it’s certain that I will never want to have more than one document with this type of formatting in it, I would just make the changes in the document and leave it at that. But if I may want to use this formatting in future — in its own right or as the basis for further development of the formatting — I create a template as shown below, and attach it to this document. 

The reasons for having separate templates for each main type of document are further discussed on page 104 under “Some advantages of attaching a document to a template other than Normal”. 

To open a blank document from a template, you can either:

•
choose File menu » Project Gallery (or key Command-Shift-p) » select the template from “My templates”,

•
open a new blank document (it will be based on the Normal template) and attach it to the template as shown below, or

•
(if you’re satisfied there will be no corruptions in a similar document — discussed above) copy an existing document in the Finder, (Command-d) and re-name and double-click on the copy, which will be already attached to the same template as the original). 

A template for this document

The following is more likely to be relevant if you are an advanced user of Word, or if you aspire to be.

When you download Bend Word to Your Will from the MVPs’ website (http://word.mvps.org/Mac/Bend/BendWordToYourWill.html), you can also download three documents that contain many of the customised features I use. Depending on which features you want to use (e.g., styles, toolbars or content), you can copy them and save the resulting document as a template. If you choose to do so, that will give you direct access to the toolbars and macros described in the document you are now reading. However, if you don’t install the template and attach it to the document you are now reading, the styles in this document will still available, because they are also stored in the document. That means you can transfer the toolbars and macros via the Organizer from this document too. 

On the Mac, Word 2001 templates are placed by default in the Microsoft Office 2001 folder » “Templates” folder » “My templates” folder. 

Word 2004 templates are placed by default in [hard disc name]/Applications/Microsoft Office 2004/ Templates/My Templates (but there are advantages when backing up in putting them in your Microsoft User Data folder and leaving an alias behind — see page 50).

In Windows 2000, Word templates are recommended to be placed in Program Files » Microsoft Office folder » “Templates” folder. 

Creating a template

Save a document containing the required styles and formatting (deleting text as appropriate) then Save as … (select “Document template” from the pop-down menu). The default location for a template is the “My templates” folder so that it will appear in the Project Gallery.

Important: don’t simply add “.dot” to the document title. The formatting of a template is very different from an ordinary Word document (.doc), so it’s important to make the “Document template” selection from the pop-down menu. 

This article explains what a template is and how to create one. 

http://word.mvps.org/FAQs/Customization/CreateATemplatePart1.htm

It links to another popular article that deals with styles. 

Attaching a template to a document

Open the document whose styles you want to base on the template’s styles (or whose toolbars or macros you want to use).

Tools menu » Templates and add-ins … » click the Attach button » navigate to the template you want to attach to the document (by default, templates are in the folder “My templates”, which is in Microsoft Office 2001 » Templates); select the template and click “open” to attach it, making sure “Word templates” is the wording in the “Show” pop-down menu.

Click the tickbox “Automatically update document styles” to update the current document’s styles with styles from the template. Then click OK. The document will now be attached to the new template; depending on what you have specified, some of the styles may change or toolbars will show.

In most instances you will not want to permanently attach the document to the template, because doing so will result in the document being changed as soon as you open it at any time in the future, if the template has been modified. To prevent that occurring, as soon as you have gone through the procedure above you should open the Templates and add-ins window again and de-select the tickbox “Automatically update document styles”.
 

A particular problem if you leave “Automatically update” switched occurs if some styles in the document apply numbering. The document will automatically update its styles next time you open it, and will reset the numbering, sometimes over-riding the way you have specified the numbering to behave.

However, there are circumstances in which you may want the styles to automatically update. If you are writing a publication that has separate documents for individual chapters because they are very large (e.g. they contain many graphics), there’s a particular benefit of attaching the documents to a template. Any modification to the template can flow through automatically to each of the separate documents if you attach each chapter document to one special-purpose template, as described above — but on this occasion leave “Automatically update document styles” ticked. Before doing this the first time, I back the documents up — just in case!

If you want to base more than styles, toolbars or macros on a template — for example, you want to include the document format (margins etc) of the template — create a new document based on the template, then paste in the contents of the old document. 

Finding / changing the template on which a document is based

Within Word, you can locate templates to attach/detach them to the document you have open via Tools menu » Templates and Add-ins. The template’s name and location shows in field at top left. To change the template on which the document is based, click on the “Attach” button and navigate.

I made up a button on a toolbar titled “Tplt?” to open the “Templates and Add-ins” window (Tools menu » Customize » Customize toolbars/menus » Commands button » [Categories box] Tools » [Commands box] Customize toolbars/menus). With the window open it’s easy to navigate to the appropriate template. 

If you create a variety of Word templates for different purposes, you may find it convenient to gain quick access to amend them via the Finder (although it isn’t possible in Word 2004 to create a “.doc” from the templates; that can only be done at present via File menu » Project Gallery (or Command-Shift-p). There are several ways to do this:

•
For direct access, open the folder containing the My Templates folder and drag the My Templates folder to the sidebar that appears to the left of each Finder window, where an alias will be created automatically. An advantage is that any folder in the sidebar always appears in the left side of the “Open” and “Save / Save As” dialogues and is therefore easily accessible. 

•
If you don’t want to add another folder to the sidebar, you can put an alias of the My Templates folder into the Favourites folder in the sidebar. The templates will only be one step further away than under the first option. To do that you open the My Templates folder (for its location, see “Which files to back up” on page 49) » Command-l ( [L] to make an alias » drag the alias into the Favourites folder in the sidebar. Don’t drag the My Templates folder itself into the Favourites folder — it needs to stay put for backing up. 
If you don’t have the Favourites folder in the Finder’s sidebar, navigate to [hard disc name]/Users/ [your user name]/Library/Favourites and drag it to the sidebar, where its alias (created by the OS) will display as a heart icon. 
•
Or drag the folder to the Dock, where an alias will be created. 

Some advantages of attaching a document to a template other than Normal

The Normal template is the one that determines the toolbars, styles, macros etc that appear when you open a new blank document. Many people do not look beyond using only the Normal template. But like so many things in Word, peering around the back of a component reveals some very powerful capabilities. So it is with templates. 

Intensive users of Word often regard the Normal template as a temporary “scratch pad” for documents — they don’t make any (or many) permanent changes to it.
 Instead they create a specialised template for each different type of document. For example, much of my professional work involves writing strategic plans, and my clients have differing preferences — such as the layout of headings and the associated fonts and font sizes. The type of tasks I perform in particular documents varies too, and sometimes call for different toolbars. To save myself having to remember each plan or strategic document’s requirements every time I do a new one for a particular client, I simply attach their new document to a customised template. 

To give two examples:

•
Client A prefers Times New Roman font throughout, and likes a slightly open line spacing for body text. This is very close to the way I have configured my Normal template (as elaborated on page 169), but there are a few “extras” that are distinctly different, such as the layout for page numbers and quality management coding at the bottom of each page. 

•
Client B prefers Tahoma headings, 1.5 line spacing in body text, very wide margins and a unique layout for table of contents. 

Of course, I could simply develop a document with the desired characteristics, make a copy the next time I wanted the same type of document, and alter it as needed. But that document would inherit any corruptions developing in the earlier version. And for convenience I find that if I have templates for particular types of documents, when I improve a style or the buttons on a toolbar it’s easier to apply the improvements in a minute or two to a range of templates via the Organizer. In other words, it’s easier to apply continual improvement across a whole range of documents rather than just to one or two. And it’s easier to change the templates to apply those changes to future documents than trying later on to remember which document contained the improvements. I’ve come a long way through following this practice, and saved a lot of time. 

With these customised templates, you can freely transfer toolbars, just as you can between documents — whereas you can’t transfer customisations of default toolbars made in a Normal template. Further, with a customised template you’re asked whether you want to save the changes made to your template on the first occasion you save the document after making changes to the template, rather than when you quit Word in the case of the Normal template.

Creating a new template, attaching a template to a document and finding the template that a document is attached to are covered on page 102. 

Needless to say, I back up templates often so that I can go back to an earlier version if necessary. 

Basing a style on styles in an existing document

To quickly create a new style based on the features of a style that’s in an existing document, go to a paragraph with the “based-on” style, apply manual changes, then click in the field in the styles pop-down menu, type the new style name and press the Return key.

Similarly, to quickly change the features of a style that’s in an existing document, go to a paragraph with that style, apply manual changes, select the text, click in the field in the styles pop-down menu and press the Return key.

For more complex style definitions, go to Format menu » Style » Modify button » use the Format button and “Based on” pop-down menu. 

Transferring styles

Transferring a style from another document — the quickest way

The quickest way to bring one or more styles in from another document is to open the “donating” document and copy the paragraph(s) containing the style. Paste the paragraph(s) into the new document and delete the unwanted text within them. You can even delete the whole paragraph, including the paragraph mark, if you do not want to format text with this style until later — the style will still be retained in the available styles in the “receiving” document. 

The same applies if you simply copy a paragraph mark from the “donating” document that contains the desired style. I simply find it a little quicker to do as above. 

Transferring styles with Format Painter — within or between documents

The Format Painter allows you to apply the same formatting (styles and manually applied formatting) contained in one paragraph to one or more other paragraphs. You can do this between documents as well as within the same document. (Some people report corruption problems when using Format Painter; I haven’t confirmed them since I rarely use it.)

To copy a paragraph’s formatting — but limited to only one action

After this one action, Format Painter cancels itself.

To “pick up” the style of a paragraph whose format you want to copy, click anywhere in the paragraph then click the Format Painter button. Go to the paragraph that you want to re-format and:

•
if you want to re-format the entire paragraph, just click anywhere in it; or

•
if you want to re-format only a sentence, hold down the Command key and click anywhere in the sentence; or

•
if you want to re-format only certain words, drag over them and release the mouse button; or

•
if you want to re-format more than one paragraph, drag over the paragraphs and release the mouse button. 

If manual formatting has been applied in addition to an automatic style in the original paragraph, you have two options in the paragraph that you want to re-format:

•
to omit the manual formatting (i.e., to transfer only the formatting of the underlying automatic style of the paragraph), just click anywhere in the paragraph; or

•
to retain the manual formatting:

–
drag on the words you wish to format, or

–
to re-format only a sentence, hold down the Command key, 

then release the mouse button.

If you double-click, successive actions are possible

Do as above, but double-click on the Format Painter icon. The Format Painter will remain selected after you apply it to the first paragraph. Click the Format Painter icon again to de-select it.

Transferring styles from one document or template to another via the Organizer

Using the Organizer is a good way of copying styles, AutoText entries, toolbars, or macros in one template or document to another template or document. You can copy from several different templates or documents into the one you are developing.

The steps are:

•
Tools menu » Templates and Add-ins.

•
Click the Organizer button, and then click the tab for the items you want to copy — in this case, “Styles”. Navigate to the templates or documents to/from which you want to copy via the pop-down menus under “Styles available in”. To select a range of items in the scrolling list, hold down Shift and click the first and last items. To select non-adjacent items, hold down the Command key as you click each item.

•
To copy items to or from a different template or file, click Close File to close the active document and its attached template or to close the Normal template. Then click Open File, and open the template or file you want.

•
Click the items you want to copy in either list, and then click Copy. 

Changing styles in a document then changing the document’s template

I don’t like to tick the “Automatically update” button in Format menu » Style » Modify button, for reasons shown on page 152. After upgrading the style in the document, and with the Style window still open, I prefer to click on the Organizer button and, in the new window that appears, transfer it across to the document’s template.

If you decided earlier to save styles and/or toolbar buttons and toolbars in templates other than the Normal template (see the discussion on page 42), you may not necessarily save the style in the Normal template. For a discussion of why you might want to have a special template, see page 101.

Modifying styles quickly

Restoring paragraph style

To remove manually applied paragraph formatting such as leading (space before/after), line spacing and “Keep with next” (but not characters in the paragraph): key Command-Option‑q. [This is also termed “revert to the underlying style”.]

Restoring character format

To restore formatting of characters in the paragraph to that of the underlying paragraph style: select the text and key Control-spacebar — but see the following panel!

	A note: Work-around for Control-spacebar, now that it’s used by Spotlight in OS 10.4 onwards

If you frequently remove manual formatting from text, you’ll probably have found already that Control-spacebar is an invaluable keyboard shortcut.
 The problem is, Apple snaffled it to toggle Spotlight on/off in OS 10.4 — just as it did with F9 for Exposé (page 21) — with consequences for Word 2004. 

Whether you change the Spotlight shortcut or the Word shortcut will obviously depend on how often you use them. I decided to change the Spotlight shortcut. 

The second problem is that (unlike the earlier shortcut for Exposé) the alternatives are few: only F keys and Command-spacebar are presented in a pop-down menu, with no modifiers available. You find when, in System Preferences » Search results, you click on Spotlight and operate this pop down menu: 

[image: image36.png]™ Spotlight menu keyboard shortcut: % Space B A




When you click on the cautionary yellow triangle, you are taken to a window in System preferences » Keyboard & mouse » Keyboard shortcuts showing this after you scroll down:
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I de-selected the two instances, but then found, on going back, that Command-spacebar had been de-selected:
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— so I reinstated the tick against Command-spacebar. 

I prefer to open the Spotlight window, so I use the Control-Option-spacebar shortcut shown below Command-spacebar, although in practice most of my searches are for “file titles only” (or folder titles only), which Spotlight doesn’t handle well, and for that I use a third-party application, EasyFind — freeware by DEVONtechnologies. 


	And a work-around for the F12 key — snatched by OS 10.4 to open Dashboard (widgets)

If you use the F12 key for “Save As” in Word, you’ll find it is over-ridden to open Dashboard before you can use it in Word 2004. I went to System Preferences » Keyboard and mouse » Keyboard shortcuts and de-selected it. I move the mouse to the bottom left-hand corner of the screen to invoke Dashboard. 
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Modifying via Style Area

You can do this if the Style Area of the visible document is present at the left of the screen. To reveal the Style Area, choose the Word (or Edit) menu » Preferences » View » in the field titled “Style area width” enter 2.5 cm » OK. The Style Area appears on the left:
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Double-click in the Style Area (on the name of the style you want to modify) and the Modify styles window will appear with that style selected (saving the need to go Format menu » Style … » Modify … » select).

To close the Style Area, drag the bar at the right-hand boundary of the Styles Area over to the left edge of the document window, where it will disappear.

Creating buttons on toolbars to apply selected styles and formatting

I often make small toolbars containing the features I most commonly use. Depending on my needs
, they variously appear either:

•
all the time (the core toolbars, in addition to my personal Standard and Formatting toolbars); 

•
only when a document based on a particular template is open;

•
when I have a larger screen and there is sufficient room; and/or

•
when a particular document is open (including documents I send to other people, to make it easier for them to work on them). 

They are small so they can easily be closed or re-opened depending on these changes such as screen size, type of project requiring other toolbars etc.

I have made keyboard shortcuts for all of the buttons; whether I use them or the toolbars depends on my mood! (or as Elliott Roper would say, the phase of the moon).
I place the toolbars at the bottom of the screen (or, less often, at the side of the document) so that I do not have to move the mouse as much — for example, to pop down the standard Format menu to get to particular styles. The choice depends entirely on your way of working. Here are some of mine. They are constructed as shown under the heading “Creating the button” on page 112. Once you know what to do, it takes only a couple of minutes to create buttons and a toolbar; even less to move the buttons to different toolbars.

All the images on the following buttons were designed from scratch, as described under “Editing the button” on page 113. 

These buttons apply the default heading styles:
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Usually I apply heading styles by keyboard shortcut (Command-Shift-s » [number of heading, e.g. “1”] » [Return key]. It depends on my mood! (The reason I follow each style with an abbreviation, such as “1” in the foregoing example — Heading 1,1 — or “ct” in “comment in text,ct” is to avoid having to key the full name.)

The following toolbar applies the “nontoc” heading styles that I initially designed to avoid a heading being included in the table of contents, and which are described in the fourth bullet point in the panel on page 85. 
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Unlike the previous toolbar, on which all the buttons are images, these buttons are identified by text: when the button has been created, simply shorten the name provided by right/Control-clicking the button and selecting “Properties”. 

The next toolbar contains my most commonly used styles. Buttons, from left to right:

•
display the Tools » Add–ins window, allowing me to check or vary the template attached to the document;

•
apply my styles (as defined on page 169) for:

–
body text (roman
 followed by italic — the red “bt” lettering is only to make it stand out more on the toolbar, because I use it so often),

[see page 117 for important reasons why I don’t use Normal or other default styles 
for body text] 

–
sub-paragraphs (“s” caters for keyed Option-8 bullets; “sb” includes automatic bulleting), 

–
ditto for sub-sub-paragraphs (ss”),

–
table heading and table text styles, 

–
notes, and

–
comment text styles (both character and paragraph styles — see page 165).
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Most of the buttons on the following toolbar adjust the leading of a paragraph (or more than one if selected). The “n-over-6” button applies 6 points of leading under the paragraph, which I use when I went some room under the last line of text in a text panel. The two buttons either side of it add or subtract 2 points above or below the paragraph each time one of them is clicked (see pages 174 and 191). The second from the right applies “keep with next [paragraph]” formatting; the final one applies “keep lines together”. For the thinking behind the design of these buttons, see ‘Making your own toolbar icons’ on page 187. 
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Buttons on this toolbar open, respectively, the bookmarks, cross-reference and footnote windows.
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This one groups buttons that I use when pasting in text from elsewhere, which I perform constantly. Respectively, they apply the variant of English (Australian) that I use most often (see page 193); apply an extremely useful macro that performs Edit menu » Paste special » Paste as unformatted text (see page 191); apply a macro that causes the spell-check to ignore selected words (page 192); and apply a macro that removes duplicated paragraph marks from selected text.
[image: image46.png]



The following buttons insert tables with a given number of columns and in ths case my preferred layout of quarter-point horizontal lines only. They are invoked as AutoText items (seamlessly), as described on page 120.  I added a button that opens up the Borders and shading window at the right-hand end in case I want to vary the layout (e.g. to add vertical lines), and a button that opens up Table Properties (most often used to tick “Begin a group” to insert a line between the button and the previous one):
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I also have AutoText keyboard shortcuts for these and tables with other types of formatting. I hate having to create them from scratch!

Creating the toolbar

You can create toolbars that are specific to all documents, a specific document, or its template. Before you follow the instructions below, do one or more of these three actions:

•
To create a new toolbar that is available all the time (provided you don’t click on the close box), open a “New” (blank) document. This document will be based on the Normal template.

•
To create a toolbar that is available only when a particular document is open, open that document.

•
If you want the toolbar to appear only when documents based on a particular template are open, first note which template this is via Tools menu » Templates and Add-ins... » refer to the information in the field under the “Document template” heading. Then navigate to the folder in which templates are stored (Office folder » Templates folder » My templates folder) and open that template. Otherwise the toolbar will be present all the time (that is, it will be based on the Normal template) unless you make it apply only to a particular document (see below).

Then carry out these actions:

•
On the Tools menu, click Customize, and then click the Toolbars tab. 

•
Click New. 

•
In the Toolbar name box, type the name you want. 

•
In the Save in box, click the template or document you want to save the toolbar in. 

[Note: it’s quite easy to unintentionally add the toolbar to the Normal template when you only intend it to apply to a specific document or non-Normal template. If that happens, it’s easy to remove it from the Normal template via the Organizer.]

•
Leave the Customize dialog box open (you might need to move it out of the way), and do one or more of the following: 

–
To add a button to the toolbar, see under the next heading. 

–
To add a built-in menu to the toolbar, click the Commands tab. In the Categories box, click Built-in Menus. Drag the menu you want from the Commands box to the toolbar. When you have added all the menus you want, click OK.

In Word 2001, you may encounter a problem where the title bars of documents move up behind the toolbars at the top of the screen, out of sight. There appear to be several varieties of cause. The problem may occur after you close a particular document (i.e., the remaining displayed documents move up). In other cases the problem occurs when documents are opened up. Any of three actions may solve the problem. The first is to move any one of your toolbars a millimetre or two out of position, then very slowly move it back. When it is almost “docked” into place, it becomes temporarily “highlighted” with a darker border (this does not happen in Word X or Word 2004 — but the toolbar goes more decisively into place). Then you let go of the mouse button and the toolbar will dock, i.e. lock into the correct position. At the same time, the Word document(s) move out from under the menu bar. A variation of this solution applies if the problem occurs when you open a document that has its own toolbar. Move this toolbar to a position where it is not “docked”, such as the middle of the screen, where there is no other toolbar. The second solution is to quit Word (Command-q) and re-open your documents. The third (if the problem is persistent and bothers you) is to restore the document template (usually the Normal template) as described on page 54 — although this may not necessarily solve the problem. All very strange …

Creating the button

[These notes continue from above, and assume you are in the appropriate document or template.]

•
Show the toolbar you want to add a button to. 

•
On the Tools menu, click Customize, and then click the Commands tab. Confirm that the pop-down menu under the heading “Save in:” shows the document or template you want to modify.

•
In the Categories box, scroll and click a category for the command you want to add. 

•
Drag the command you want from the Commands box to the displayed toolbar. (If you don’t see the command you want under a particular category, click All Commands in the Categories box.) 

•
When you have added all the buttons you want, click OK.

Once you have put the new button on the toolbar, if you want a vertical separator line between this button and the one to the left of it, hold down the Command key and drag the new button a little to the right. If you want a vertical separator line between the new button and the one to the right of it, hold down the Command key, click on the “old” button and drag it a little to the right. To remove a separator line, hold down the Command key, click on the button to the right of the line you want to remove, and drag it a little to the left. (If you find it difficult to nudge the buttons the tiny amount required, use this method: hold down the Control key and click on the button to the right of where you want a vertical separator line » select “Properties” » tick “Begin a group” » OK.)

Editing the button

[These notes continue from above, and assume you are in the appropriate document or template.]

When you drag a style button to the toolbar, it will appear as “[name of style] Style” — for example, “comment text Style”. This will probably take up more space than you want. To shorten it, hold down the Control key and click on the button » Properties » [the field against “Name” will show the name selected] » type new name » OK.

Alternatively, you can substitute an icon for the name when you are in the Properties window. If you choose to design an icon from scratch (as with some of my buttons), you can subsequently choose View » “default style” then change the name of the button to an explanation that is useful when the screen tip is visible — such as in this example of a screen tip explaining the essential features of style “s”:
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(If the letter “s” on the button had been created as the name of the button instead of being drawn in, the screen tip would simply have read “s” too.)

More information about buttons and toolbars (including a work-around for the lack of an icon editor in Word X and Word 2004) is in Appendix D: Making buttons for formatting shortcuts, starting on page 183. 

Transferring a “non-Normal” toolbar to another template or document

If you have a toolbar that only appears when a particular document appears (or documents attached to a non-Normal template) and you want it available for another document (or documents attached to another template), you can easily transfer them via the Organizer. The steps are: Open the document or template in which you want the toolbar to be available » Format menu » Style » Organizer button » Toolbar tab » in the right-hand box, navigate to the template or document that has the toolbar you want » below the left-hand box, select the document or its template as desired in the “Toolbars available in” pop-down menu » click the Copy button to transfer it » click Close.

Applying a style via keyboard shortcuts

Keyboard shortcuts can be used to apply styles very quickly: with your insertion point in the paragraph you want to style, key Command-Shift-s followed by the style name.
 If you amend the names of your styles by following the full title with a comma and a short title (for example, the heading style above this paragraph is “Heading 3,3”) then you only have to key Command-Shift-s » [short title, e.g. “3”] » [Return]. Similarly, the style of the paragraph you are now reading is invoked by Command-Shift‑s » bt » [Return]. 

And similarly again, this paragraph style — “comment para,cp” — is applied by Command-Shift-s » cp » [Return].  I apply “cp” only when a comment occupies its own paragraph — that is, it does not appear in a paragraph with other text.

You can also apply a character style to one or more words or lines of a paragraph that has a different style. I use this facility to make comments for other people while we are developing the document, often. [This — style “comment text,ct” — is an example.] You should never apply a paragraph style to selected words — only a character style. 

In the latter example, to apply a style to only some words in a paragraph, I either: 

•
key the words then select them by holding down the Shift key and the left-arrow key. When all the characters are selected, I key Command-Shift-s » ct » [Return] as above; or

•
when I’m inserting standard text, click a button on a toolbar that both types the words and applies the style via a simple macro, as described on page 125. 

To restore formatting of characters in the paragraph to that of the underlying paragraph style, select the text » Control-spacebar.
 (I don’t select the precise words — I simply drag across them and adjacent words.) 

Stopping Word from changing your definitions of styles

Word may automatically apply a heading style to text that you have manually formatted (such as when you have applied bold + larger font size to “Normal” text). Or it will do the same in a document from someone else. To stop that, choose Tools menu » AutoCorrect … » “AutoFormat as you type” tab » remove the tick from “Define styles based on your formatting”.

A similar, usually unwanted, situation occurs if you tick “Automatically update” in the “Modify style” window: all instances of a style will change when you manually alter just one paragraph that’s in that style. This topic is discussed on page 152.

Checking whether a style has been manually modified or not

A quick check is unavailable

There is no longer an easy way to check quickly whether a particular paragraph’s style has been manually modified as in Word 5.1, which showed a “+” cue in the Style Area at the bottom of the document window if an automatic style had been manually modified. 

The Reveal formatting feature (see page 47) provides a great deal of information (more than you want, because it describes all the features of the automatic style). In the top area of both the “Paragraph formatting” and “Font formatting” panels it presents all the inherent characteristics of the automatic style (up to the space available in the panel); and in the lower areas of the two panels it describes the directly applied characteristics. But it does not include the name of the style in the selection nor any variation to the style. The following work-around achieves this in a round-about way.

Work-around

1. To see the underlying style

Display the Style area to the left of the document: Edit menu » Preferences » View » in “Style area width” field, type 2.2 cm » OK. This allows you to see the underlying style of each paragraph (but it does not include a “+” as in Word 5.1 that would let you tell at a glance whether it had been manually altered or not).

2. To see the variation to that style

To see the variation to the style shown in the Style Area, do the following:

•
Click (to drop in the blinking insertion point) in the place where you want to see the style characteristics. The Style Area entry to the left shows the underlying style of this paragraph.

•
Activate “Reveal Formatting” (I allocated the keyboard shortcut Control-Option-f to this command)* and click again at / near this point. The “Reveal Formatting” window appears. 

•
Under the two headings — “Paragraph formatting” and “Character formatting” — read only what is listed against “Direct”. This gives you the variation from the underlying style shown in the Style Area.

•
De-activate “Reveal Formatting” (Control-Option-f)*.

*  [You can also activate and de-activate “Reveal formatting” through the View menu, or via a button you could add to the Formatting toolbar (see “Adding to personal Formatting toolbar” on page 47)]. 
Alternatively, if you suspect little has been changed, you can restore the underlying style with Command-Option-q — and/or remove character formatting with Control-spacebar
 — to see if anything changes. 

Removing manually applied formatting from a style

To restore character formatting to that of the underlying characteristics of the paragraph’s style, or to restore a paragraph’s style, see under the heading “Modifying styles quickly” on page 107.

Removing styles from copied text to be pasted in

Some people like to have the option in each case to choose whether pasted text is formatted like the “departure point” or the “arrival point”, but if you do a lot of pasting from elsewhere you will probably conclude that Word’s implementation gets in the way. Accordingly, the following assumes that you have de-selected “Show Paste Options buttons” in Word’s settings (page 35).

If you have a number of paragraphs of text in a document you’re copying or cutting from, in one or more styles, none of which you want to take over to the document you are pasting into, and you want them when pasted in to be formatted in the one style (say, body text), it can be done easily by pasting in as unformatted text:

1.
Select text, including paragraph marks, and copy.

2.
Click in the document you want to paste into. Make sure that where you will paste into has a paragraph style that you want your pasted text to take on (e.g. body text — in my case my customized style “bt”). Click in that paragraph (e.g., before the first letter of text in such a paragraph) or press Return for a new blank paragraph.

3.
Edit menu » Paste special » Unformatted text. The style of all paragraphs will be as you have chosen (e.g. body text) in step 2.

I do this so often, because I paste a large amount of text from the web, PDFs and badly formatted Word documents, that I have created a special button to perform step 3 in one keystroke. Details are on page 189. 

With larger slabs of text pasted in this way, I usually want to apply other styles in addition to body text, but it’s usually best to start from a “base” of body text if that is in the majority. 

This process removes all text formatting, so if there is a large proportion of, say, italicised text in some paragraphs you may find it better to copy the text in such paragraphs — but without including the paragraph marks themselves — and to paste that text successively into blank “body text” paragraphs, thus preserving the italicising or whatever. 

One advantage of this process is that if someone has put a coloured highlight behind some of their text and you don’t want to retain it, all you need to do is select some text including the highlighted material, cut it (i.e., Command-x) and paste it back in, unformatted, without moving the insertion point. This is by far the quickest way of getting rid of such tedious formatting. 

For a similar technique for a complete document, see ‘Document from someone else — checking and fixing formatting of’ on page 130. 

Stopping other people’s styles over-riding yours when they receive your document

When you send a document to someone, often it doesn’t matter much whether it looks the same on the recipient’s computer as on your computer. If it’s essential to preserve the exact appearance, and the document doesn’t need to be worked on, creating a PDF file is the best option. 

I usually want the long Word documents I develop with colleagues to look more or less the same on all the computers involved. That’s important, for example, if the document has tables containing text of a certain size and line spacing: if the text is bigger on one computer the tables will take up more space and the pagination will be very different. Depending on the document, this can be a very serious problem. 

Similarly, if you have defined the body text of your document say in Normal style, as 11 point Times New Roman with 12 points of leading
 and the recipient has defined Normal style as 10 point Arial with zero leading, your document will look very different on their computer if they have configured it so that their definition of Normal predominates.
 

The setting that over-rides your specifications

What is the setting in the recipient’s computer that over-rides your specifications for a style? It’s the tickbox “Automatically update styles on open” in Tools menu » Templates and Add-ins. If the recipient activates this setting for the document, each time they open your document Word will search for an attached template and, if one isn’t found, will attach it to their Normal template.
 That’s when styles in your document will take on the characteristics they have defined or (more likely) the Word’s default style definitions. 

Copying the text into a new document may also alter the appearance

Whether or not the recipient has ticked “Automatically update styles on open” in Tools menu » Templates and Add-ins, their style definitions will also take over if they copy the text of your document into a new blank document. This occurs because the Normal style in the originating document does not copy over to the new document; instead, the Normal style of the new document takes force. 

Even if no text is styled with Normal style, modifications to other styles can result if the document is copied and pasted in this way — because most people draw some of the attributes of their document styles from the Normal style. (That’s just one of the many reasons why advanced users of Word don’t base their styles on Normal style.)

It follows that if you want to over-ride the definition of Normal in a document you have received, the easiest way is to copy that document into a blank document of your own. (When I do that, I always make sure I don’t copy the last paragraph mark, thus greatly reducing the chances of carrying across some document corruption — see ‘Corruption of documents, removing’ on page 127. Then I attach the new document to whatever template I want to use, via Tools menu » Templates and Add-ins.) 

Three alternatives to prevent over-riding

Depending on factors such as how often you exchange documents, how willing the other person is to go along with your suggestions, and so on, you can minimise the chances of your document changing appearance in these ways:

1.
The easiest way: walk them through the Tools menu » Templates and Add-ins and ask them not to select the “Automatically update styles on open” setting for your document. 

2.
If they frequently work on the document or documents of this type:  send them the template you have attached to your document and show them how to attach it.
 Other advantages flow from this option, in that for long documents it’s much better not to use the Normal template but to create your own template, which will be far less prone to corruption and will make it easier to improve as your experience with this document increases. When that happens, you simply send the updated template to your colleague. For more details, see the various headings below “Templates — convenient places to store styles and other formatting” on page 101, and “A template for this document” on page 102. 

3.
If the document regularly goes to more than one person: use styles that you create, which have different names from Word's default names, so that there are no defaults on their computer to take over as described. I also find that if I use Normal style, other people will manually amend it in all sorts of ways, whereas if I use “bt” style and provide a toolbar with the styles I’ve used they will tend to leave the formatting alone. For more details, including samples of such toolbars and covering notes for them, see the documents that are available from the same download page as this document. 

There are so many advantages with the third option, and no downsides, that it has become my standard way of formatting my documents. I should add a rider to that: I’ve concluded it’s not worthwhile to design heading styles that do not take advantage of the characteristics of Word’s built-in heading styles.
 

Nowadays I don’t apply Normal style to any paragraph

So, the upshot of the third option above is that nowadays I don’t apply the Normal style to any paragraph. (This has several other advantages, including being able to change the appearance of body text very quickly, and avoiding problems of broken numbering sequences.) For body text I use my own style, “bt”, as in the paragraph you are now reading. All other styles within the body of the document, such as for sub-paragraphs, notes and text in tables, are based on this “bt” style.
 I also recommend basing heading styles on “no style”, because this creates a break in the inheritance list that isolates the Heading styles as a group. 

[In a document that has a table of contents, I do actually apply Normal style, at two places: immediately before and after the table of contents. This facilitates the successive updating of the fields in the table and minimises the chances of corruption.]
To see the characteristics of these styles, choose Format menu » Style and scroll to the particular style, or refer to Appendix B: Specifications for some of my styles — especially to reduce the chances of changed appearance on other computers (page 169). It may help to open the style area while looking at the styles — see “Displaying style names in the style area of the document window”, below. 

Attaching a small styles toolbar to a document is helpful to my colleagues

Most of my colleagues adapted readily to using documents with styles, since most had been accustomed to manually re-formatting Normal style and were well aware of the limitations in longer documents, though they were usually wary of “getting involved with styles”. I followed John McGhie’s philosophy:

“It’s far more productive, I find, to put your effort into setting up your templates and macros so that ‘the right way’ to do things is also the ‘easy way’. Obviously, you have to put a bit more time into understanding exactly the job the users are trying to do and the way that they want to work. But when you succeed, users automatically do the right thing because they want to, which leads to you getting an almost perfect result that lasts.”

When I first arranged with the colleagues that I would attach to the document a toolbar containing buttons for the principal styles, they liked using the toolbar, and gradually started to use styles in other longer documents of their own. 

A toolbar like these is attached to this document: choose View menu » Toolbars » select “Headings and styles for this doc”. The toolbars vary with the documents. 

For more information, see “Creating buttons on toolbars to apply selected styles and formatting” on page 109. The template to Bend Word to Your Will (Word notes template.doc), which is also downloadable, includes the specific guidance on document formatting that I include with these documents. 

Avoiding broken numbering sequences

If you like to use automatic numbering and you share documents, you can avoid problems of broken numbering sequences by not using Normal style or basing other styles on Normal — see the notes on “Minimum maintenance” formatting on page 144.

Displaying style names in the style area of the document window

Done in initial configuration. 

•
Switch to Normal view if you are in a different view.

•
On the Edit menu, click Preferences, and then click View.

•
In the Style area width box under Window, enter a measurement for the width of the style area (I use 2.2 cm). 

In practice I only use this if I need to analyse the style structure of a document someone else has prepared.

Printing specifications of styles

To print a list of the specifications of styles in a document, choose File menu » Print » pop down the menu that shows “Copies & pages” to “Microsoft Word” » next to “Print what”, pop down the menu that shows “Document” to “Styles” » if you want a PDF rather than a hard copy, click on the “PDF” button at bottom left and choose “Save as PDF” » Print.

You will find it easy to see the logic behind the styles in this document by printing them. 

Revealing automatic and manually applied formatting of a paragraph

A button was installed on the Formatting toolbar to do this, and keyboard shortcut Control-Option-f was applied (for description, see notes for “Add a ‘Reveal formatting’ button” under heading “Adding to personal Formatting toolbar” on page 47). 

Action if button is not installed:

View menu » Reveal formatting (pointer changes). Click in the paragraph: a window will show (top of window) paragraph formatting and (below that) character formatting, with direct (manual) styling at the bottom in each case. To cancel: Esc or Command-period, or click “Reveal formatting” button (installed as described below) a second time. 

Installing a keyboard shortcut to reveal formatting:

To apply the keyboard shortcut, see immediately under the heading “Examples of keyboard shortcuts I’ve assigned” (page 76), and the shortcut listed against “Reveal formatting” in the table. 

Miscellaneous tips and reminders (in alphabetical order by main keyword)

AutoText (formerly Glossary)

AutoText enables you to store a piece of text, either formatted or not and long or short — or other entries such as tables, and to insert it via a keyboard shortcut.

AutoText entries stored in the Normal template (or other global templates) are available to all documents; entries stored in specific document templates are available only to documents based on those templates. 

If you use the Insert menu to insert AutoText entries, you will only be able to see the entries applicable to the style of the paragraph in which you have the insertion point (crazy? Word is like that…). 

To create a new entry

Put the insertion point in the style of paragraph from which you want to gain access to the AutoText in future. Select the item (e.g., text or table etc), including following space if applicable. Insert menu » AutoText » New » name the entry (I prefer to have an abbreviated term followed by explanation) » OK.

To insert an existing entry

These tables can be inserted by keying an abbreviated term for the AutoText entry. First, type the abbreviated term in the document (or rather, as much of the abbreviated term that is needed to make the entry unique — if you only had one entry starting with “m”, for example, you would only have to type this one letter). Then » Command-Option-v (on the PC, this is F3 or Alt-Ctrl-v). There is no need to select the abbreviated term.

They can also be inserted via the menu: insertion point in required place » Insert menu » AutoText » AutoText… pop-out » AutoText tab » either scroll to the entry or key first (or more) letters of desired entry » select » Insert (or Return key).

Example — creating and inserting a pre-formatted table via AutoText

I produced these entries for tables of one to six columns to save the time involved in doing this via the menus.
 The result is a huge saving against the time otherwise taken to format a table via Table menu » Insert » Table.

I formatted this example with the following characteristics:

•
only the horizontal lines show between the cells when printed; 

•
those lines are a quarter of a point in thickness (more elegant than the default half-point lines); 

•
the columns are of fixed width (since setting tables to automatically adjust cell sizes makes Word more prone to failure); and 

•
the style “table text” is applied in the cells. 

To space the table within the body text of the document, the table is preceded by a paragraph mark in “bt” style (my body text style; see page 97) plus “Keep with next” and no leading. A similar paragraph mark follows the table (without “Keep with next”, so that if a heading follows the table and the table or row is formatted as “do not break”, the last row is not pulled prematurely over the page):

	

	


Here are two factors that might influence how you format such an AutoText entry: 

•
If you want to start most of your tables with emboldened column headings, you would be better off applying an emboldened style to the first row, instead of “table text,tt”, before making the AutoText entry (for specifications of such a style — “table heading,th” — see the table that starts on page 169). 

•
The next choice depends on whether the final version of your document is “published” from Word or whether you work on Word “drafts” that end up in page layout applications. If the former, given that readers should never be asked to chase content across pages, before creating the AutoText entry select the whole table from the left margin and choose Table menu » Table properties » “Row” tab » de-select “Allow rows to break across pages”. (This also has the advantage that you can ensure that you don’t leave a widowed row behind: you can apply “Keep with Next” to the first (say) two rows, which will only work if you de-select (switch off) “Allow rows to break across pages”.) In practice, because I’m mostly working on drafts with “minimum maintenance” formatting (see page 161) I usually apply that characteristic manually when I need it. 

To make the AutoText entry, I selected the manually formatted table and the preceding and following paragraph marks (keying Command‑8 makes it easier). Then Insert menu » AutoText » New » the entry is named “1ch, 1 col horiz lines” » OK. I went on to make “2ch”, 3ch” and so on as I wanted. I used “1cb, 1 col all bordered” to describe the same table but with vertical lines visible too — which is the format that most people use. And “1cn, 1 col no visible border” et seq.

Similarly, I created an AutoText entry to instantly insert the green panels that contain details of new features in Word 2004, such as the one below. 

These tables can be inserted very simply and quickly by keying the abbreviation and following the sequence shown under the heading “To insert an existing entry”. If I’m setting up many tables, I use a special toolbar (see page 111). For the more commonly used tables I use keyboard shortcuts. 

	A Word 2004 problem with copying tables, and an easy workaround

Word 2004 introduced changes to tables which, among other things, can result in the table disappearing (leaving only the text) or acquiring the awful “Table Normal” so-called style, when you copy a table from a document and paste it into a new document. There is a simple solution: just include the paragraph mark that precedes (i.e., is immediately above, and external to) the table when you select the table for copying; or just drag the table across to the new document instead of copying and pasting.

[This green panel is another type of table, created as described above and inserted using AutoText.]


Bookmarks in cross-referencing

If you’re not familiar with cross-referencing, please read “Cross-references” on page 129. 

In Bend Word to Your Will, almost all of the cross-references are to headings. It’s quicker to insert them than cross-references to bookmarks. However, in some instances it’s more appropriate to make the “Reference type” relate to “Bookmark”.

Here’s an example of where it’s desirable to use a bookmark. I wanted a cross-reference to go to the toolbar image on page 44 rather than the heading a few paragraphs before it. Since that image is preceded by a one-sentence paragraph formatted as “keep with next [paragraph]”, that was close enough for cross-referencing. I therefore selected the words “standard toolbar” in the sentence (they could have been any word(s) or even a space). Then I chose Insert menu » Bookmark » gave it a name (“StdToolbar”) » Add. Assuming you ticked Bookmarks when you did your initial modification of Word’s settings on the Edit menu (page 31), you will see the bookmark is surrounded by two dark grey [ ] brackets. (It’s worth having them visible, especially if you are likely to be doing a lot of cutting and pasting — that way, you don’t split them, which can lead to interesting consequences!)

Having named the bookmark, it was easy to set up the cross-reference in the usual manner, selecting Bookmark from the “Reference type” pop-down list and selecting StdToolbar from the “For which bookmark” scrolling list. 

[image: image49.emf]
You can find them by keying Command-g, selecting “Bookmark” from the “Go to what” scrolling list, then selecting a bookmark’s name. I use them so often I have put a button on a toolbar.

You can remove bookmarks via the Insert menu » Bookmark » “Delete” button.

Bookmarks cannot be moved, but there is a work-around: select the text to be bookmarked with the old name in the new location, choose Insert menu » Bookmark » select the name of the existing bookmark, and click “Add”. Word will delete the old one automatically, leaving the re-named one in the new location. 

To change the case of words in a cross-reference — for example, if the text you want to refer to is in upper case and you want your cross-reference text to be in lower case, see “Cross-references” on page 129. 

In a long document, bookmark the Table of Contents heading

This practice saves me a huge amount of time navigating around long documents. It takes me to the table of contents from anywhere in the document, from where I can click back in via a table of contents entry.
 

I invariably apply a bookmark to the “Contents” heading — even in long documents received from other people.
  I then use a keyboard shortcut that invokes a simple macro to go to that bookmark. I have the keyboard shortcut in my Normal template, so it operates even in other people’s documents. 

First, create the bookmark in the document: select the word “Contents” (not its paragraph mark), choose Insert menu » Bookmark » type “Contents” in the “Bookmark name” box » Add. 

Second, set up the macro described under ‘A keyboard shortcut to go to the table of contents from anywhere in the document’ on page 196.  Create the keyboard shortcut as described under ‘Changing keyboard shortcuts’ on page 69 (you’ll find “Macros” down at the bottom of the “Categories” list referred to, below the list of menus).

If you don’t want to create a macro, try this instead (actually I do it in addition to the above): create a blank paragraph as the second-last paragraph in the document, then insert in it a cross-reference to the “Contents” bookmark. To make the cross-reference more recogniz​able as such, I apply my “to be hyperlinked,tbh” style to it, which makes the word blue and underlined; it could also be formatted manually. You’ll see one at the end of Bend Word to Your Will. To get to the table of contents from anywhere in the document, key Command-End ( [The key above the Up-arrow key], which will take you to the end of the document, then click on “Contents”.

[I also put a comparable hyperlinked cross-reference to the “Contents” bookmark at the top of the title page of Bend Word to Your Will, but that was only because the table of contents is somewhat further in than with most publications. It’s there for anyone familiar with the document who wants to go straight to the bookmark.] 

Borders

To put a border around a paragraph with direct formatting, choose Format menu » Borders and Shading …Borders tab » apply values, e.g. line thickness » Options … button » apply distance from text. (It is not possible to change the default values that appear in the Border and Shading Options window; they must be changed manually each time.)

Comment, deleting

Hold down Control key; click the comment reference mark; choose “Delete comment”.

“Comment” feature, a simple substitute for

Word’s “Comment” feature (that is, for making remarks in the document via Insert menu » Comment) can be quite useful, albeit at the cost of some electronic complexity of the document that can lead to corruption. However, the feature is not convenient for people who are involved in commenting on the document using a hard copy. Some of my colleagues prefer to look at hard copy, especially when flying. Others just don’t like the Comments feature. So I find it’s more convenient, and just as quick, to include my comments in the running text. 

The comments need to be distinctive so they stand out in both electronic and hard-copy form. I use either of two styles, depending on whether I make the comment in a complete paragraph (a paragraph style) or as a few words (a character style): see “Paragraph styles and character styles — what’s the difference?” on page 99. [Please note: you should make sure you clearly understand the distinction between character and paragraph styles.]

A great advantage is that you can easily hide the comments when necessary by re-defining the style as hidden text, in that document only. This takes only 15 seconds. However, if I want to run off a PDF or hard copy for someone who doesn’t need to see them I’m more likely to delete the comments altogether by a search-and-replace command (replacing text in that style with nothing) — because I usually have my printer set to print hidden text. This is also quick to do. I immediately follow that with a Command-z “Undo” command to restore them. If the document is important and there are many comments, I do it on a Saved As copy.

There are two alternative formats, in the interests of document stability (because you should only apply a paragraph style to an entire paragraph). The first bullet-point option below is for when you want to create an entire paragraph comprising the comment; the second is for inserting a comment within a sentence.

I made the text in these two styles stand out by being in Arial 9 point blue italic in both instances:

•
I named the paragraph style “comment para,cp”. I created it via Format menu » Style » “New” button, based it on “no style”, chose “bt” as the style for the following paragraph, and also defined it as follows: 

–
font: Arial, 9 pt, italic, blue;

–
paragraph: flush left, line spacing at least 12 point, space before 10 point [note: there are good reasons also for making this spacing after the paragraph — see note 4 in appendix C], and widow/orphan control; and 

–
language: my version of English (Australian).

This blue paragraph is an example of a paragraph styled in “comment para,cp”

•
I named the character style “comment in text,ct”. I also created it via Format menu » Style » “New” button. There I selected “Style type” (in the pop-down menu at top right) as “Character”. This resulted in “Default paragraph font” being automatically inserted as the basis for the style. I further defined it as follows: 

–
font (in addition to “Default paragraph font”: Arial, 9 pt, italic, blue; 

–
language: my version of English (Australian). 

Here is an example of a comment involving selected words within a paragraph using this character style. I often use an arrow to point to the words I’m commenting on (see the first row in the table on page 81 for a quick, mouse-free way of making these arrows). ( such as here
To apply the style to comments within a paragraph, I type the comment, select it (by holding down the Shift key and clicking immediately before the first character, or by dragging, or by using Shift-arrow) then apply the “comment in text, ct” style by keyboard shortcut, as discussed on page 114. 

To apply the “cp” style to the entire paragraph (the first bullet-point above), do not select the paragraph — just have the insertion point anywhere within it.

I usually type in one or more hash signs (“#”) before these comments so I can easily find them — the quantity of hash signs signifies the importance or urgency. When clearing up these comments in a document I therefore do a search for “###” first, then “##” and finally “#”. 

To revert to the style of the underlying paragraph, you simply select the blue text (and, in the interests of selecting it more quickly, you can include nearby text too) and key Control-Spacebar
. 

Appendix G: Automating standard comments via AutoText items on a toolbar, starting on page 204, describes how to prepare buttons on a special toolbar to add standard comments — they are useful if you make comments frequently. 

Conversion of text from other formats when converters don’t work

If your text converters don’t work and you just want to obtain the text of an electronic document in non-Word format, open the document from within Word (File menu » Open » note the current setting in the “Show” pop-down menu » select “Recover Text from Any File” » Open. Although the resulting text will be unformatted, it’s often better that way, in that if you have your styles and templates set up properly, reformatting a whole document is much quicker than dealing with one that has come in from a different format. Important: See below: “‘Recover Text from Any File’ is a dangerous sticky setting”. 

For a more permanent solution: MacLink Plus at www.dataviz.com/products/maclinkplus
“Recover Text from Any File” is a dangerous “sticky” setting

Sometimes as a last resort you will have to open a corrupted file in a format that removes all the document formatting. It’s achieved via File menu » Open » Show [in some versions it’s “Files of type”] pop down “Recover Text from Any File”.

Be aware that this is a “sticky” setting — that is, whatever you choose will remain as a setting for opening the next document. This is notorious for scaring the daylights out of people who forget that they have used the setting, because the next time they open a Word document they think it has lost its formatting. Opening other documents appears to confirm that all documents have suffered the same fate. 

The solution is — immediately after having used this setting — to choose File menu » Open » select any other Word document » select, in the “Show” pop-down menu, the option that showed previously (such as “All Word documents”) » Open. Then close the document. The setting you chose will remain. 

Corruption of documents, removing

Corruption is problematic because the difficulties caused can take some time to trace and remove — not at all welcome if a deadline is involved — or at worst can suddenly lock up a document and prevent it from being opened altogether. All documentation professionals have experience of it, including helping others whose documents have corrupted. It is by no means a hypothetical occurrence, although obviously the shorter and simpler the document the less likely it is to occur.

It is a vexatious problem for Word users. Corruption partly originates in Word having more than 30 million lines of code; partly in marketing-influenced “features” added by Microsoft over the years without a full understanding of the side-effects; and partly from using features that are more prone to corruption. It is only the last of these factors that can be moderated by the user. I won’t enter discussion of how reasonable or unreasonable it is for the user to have to resort to that, other than to say I tend towards the “unreasonable” end — but I also acknowledge that if one can avoid the corruption-inducing features, Word can be extraordinarily powerful and time-saving and there is therefore some self-interest in seeking ways to minimise corruption. Bend Word to Your Will is based on pursuit of that aim, and by following the practices described in these pages it is extremely rare for me to encounter any corruption in documents I have created, despite most being long, quite complex, and intensively developed in most of my work. However, that’s not much consolation if your work makes it essential to incorporate, for example, automatic numbering, tracking of changes or table features that are at best “flaky”. 

Word has moved to a radically different, XML-based structure with Word 12 (Word 2007 for Windows, and Word 2008 on the Mac). It has been said that most (many?) of the traditional problems with corruption disappear with the new structure. I haven’t yet tested the extent to which this is true. 

In the meantime, here are my thoughts.

First, an excellent article by Word MVPs Beth Rosengard and John McGhie, at http://word.mvps.org/Mac/DocumentCorruption.html, is essential reading. 

How do you know when a document is corrupted? Some corruption will not be obvious at first, but usually corruption becomes evident — suddenly or slowly — when slowness, odd behaviour or crashing of the application occurs in a document or group of documents, even though your Word settings are appropriate. 

If this behaviour occurs in all documents, your Normal template is highly likely to be corrupted. To fix this, see “What to do if you have a damaged Normal template” on page 54. However, most of the following discussion applies both to document and template corruption.

Sometimes (but not always) a way of seeing whether the file is corrupted is to click on and hold down the sliding “thumb” that moves up and down the right-hand scroll bar of the document. Moving it up or down will show the number of the page that you are travelling past. If you see unusual numbers (e.g. starting at 105 when it’s a 20-page document) or the sequence of numbers jumps, the document is corrupted. Other symptoms can include infinite repagination, incorrect document layout and formatting, unreadable characters on the screen and crashes when you load or view a particular file. 

[At this stage, many people — especially those who have come to the Mac via Windows — reinstall Microsoft Office. However, reinstalling almost always has no effect at  all, because the things that get broken are outside the Office folder and are not over-written by a reinstallation. And reinstalling can subsequently confuse the “Remove Office” tool.]
As with any other major procedure on a document, do a “Save as” first, and work on the spare copy. Then you will always have the original if anything goes [more] wrong! To be even safer, do a back-up to a medium other than your hard drive.

The first way to fix most corrupted documents is to paste everything except the last paragraph mark into a new blank document. This forces Word to repair the document’s internal structure. To do this, key Command‑8 to show all paragraph marks (if you normally have them invisible) and select all the document except the last paragraph mark — I prefer to key Command-a to select the whole document, followed by Shift-[left arrow] to exclude the last paragraph mark. Then copy and paste the selected text into the new blank document. Then save under a new file name and the new document, then re-open it. 

You will have to set up any headers and footers again in the new document. If the corrupted document was attached to a special template, you may want to re-attach the new document to the template if you want to be able to update changes to formatting in future — but you will need to test whether the problem lies with the template rather than only with the problem document. 

Pasting everything except the last paragraph mark in the document most often solves corruption problems because the document properties stored invisibly behind the final paragraph mark are the elements most likely to be corrupted.
 

If that does not solve the problem and the document has section breaks within it, follow a similar procedure again but, this time, copy each section in turn except for the last paragraph mark in each section — that’s because most frequently the final paragraph mark in a document tends to harbour corruption, and after that the section breaks within the document are the most common source (that’s because section breaks are a very complex part of Word; they create an internal structure very similar to having multiple documents embedded in a single file). 

If that doesn't resolve the problem and one or more tables exist in the document, then there is a good chance that a table is corrupted. Using a fresh copy of the original, split the document until you locate the area of corruption. This is easiest done by opening, selecting say the first half, deleting the selected text and saving under a new name. If that works, go back to the full copy and try the same with the other half. Continue this until you find the corruption. If it is in a table, choose Table menu » “Convert table to text”, save the document and test it. If that has worked, use “Convert text to table”. 

For more about corruption in tables, see “Tables” on page 60.

You can greatly reduce the chance of corruption in long documents by eliminating section breaks and instead using page breaks (which never corrupt) or the techniques described under the heading “Header that shows the wording of the chapter heading” on page 139 or “Header that displays the edition details, or other details, from the front page” on page 140. However, it’s necessary to include one or two section breaks if you want, for example, to change the page format from portrait to landscape; have a “different first page” in a section (for example, because of header requirements); to re-start page numbers at “1” (such as after the page containing the table of contents); or to restart footnote numbering by chapters. 

In Word 2004, saving as a web page (not “web page filtered”) is another good method of curing corruption. Make sure you choose the option “Save entire file into HTML”; then close the corrupted document; then save the web page version as a Word document.
 Check it visually for errors: if it was badly corrupt, bits of text may be missing and some styles may have disappeared. Screentips for hyperlinks will be lost from the document when it’s re-opened in Word. 

Other methods include opening the corrupt document in a text editor such as BBEdit or in TextEdit (Mac OS 10.3) or AppleWorks and looking for obviously weird data in the file and deleting it. And for shorter documents it’s easy to simply copy (or drag across) the text in paragraphs without the paragraph marks (one of which will contain the corruption) into a new, clean document. Holding down the Command key before clicking in one of these sentences, and dragging if you need to pick up more than one sentence, is a very quick way of doing this. 

Various causes of corruption are also described in many places in these notes; it’s best to find them by doing a search of this document for “corrupt” (via Edit menu » Find). Some are tabulated in appendix A (pages 165 and 166). 

EndNote software, useful though it may be, has been frequently reported to cause problems for Word, especially while the “cite while you write” feature is turned on. (This may have changed in recent times, however.)

For other solutions, check the MacWord MVP newsgroup. 

For recovery of badly damaged documents, see page 148. 

Crop marks

A good article is at http://sbarnhill.mvps.org/WordFAQs/CropMarks.htm
Cross-references

Cross-referencing can be very handy in some documents where you want to be able to move around quickly — such as in these notes. Word’s cross-references are easily updated, so that if you move text around and the pagination changes you can update the cross-references by keying Command-a to select all text and pressing the F9 key (see the note on page 21). If your document has footnotes that contain cross-references, you need to update them separately from the main document. Use Normal view, then choose View menu » Footnotes » click in any footnote » Command‑a to Select All » F9.

Inserting a cross-reference is simple: with the insertion point in the right place, choose Insert menu » Cross-reference. Then make your choices accordingly, including from the “Reference type” pop-down list. Make sure that “Insert as hyperlink” is ticked so that by clicking on the heading title, page number or whatever you will be taken to it. 

I insert cross-references so often that I created a keyboard shortcut to open the cross-reference window.

To convert cross-references (and any other fields) to plain text, simply select the text and key Command-Shift-F9. Other than keying Command-z soon afterwards, this action is not reversible. 

To change case in a cross-reference — for example, if the text you want to refer to is in upper case and you want your cross-reference text to be in lower case — you can include instructions in the cross-reference field. Click to one side of the cross-reference field, arrow-key to the edge of the field, and select the field by holding down the Shift key and continuing to hit the arrow key. Then key Shift-F9 to reveal the code. With the insertion point to the left of the “}” bracket, type in the instruction (“\* Lower ” in the lower-case example — note the space). For more information, see “Create a cross-reference” and “Capitalization formats” in Word’s Help. When finished, key Shift-F9 again. Then move the pointer to the left margin, click to select the line and key F9 to update the field to lower-case.

( F9 is now taken by the Mac operating system: for a work-around, see page 21.)
	Very slow cross-referencing to headings in Word X and 2004

In Word X and 2004, depending on the length of your document, it could take up to a minute or more after you opened the Cross-reference pane and choose Reference type » Heading. Other types of cross-referencing in Word X and 2004 (such as to bookmarks) are instantaneous. 

Service Pack 2 for Word 2004 fixed the problem. 


Custom dictionary

The custom dictionary can be edited easily.  Just locate it (see page 49 or do a Spotlight search) and open it with TextEdit, delete or add words, save and quit.

If you add a word to the custom dictionary all in lower case, the spelling checker will accept any capitalisation. If you add the words with mixed case (such as initial capitals) the spelling checker will accept only that capitalisation.

Document formatting, best ways of

Although most of these notes deal with this subject, some particularly important ones are under the heading “To avoid having to manually alter your formatting” on page 163. It’s well worth getting familiar with the “Styles and templates” section starting on page 85 — especially “The minimum you need to know about styles” on page 92. 

Document from someone else — checking and fixing formatting of

When I receive somebody else’s document to work on, I like to understand clearly how they have formatted it. First I check its underlying formatting via a keyboard shortcut for the Reveal Formatting command (see “Adding to personal Formatting toolbar” on page 47). In particular, by checking in several places through the document I found out how much manual formatting has been applied. If the document appears to be inconsistently styled, I open the Style Area (page 109) and/or check whether the structure is clear in outline view (Command-Option-o) — if heading styles have not been applied consistently, it will show up here.

The most common modification I make, since I generally use an English (Australian) dictionary, is to apply that language to the whole document as described on page 142.

If I’m going to work extensively on the document and the time spent on cleaning up the formatting will be justified by quicker work and less frustration later, I will change it to a more consistent, styles-based format. This involves a choice between these three alternatives:

•
Manually change the applied styles within the received document. Usually I only do this when the document is from someone whose formatting practices are familiar to me, since it transfers into your document all the styles that were in the sent document — including any corruption that may be present.

•
(The following also applies to html text that has been copied from the Web.) Paste the text, without any of its styles, into a new document as follows:

–
Select the text in the web page or the received document (and if it’s an entire Word document, to minimise corruption select everything except for the last paragraph mark by keying Command-a then Shift-[left arrow], then Command-c to copy). 

–
Display a new blank Word document on screen next to this document (based on the Normal template or a tailored template, as you choose). If you don’t have screen space, you could close the original document after printing a copy so you can observe the original appearance of the received document. 

–
In the new blank document, click in a paragraph with a body text style (in my case, “bt”), then choose Edit menu » Paste Special » Unformatted text. I do this so often that I created a macro (page 189) that does this with a keyboard shortcut.

–
Go through the new document and apply styles. It’s usually quicker to sweep through applying one style at a time: for example, apply Heading 1 style via keyboard shortcut, menu or button just once, then repeat by keying Option-Return for all the other instances. After all instances of Heading 1 are applied, repeat for other styles in turn. This may strike you as boring (it is) and time-consuming (usually not very, and much quicker than it might first appear it will be) — but the pay-off is complete freedom from any corruption in the original document. 

For a similar technique for text that is less than a complete document, see ‘Removing styles from copied text to be pasted in’ on page 116. 

•
In a short document, drag text across into another document shell (but not paragraph marks — holding down the Command key when clicking on the sentences in a paragraph selects the sentences only, without the paragraph marks). This method, however, does not remove directly applied formatting, so that — for example — a manually emboldened piece of Normal text when dragged across to a paragraph styled in heading (i.e., bold) style will take on a non-bold appearance.

My preference is to make sure that none of the styles I use is based on Normal and none is set to Automatically Update.

Document map — be careful before you use it

“Document map” is a vertical pane along the left edge of the document window that displays an outline of the document’s headings. You can use it to move quickly through a document and to keep track of your location in it — for example, by clicking a heading in the Document Map pane. It’s accessible via View menu » Navigation Pane » on the pop-down menu select Document Map.

Document Map uses a rather complex algorithm to do its work, and it isn’t perfect. When I last tried it extensively, it would make changes that could not be reversed. It is also reported as causing document corruption. So the first recommendation is to try out Document Map on a “Saved As” copy of the document. You should also look up the articles under “document map” in Word’s Help before experimenting. 

If you only need to see the overall structure of your document and do not need the navigational capabilities of Document Map, consider simply switching to Outline View (key Command-Option‑o ( [“oh”, not zero] and click on one of the heading number buttons to confine the displayed outline to a particular level of headings; to return to Normal view, key Command-Option‑n). 

Sometimes, though, I prefer to have some navigational tools to go to the main parts of long documents. Avoiding Document Map, I do that by using:

•
a keyboard shortcut to go to the table of contents from anywhere in the document (see page 196), from where I can click on any of the table of contents entries

•
a small batch of hyperlinks that I quickly set up at the beginning of main parts of the document to go to the other main parts (they need not necessarily be at the start of chapters).

How does Document Map work, and where do the problems come from? Essentially, to derive the structure of a document from which you can navigate around, Document Map will guess that any paragraph that is less than 80 per cent of column width and has no paragraph style applied is a heading.
 

I most recently tested Document Map occurred in Word 2004 after I heard that the feature had been improved. I used a specially prepared document that had all text styled only in body text, and several two-word paragraphs that would presumably be interpreted as headings. I was pleased to find that Document Map did not apply direct (e.g. bold) formatting to these short paragraphs as it had in Word 2001. However, it failed to identify all such paragraphs as headings. After manually emboldening several of these paragraphs, including the ones not previously identified as headings, Document Map correctly identified all such paragraphs as headings. Next, I applied heading styles (see page 98) as I normally would, and it was also pleasing to see that all such paragraphs were identified by Document Map as headings. 

However, my testing did not extend to establishing conclusively, in a wide variety of documents, whether Document Map in Word 2004 has overcome two previously nasty habits: namely inappropriately applying an outline level to body text paragraphs of less than one line, and — much more importantly — imposing incorrect formatting in a long document that cannot be removed by closing the document and not saving changes.
  

This matter is too important in relation to the types of documents I work on to be less cautious, but for simpler documents the signs are that Document Map is now tranquilized. 

Dragging text from one document to another

This is an excellent feature of Word. I find it’s best to position the place at which you want to drop the text about half-way up the screen. Then select the text in the other document and drag it (fairly quickly, or you will get a dose of the “runaway scrolls”!) to that spot, and drop. There is no need to hold down a modifier key unless you are working with two views of the same document — that is, you have chosen Window menu » New window — in which case you would hold down the Option key.

As with dragging text within the same document, I find quite often that it doesn’t work the first time — but invariably it will work at the second attempt. Strange. Word is like that … 

Fast Saves — avoid this “setting from hell”

“Fast Saves” is a feature that was very useful for the first versions of Word operating from floppy discs. Essentially it adds supplementary files to the main file, which in the early days of floppy drives and slow processors sped up the Save function considerably. However, it should have been removed years ago, because it rapidly corrupts any document for which it is left turned on. Apparently it has been retained because it is too deeply embedded to remove. 

Ironically, if anything, “Fast Save” slows down operations on today’s processors. And in modern versions of Word, every ten saves, or every time you save to a different file, or when you close Word, the application will perform a “full save” in any case. 

The feature is enabled on the Edit menu » Preferences » Save » Allow fast saves. Make sure the tickbox is empty. 

It’s no exaggeration to say this is the “setting from hell” — it’s the most common source of major corruption of documents and the software itself. There are no advantages in using it, and some ugly disadvantages. 

Sometimes you will receive a document that is far bigger than it should be (see the article “File size, keeping it small”, below, for other “bloat” factors). If it was developed with “Fast Saves” on, it will have collected additional material at the end of the file. Sometimes such a document grows to several times (even 20 or more) bigger than it should be. The solution is to do File menu » Save As …. And it probably won’t hurt to copy all of the document other than the last paragraph mark and paste it into a new document, as described on page 127.

Field, converting to plain text

To convert the contents of fields (for example, table of contents and date fields) to text, select the field (if the insertion point is immediately after the field you can use the Delete key to do so; or Command-a to select the whole document) then Command-Shift-F9. Other than by keying Command-z or clicking the “Undo typing” button on the Standard toolbar soon afterwards, you cannot reinstate the plain text to fields. Therefore, if in doubt, it’s best to apply Command-Shift-F9 to a “Saved as” copy of the document. 

Field, showing the scripting in

To reveal the scripting in a field, select the field and key Shift-F9 (see the note on page 21). Repeat to return to the view of the results, i.e. the original presentation. 

Fields, updating

Key Command-a to select the whole document and press the F9 key (see the note on page 21).

You can get Word to update the fields whenever you print, avoiding the embarrassment of making a last-minute change and forgetting to update the fields. Choose Edit menu » Preferences » “Print” » tick “Update fields” under the heading “Printing options”. 

“Find” command — useful keyboard shortcuts

See page 149. 

File size, keeping it small

The over-all limit to text in a Word file is 32 MB, i.e. excluding any graphics (you can obtain this and other information by choosing Help menu » Microsoft Word Help » “Search” button at top » type “limits” in the field » click “Search”). 

Many factors make Word documents larger than they ought to be. Here are the most common:

•
Fast Saves: A document developed with “Fast Saves” on will collect additional material at the end, often causing the size to be several (even many) times bigger than it should. But that’s the least of your problems if you use Fast Saves — see the notes on page 133 about why you should never use this setting.

•
Track Changes: A seductive feature, which is being used more and more as a bureaucratic “prop”, especially in organisations that employ a lot of control freaks! File sizes 20 times what they should be are reported regularly as a result of this feature. I’m no fan of leaving this feature on while working, mainly because it tends to make you concentrate on the minutiae of the words, to the detriment of the over-all thrust and tone of the writing. Of course, being able to see changes when you get a document back certainly has its place, and this capability is marvellous for spotting minor changes in a long document (e.g. changes with legal effect). However, I don’t view changes by leaving Track Changes on, and I try to discourage the practice among colleagues with whom I share documents. Instead I make a “Saved As” copy and do a document comparison on that copy. This achieves the same thing as Track Changes without much downside, and does no damage to the document (e.g., corruption arising from more than one layer of Tracked Changes or with merged documents). For further information on what’s involved, see “Track changes, turning off” (page 63) and “Track changes, important settings for” on the page that follows it..

•
Preview picture: File menu » Properties » “Summary” tab » clear the “Save preview picture” tickbox. 

•
Versions: File menu » Versions » make sure “Automatically save version on close” is not turned on.

•
Embedded graphics: that is, graphics that have been copied into the document. The alternative is to link the Word document to the graphic files. It’s best to have such files in the same folder as the Word document, since they will be less vulnerable to being moved around, which results in the links being broken. Similarly, you should consider getting recipients of such documents to store the graphics files in their same folder.

•
A corrupt document: Do a “Find” command for “corrupt” in this document to see various discussions. Very often, taking the action shown under “Corruption of documents, removing” on page 127 will solve the problem. 

•
Section breaks: Documents can be kept remarkably “thin” by avoiding section breaks. If you use Heading 1 as your chapter heading, you can incorporate a “Page break before” in the style. If you have a different header
 in each chapter, you can use a StyleRef field in the header (see “Header that shows the wording of the chapter heading” on page 139) to change chapter headers. Setting up the page numbering is simpler with this method, too.

•
Direct formatting rather than styles-based formatting. Enough said.

Font size changes when you move the border of the document window

If this occurs, it means that “Page Width” has been selected (i.e., the document will re-size according to the width of the window). Usually this means that the display isn’t going to be at the size that’s best for viewing the main fonts.

To set a fixed value, go to View menu » Zoom and either:

•
click on one of the fixed-size options, or

•
for a non-standard option, type a number in the “Percent” field (no need for “%”) then » OK (my preferred size when 11 point Times New Roman is used for text in the body is 125% or 140%, depending on what machine I’m on, so I type in “125” or “140” followed by [Return key] — with Arial I use 125, but those figures reflect the fact that I work on Mac laptops with a second, LCD, screen usually attached.

You can achieve the latter more quickly by clicking in the Zoom pop-down box on the Standard toolbar and typing your preferred percentage followed by the Return key. This is illustrated on the second button from the right in the Standard toolbar shown on page 47.

Fonts that retain the same pagination on Macs and PCs

Fonts in Word X, 2001 and earlier

Despite their similar appearance, the standard Macintosh TrueType fonts (Times, Helvetica, and Courier) are actually quite different from the standard Windows fonts (Times New Roman, Arial, and Courier New). These fonts come from broadly the same font families, but the font metrics of the font sets are different. Even a very short document that uses these fonts can exhibit noticeable change in pagination when you move it to the other platform, and long documents can display a considerable amount of change.

Word for the Macintosh in these versions uses Microsoft’s TrueType font set for the Macintosh, including Times New Roman, Arial, Courier New, and Wingdings. These are the same TrueType fonts that come with Microsoft Windows.
 This offers a consistent base set of fonts for every Word user, minimizing font-mapping difficulties when you cross platforms.

For a broader discussion of interchangeability of documents between computers, see Appendix A: The main “minimum maintenance” features of my documents, starting on page 161. 

	Fonts in Word 2004

This is what Microsoft says about font compatibility in Word 2004: “The fonts that are installed by default with Office for Mac are also installed with Windows versions of Office. So it’s a safe bet that when you choose from these fonts, other people will see the same fonts that you see. You can choose the following fonts with confidence: Arial, Arial Black, Century Gothic, Comic Sans MS, Copperplate Gothic Bold, Copperplate Gothic Light, Curlz MT, Edwardian Script ITC, Impact, Lucida Handwriting, Monotype Sorts, Tahoma, Times New Roman, Verdana, and Wingdings.” ( [CH note: Courier New is now absent] 
A radical change has occurred with screen display and fonts in Word 2004. Unicode fonts are able to display for the first time, and cross-platform compatibility has greatly improved. 
The first thing I observed in Word 2004 was that it uses Times New Roman as the default font. Now, when a document in Times New Roman goes to Word 2003 on a PC, no font substitution is needed and the document should appear the same. (If a PC has to open a Mac Word document containing Times — a Mac font, still included in the suite of fonts for Word 2004 — the PC will automatically substitute Times New Roman, which takes up different space and will therefore paginate differently.) 

You do not have to use the default font in Word, but unless you set your Normal template to be something else, in Word 2004 the default font will be Times New Roman rather than Times. 

Times New Roman looks much better when displayed in Word 2004 than it did in Word 2001, and Times looks much worse, so it makes sense to change over. Times New Roman is better-looking when printed, too. 

The improvements in Word 2004 go far beyond the fonts. Microsoft changed the way text is laid out on the page to match the way Word 2003 on the PC lays out its text. The text layout engine has changed significantly (it was QuickDraw; now it’s the Apple text layout for Unicode, called ATSUI) to accommodate the range of Unicode characters previously unavailable on the Mac, of which Times New Roman is one, along with Verdana, Trebuchet MS, and one of the Asian fonts.
 

One consequence of this change is that documents may display better at a different magnification (“zoom”) setting — for example, these notes are best displayed at 125% on my LCD screen whereas before Word 2004 they displayed well at 110%. 
If you’re in Word 2004 and get “(Default)” in the definition of a style, that’s because the Normal template imported from the earlier version of Word contained Times font as part of its Normal style. 


Fractions, formatting of

See Appendix F: Formatting of fractions using AutoCorrect (page 200).

Function keys, if they don’t work in Word

When you hit a function key for the first time in Microsoft Word, you may see a message saying “The F1 through F12 keys can be set up to open an application … Do you want to open the Keyboard control panel now?” Clicking so that a tick appears in the tickbox “Do not show this dialog again” will bring the function keys into operation in Word. 

An additional problem is that recent versions of OS X have introduced keyboard shortcuts the same as shortcuts frequently used in Word. The OS cuts in first in response to the shortcuts — for example, F12, which operates “Save As”, opens Dashboard. Descriptions of work-arounds start on pages 21 and 108. 

Graphics, source of advice on

I don’t usually incorporate graphics into my Word documents, because for most of my work a graphic designer eventually does that in page layout software. (Generally I just leave instructions in the Word document on where to place images. However, in drafts I sometimes drop in rough screenshots from websites etc., obtained by keying Control-Command-Shift-4 which, after dragging the cross-hairs to select the image, puts it on the Clipboard ready for pasting into the Word document. Often I then re-size the screenshot via Format menu » Picture » Size » Scale » 80% (if you enter the number in the first box, the second box will update when you click in it, provided “Lock aspect ratio” is ticked). The percentage that looks best on your Mac may be different, especially if it isn’t an LCD display.) 

Frankly, I’m glad I don’t need to incorporate much in the way of graphics, because there are many accompanying problems in Word. However, some good information is on the Word MVP website at http://www.word.mvps.org/FAQs/DrawingGraphics.htm

In general, other than as mentioned above, it’s a good tactic to size a graphic in the originating software so that it does not need to be re-sized in Word, avoiding fuzziness in printing. ###
Graphics, reducing file size caused by

Graphics can greatly increase the size of a Word file, but you do not have to include them in the file — if the file becomes bloated and slow, you can use external graphics, linked into the document. Then it is very much easier to work in Word. (If it’s essential to include the graphics when the document is finished — or prudent, such as when sending the file to others — you can put them into a “Saved as” copy at the last moment.)

Do a “Save as” of the document to retain a good copy if anything goes wrong. Then, on one of the copies, save the graphics out of the document as separate files — preferably into the same folder as the document (makes it easier to work). Then choose Insert menu » Picture » From File » navigate to the folder. Select (tick) “Link to File” and make sure to de-select “Save with document”. Go through the document after you have done this and check that all the graphics appear and the document scrolls well — sometimes people report that the reality with linked graphics isn’t nearly as good as the theory. 

Graphics, speeding up document containing

Ticking “Image placeholders” (Edit menu » Preferences » “View”) will speed things up by relieving Word of the necessity to render graphics. You can turn these options back on whenever you need them.

Header that shows the electronic title of the document

	An amazing number of people use the word “header” when they really mean “heading”. This discussion is about the text that appears across the top of every page.


It’s easy to have Word insert text in headers (or anywhere else, for that matter), that’s gathered from somewhere else. For example:

•
the electronic title of the document; 

•
the chapter heading; or 

•
words you specify, such as the details of the edition on the front page of a draft. 

This first example describes how to follow the longstanding convention of having the publication title in the header of left-hand pages in documents printed double-sided. 

To set up separate odd and even headers, choose Format menu » Document » Layout » tick “Different odd and even” and “Different first page”, and apply to “Whole document” » OK.

To make the header show the electronic title of the document, choose View menu » Header and footer. Key into the header as follows (note the spaces): 
{ FILENAME \* FirstCap \* MERGEFORMAT }

The following field shows the title of the document you are reading now: 

Bend Word to your Will -- the last Word 2004 version.doc
If you’d like to reveal the scripting in this field, select the field (e.g. by dropping the insertion point to the right of the field, holding down the Shift key and pressing the left-arrow key) and key Shift-F9. Repeat to return to the title. (You can copy the above field, paste into your header, then select the field, then hit the F9 key to get it to update to your document — but see the note on page 21.)

Of course it is really only worth following the foregoing sequence if the title of the document is going to change, such as with new edition or draft-version numbers, or in a template that you use to create many documents. Otherwise it’s easier just to key the title into the header! 

Header that shows the wording of the chapter heading

This second example describes how to follow the convention, related to the foregoing example, of having the chapter title in the header of right-hand pages. 

[It’s assumed you have set up separate left-hand and right-hand headers as shown above.] 

	This method has a secondary benefit that is very beneficial — it reduces the number of section breaks in a document. That’s important, because section breaks, like the final paragraph mark in a document, tend to harbour corruption. (More details of document corruption are on page 127.)

Electronic documents can also be kept remarkably “thin” (smaller for a given content) by using this method to set up headers for each chapter.
 For further information, see “File size, keeping it small” on page 134.


This feature is based on the StyleRef field, which inserts the text of the first “paragraph” that’s formatted with a style you have specified. (Usually the “paragraph” is formatted in a heading style, but that’s not necessary — it can be any style you nominate).

When inserted in a header or footer, the StyleRef field displays the first or last text formatted with the specified style in that section (and continues to display that until the next section that’s formatted with a different header). 

For more information, search for the topic “Effect of the STYLEREF field location” in Word’s Help. 
The following sequence puts into the document’s header the words of the first heading that appears in the style that you nominate. So, for example, if you have applied Heading 1 as the style of your chapter heading and you nominate Heading 1 in the sequence below, the words of the chapter heading will appear in the header.

If headers for subsequent sections are set to “Same as previous” they will also show the words of the first heading that appears in the chosen style in each of those sections. 

Open the header (View menu » Header and footer; increase size to 125% so you can see better). Leave the insertion point at the beginning of the header. Choose Insert menu » Field » leave the Categories scroll list at “All”, scroll the Field Names list to StyleRef. 

Click the Options button » Field Options window opens » Styles tab » click on the style you want (e.g. Heading 1) » click “Add to field” button » OK » OK. 

Header that displays the edition details, or other details, from the front page

This third example is a variant of the previous example. It involves getting Word to automatically repeat, in the header, the first instance of text in a particular style that you nominate. I find this very useful, for example, in drafts of the documents I develop — I want to be clear about which version I’m working on and I want comments that will be faxed back to me to have the version number on each page, so I key the version or edition number on the front page and the details are repeated in the header of each subsequent page. 

This method can also be used to pick up the title of the publication from the front cover (or the prelims page) and put it in the subsequent page headers. 

On the cover page of the document you are now reading, you will see that on the title page I have typed “April 2013 edition”. ( [What you see here is a StyleRef field that inserts the words of the nominated style, “version number,vn”. If you configured your Word preferences as recommended on page 17, the grey background will show you that it’s the contents of a field.]  These words also appear in the page header, which you will see above if you are in Page Layout view, or via View menu » Header and Footer if you are in Normal view. In a simpler document I may well have assigned Heading 5 style to it, perhaps manually altered in appearance to suit the context. 

To avoid the title on the front page appearing in the table of contents, it is advisable either not to format the title with a heading style, or to format it in a heading style that’s so low you do not include it in the table of contents.
 In the latter case you may need to format the text manually to look larger, uncoloured or whatever. 

Hyperlink to another document, creating 

By drag-and-drop

This hyperlinks to a location in Word, in an Excel worksheet or a PowerPoint presentation

This is quicker than via the Insert menu.

In the document you want to link to, select the text you want to link to.

Command-Option and drag to the document in which you want the hyperlink to appear.

Keeping the Command and Option keys down, release the mouse button. From the Shortcut menu that appears (after which you can release the keys), choose “Create hyperlink here”. The dragged text is now a hyperlink. Click on it to test that it takes you to where you want.

By the Insert menu

This hyperlinks to a website or a file (for website instructions, see p. 267 of Office 2001 Bible)

If you want to hyperlink to specific text in a document, select it.

Insertion point in document that will contain the hyperlink. Key Command-k or choose Insert menu » Hyperlink » click “Document” tab » use “Recent documents” pop-down menu or “Select” button to identify the document. If you want to jump to a specific location, such as a Word bookmark, enter the location in the Anchor field (leaving it blank makes the hyperlink jump to the beginning of the file or web page).

Click “OK” to establish the hyperlink.

Hyphens, optional and non-breaking

Optional hyphen (allows the word to break at that point if appropriate): Command-hyphen.

Non-breaking hyphen: Command-Shift-hyphen.

Index, creating

See http://word.mvps.org/FAQs/Numbering/CreateIndex.htm

Language, default — applying to text that has a different version of English

For most of my work, I prefer to use a variant of English, namely Word’s “English (Australian)”. I find I often receive text from colleagues that is in English (US), even though they also prefer to use English (Australian). Usually this occurs because of the way their computer has been set up. The problem is that Australian place names and other terms used only in Australia are immediately underlined in my document as being discrepant. My solution was to create a toolbar button to apply English (AUS) to text that I have selected (or Command-a to select all the document). It’s described on page 190. 

Words are then marked as discrepant only if they do not conform to what’s in my English (AUS) dictionary. 

Leading (blank space above and/or below a paragraph)
A discussion of the advantages of having leading (blank space above and/or below a paragraph) as part of paragraph styles is at page 174. 
Linked object’s setting — change to automatic or manual updating

On the Edit menu, click Links. The Links command is unavailable if your file does not contain a linked object. 

Click the linked object you want to update. To select multiple linked objects, hold down the Command key and click each linked object. 

To update a linked object every time you open the file that contains the object or any time the linked object changes while the file is open, click Automatic. To update a linked object only when you click Update Now, click Manual. 

Manually imposed (colour) highlights

Finding them

Command-f or Edit menu » Find » “More” » Format » Highlight.

Deleting them

Select text (or Command-a to select entire document). View menu » Toolbars » Reviewing » click the downward-pointing arrow to the right of the “ABC” icon » select “None”.

[See pp. 646–648 of Using Microsoft Word 97 for more info on highlighting and comments.]

Master documents — best avoided

Because I don’t use master documents, I’ll first quote from Word guru Charles Kenyon:

‘Master Document’ is a term of art in Word referring to a ‘feature’ that not only doesn’t work but also destroys documents. The consensus … among those offering advice on [the now closed Microsoft newsgroup]s is that using the Master Document feature is a sure way to destroy your document. It can destroy parts of your document that you are not even working on! I think John McGhie said it succinctly when he said that there are two kinds of Master Documents: those that are corrupt and those that will be corrupt soon. 

See http://addbalance.com/word/masterdocuments.htm for information on the Master Document feature and workarounds. 

Another Word MVP said to someone who was determined to use the feature:

I think the general view is: use it at your own risk and be sure to make regular backups, especially of the sub-docs. Never edit the sub-docs while they’re open in the master (except necessary things like headers/footers and cross-refs), and never try to change the order of the sub-docs by dragging them.

Consider the master doc, itself, as a ‘throw-away’ file that’s really only used to pull the sub-docs together for table of contents, indexes, cross-refs, page numbering for printing. (That’s what it was designed for, originally, and it does that quite well.)

John McGhie has also given this “what to do if you must use Master Documents” advice:

[The Master Documents feature] is a very powerful and complex mechanism, and there is a requirement on the user to really know the mechanism well to get the best out of it. 

The most important tip I can give you is to ensure that all of the pieces — all of the documents and anything else you want to link — are all in the same folder, and not in a sub-folder of the main folder. If they are all in the same folder, Word has the ability to self-correct the links. If you place bits in separate folders, you then must not move any of the documents or you break some of the links. 

Next, you need to ensure that anyone else who is going to open any of these documents knows that this is a complex linked structure, and knows exactly what they are doing with externally linked files. This feature works brilliantly in a workgroup of documentation professionals who are used to dealing with external links in documents. It works brilliantly if you are the only user able to access the documents. But it rapidly turns into a disaster area if some or all of the users are not used to commercial document production! 

First: Decide whether you need to do this at all. If your finished publication is going to be less that 1,000 pages, you do not need to do this at all. Between 1,000 and 2,500 pages, there are some benefits in linking. Over 2,500 pages in a single document and you must use external links. But if you are creating a document that size, you can afford to hire a documentation professional and a team of specialists to help you :-) 

Next, you need to decide whether you want the links to update every time you open the file, only when the external files update, or never. There are switches in the field codes for this purpose. Read Word’s Help on this point and make sure you understand it. 

And … create all of you component documents from the same template, so that the styles all match. 

You can choose to link your pictures, charts and graphs the same way as you link the other documents. If you are doing a large document, I would certainly link the pictures, rather than embed them in the document. 

Read the Help on this point too: Understand the difference between “Linking, Linking AND embedding, and Embedding only. 

You can link graphics to your component documents. Or into your main document. Unless you are going above 2,500 pages, I would keep all of your text in one main file, and link only the graphics. Otherwise you are creating complexity you do not need. 

Also see:

•
http://word.mvps.org/FAQs/General/WhyMasterDocsCorrupt.htm for more information on what goes wrong

•
http://word.mvps.org/FAQs/General/RecoverMasterDocs.htm 
for ideas on how to salvage what you can.

“Minimum maintenance” formatting

See Appendix A: The main “minimum maintenance” features of my documents, at page 161, for lists of features that:

•
avoid the need to re-set pagination and update the table of contents and cross-references etc when amending the document (especially when sending out drafts for comment); 

•
minimise the chances of document corruption; and 

•
maintain the desired appearance on other computers, especially on machines with Microsoft Windows operating systems. 

Normal view, why it’s best used when working on a long document

Like most people who work professionally on long documents (especially with a “minimum maintenance” structure — see page 161), I use Normal view most of the time. Among other things, pagination is suppressed and screen display is approximated to make Word work much faster than in Page Layout view, which has to continually render the total WYSIWYG appearance of the page as it will appear when printed. One consequence is that scrolling is faster. Also, various non-printing things are shown, so the document is easier to edit — and is less prone to corruption through not seeing the structure of some features. The “Disc full” bug (see page 155) is also less likely to occur.

I only use Page Layout
 view (which is within one pixel of about 99% WYSIWYG) or Print Preview (which is within one pixel of 100% WYSIWYG) when:

•
I want to force repagination using Page Layout view, since repagination occurs infrequently in Normal view (that’s an over-simplification; for more information see page 31); 

•
I’m about to print and I need to check graphics and text for correct placement and the overall pagination (though for a totally accurate view of how the document will print, it’s better to use Print Preview — see page 148); 

•
the document has many footnotes that I need to refer to; or 

•
occasionally, to re-establish page numbers (using Page Layout view) if they don’t show during scrolling. 

In these instances I go out of Normal view only for the duration of that task. 

Normal view presents much more useful information about the features you need when preparing a long document. These features concern the structure rather than the appearance; and usually if you get the structure right the printed appearance will follow.

For example, you can open a Styles Area or Document Map in Normal view. You can open all your footnotes at once. You can see any combination that you choose (via Edit menu » Preferences » “View” » Non-printing characters) of non-printing characters such as paragraph marks, tabs, spaces, hidden text, optional hyphens, section breaks and page breaks.

If you know all these features are in their correct place, and there are no blank lines (empty paragraph marks) in the document, and all the style names are correct, then you know that the document will print out correctly. A last-minute check in Page Layout view or Print Preview is all you need, if at all. 

Numbered headings; outline numbering

A complex subject. The most robust, reliable method (with minimum potential for corruption, which is why I use it when I’m forced to use automatic numbering) is very well explained at www.shaunakelly.com/word/numbering/OutlineNumbering.html

But if you do not do it exactly the way Shauna describes, it won’t work.

For numbering headings and figures in appendixes, see http://www.shaunakelly.com/word/numbering/NumberingAppendixes.html

(These excellent articles are PC-oriented, but don’t let that worry you if you only know the Mac. The main difference is that for Control key modifiers read Command, for Alt read Option (Alt is even printed on the Mac’s Option key), and Tools menu » Options is Edit menu (in Word X or 2004, Word menu) » Preferences. 

Numbering, automatic

Automatic numbering in lists is the same thing as automated bulleting, except that Word does not increment bullets; so these notes also apply to bulleting. 

I avoid automatic numbering wherever possible because corruption occurs frequently in the electronic structure that controls it (and that includes automatic bullets). But for some of my work I have to use the feature. In that event I seek to maximise reliability by basing numbering on styles and not altering anything manually. 

The biggest mistake is to try to apply numbering independently of the styles. As John McGhie said: “if you do that, you can live in very interesting times”.
 Or as Elliott Roper said in his inimitable style about “the tar pit known as Bullets and Numbering”: 

Microsoft made a truly baroque and powerful numbering system and subsumed bullets into it, but somebody must have panicked before shipping time, and exposed it only with a Tonka Toy user interface. So now you can get into the mess with the greatest of ease. But, once you are stuck …
In other words, for serious documents, do not use the “Bullets” and “Numbering” buttons on the Formatting toolbar.  

For notes on these features and further reading, see “Bullets” on page 153. 

Outline view

This is reached by keying Command-Option-o  ( [“oh”, not zero].

Outline view gives you a “helicopter view” of your document by allowing you to concentrate on its headings on the one screen, free of the clutter of subordinate text (though you can get it to show subordinate text if you want). It is an excellent resource if you want to prepare a complex document by typing up its structure first, or to re-arrange the structure of a document. I use the latter capability often. You do the re-arranging by simply dragging the heading(s) to a new position. The subordinate text follows with the heading(s), even though it isn’t visible. (You may prefer, when trying this out for the first time, to do it on a spare “Saved As” copy of your document — though the Undo Typing feature does allow the actions to be reversed.)

Only documents formatted with Heading styles will make any sense in Outline view. For a quick view of this document’s outline, key Command-Option-o then, in the toolbar that appears, click on “4”. This will make all body text and headings 5 and below disappear. Click on the “A/A” button and any colours or font characteristics of your headings will appear/disappear. The structure of the document now looks like the table of contents, which is based on the same information, but an outline has nothing to do, functionally, with a table of contents. 

For more information, choose Help menu » Microsoft Word Help » click on “Search” » type in “outline view” and go from there. Or go to:
http://word.mvps.org/FAQs/Formatting/UsingOLView.htm

Page breaks, avoiding

If you use hard page breaks in your document, the pagination may end up being very different on another computer, possibly giving rise to a number of problems, including pages containing only one line of text. To avoid this, see Appendix A: The main “minimum maintenance” features of my documents, at page 161. 

Paragraph spacing — Word uses greater of two values for leading

A discussion of the advantages of having leading (blank space above and/or below a paragraph) as part of paragraph styles is at page 174. 
Suppose you have a paragraph with 6 points of leading after it, followed by another with 10 points before it. Before Word 2001 (2000 on the PC), the space between the two paragraphs would be the sum of the two leading values — that is, 16 points. Now it’s the greater of the two, namely 10 points in this case, in the default configuration.

To revert to the old behaviour, choose Word menu » Preferences » Compatibility » turn on “Don't use HTML paragraph autospacing”. 

PCs and Macs, main differences in Word interfaces

The most frequently noticeable difference between Word on the Mac and Word for Windows on the PC is the frequent reference to “right-clicking” in Windows, which simply means “clicking the right-hand button” on the two-button (or multi-button) mouse that Windows users always have. Right-clicking is equivalent to Control-clicking on the single-button Mac mouse — that is, holding down the Control key while you click. The Control-click or right-click brings up a “contextual menu” wherever you happen to be. If you use Word intensively, it’s a good idea to buy a configurable multi-button mouse or trackball, since Word is rather right-click-intensive. Word also responds to the scroll-wheel.

You may need to know some of Word’s keyboard shortcuts on the PC, especially if you read Windows-based Word manuals or if you want to tell a colleague on the Windows platform how to perform an action using keyboard shortcuts (and vice versa for the Mac if you are a Windows user reading these notes).

In keyboard shortcuts, the modifier keys in Word on the Mac and Windows platforms are often different — in part because the PC does not have a Command key (see this topic on page 19). Many default keyboard shortcuts on the Mac that are “Command-[whatever]” are “Control-[whatever]” on the PC. The Control key is used less on the Mac, though not in Word. The “Alt” key on the PC may be the “Option” key for a Mac command — but often it isn’t. 

On both the Mac and the PC, you can compile a document of all keyboard commands in Word by following the notes under the heading “Standard keyboard shortcuts in Word” on page 68. 

Here are the most commonly occurring equivalents:

	Windows
	Macintosh
	Remarks

	“Enter” key
	“Return” key
	

	Right-click
	If you don’t use a two-button mouse: Control-click
	That is, hold down Control key and click

	Control-c
	Command-c

(Some people call the key with a [image: image50.png]


symbol on the “apple” key, but Apple Computer never has, and the apple symbol no longer appears on keyboards)
	Copy

	Control-v
	Command-v
	Paste (cue: “v” for “viscous”)

	Control-s
	Command-s
	Save

	Control-f
	Command-f
	Find

	Control-h
	Command-h
	In Word X and 2004: Command-Shift-h

	File menu » Close
(sometimes Control-w)
	Command-w
	

	Control-q
	Command-Option-q
	Restores paragraph formatting to that of the underlying style

	Control-x
	Command-x
	Cut

	Tools menu » Options
	Edit menu » Preferences
	In Word X and 2004: 
Word menu » Preferences

	File menu » New Task Pane
	Project Gallery
	

	Mail merge task pane
	Data merge palette
	


Test the various combinations of Shift, Control, Option and Command and you’ll soon find out. 

If you’re on the Mac and you need to know what’s used on the PC, you can get a PC-using colleague to print out the list of PC keyboard shortcuts as described on page 68.

Remember that in Word you can easily re-assign keyboard shortcuts to (almost) whatever you want, to suit your working habits. 

Further information is on the Word MVP website (http://word.mvps.org/FAQs/WordMac/Differences.htm).

Print preview, advantage of

Print preview gives an exact (within one pixel of perfect) WYSIWYG view of a document’s appearance when it is printed. Sometimes, it will give a slightly different view from page layout view — which can occasionally include a line moving over to another page. Trust print preview, not page layout view.

The reason for the difference is that in print preview, Word calls in everything to make the display as accurate as the screen allows — including looking up the printer driver and its fractional widths and font metrics. Page layout view isn’t quite as accurate, because it doesn’t look up the printer driver. However, the display is about 99% WYSIWYG.

The display in Normal view is only indicative — the real fonts aren’t used and the pagination engine isn’t running continuously (but it’s much quicker than the other views, and it’s best to work in Normal view most of the time — see page 144). 

When you go into print preview, a dedicated toolbar appears with a Magnifier button (second from the left). If you click the button until it is not enabled, you can edit in print preview. Save frequently and don’t do much editing in this view: the hardware demands are truly outrageous and crashes are likely

“Read-only recommended” protection

Do a “Save As” and click on the Options button » window opens. Click the tickbox “read-only recommended”. 

Recovering badly damaged documents

This is what a poster in the microsoft.public.mac.office.word newsgroup said about a recovery service based in Madrid (www.cimaware.com):

[I’ve had success in paying a recovery service] to recover the document. They succeeded in getting almost all of it back. As I mentioned before, the document was a 2.8 MB Word Mac X file, about 400 pages, with lots of tables, figures, and equations, and a table of contents. The service recovered all of the tables, text, and formatting, and almost all of the equations, but none of my figures. (I happened to have up-to-date back ups of my figures, however). The service cost $US29 for the one document (which I happily paid to salvage several days’ worth of work), and was very fast. (They say it takes 15 minutes if you do it all via their web page, but I did it via personal e-mail exchange with one of their reps, because we weren’t sure what they could recover.) 

For Macs, see www.word-rescue.com/macintoshusers/index.php and for PCs, see www.word-rescue.com/home/index.php

Re-formatting text obtained from the Web or other sources

Depending on how much text is involved, there are three ways to re-format text transferred from a website or another word-processed document. See “Document from someone else — checking and fixing formatting of” on page 130.

“Replace” pane — useful keyboard shortcuts

Command-Shift‑h opens the “Find and Replace” pane at “Replace” (just as Command-f opens it at “Find” and Command-g at “Go to”):

[image: image51.emf]
The following keyboard shortcuts save time:

•
Control-tab cycles through the alternatives across the top.

•
The Return key activates “Find next”. 
•
Command-r activates “Replace”.

•
Command-a activates “Replace all”.

•
Command-period, or the Esc key, activates “Cancel”.

•
After the Find/Replace pane is closed, Command-Option-y continues finding the same word.

To see how much time you can save, try the keyboard shortcuts to temporarily change “the” to a different word in any open document. First save the document, then key Command-Shift-h » [type “the”, which will appear in the top box] » hit the tab key » [type “x” or any other word] » key Command-r a couple of times (to check what’s happening) then Command-a to finish replacing all such instances. Finally, key Command-[period] or press the Esc key to close the pane.

(Then close the document without saving, to remove the changes you made.)

Saving documents, strategies for

Absolutely essential — no exceptions: Always have “Fast Saves” turned off — see page 133. 

Word saves new documents and “saved as” documents into (one only) nominated folder unless you navigate to the folder you ultimately want it in, which I find a nuisance. So I have a folder for this purpose titled “Interim saves”, which is permanently open on the desktop. Often I just wait till later on to drag documents out of this folder into the correct subject folders; sometimes (e.g. if there is a danger of working on the wrong version) I close the new document immediately after saving, then on the desktop drag it from the Interim Saves folder to the correct folder, then double-click it to open it again.

Expert advice is that if you select “Always create backup copy” in Edit menu » Preferences » Save, you will almost never see the problem of “Disc full — cannot save” (the “60 saves” bug) that can cause serious problems for some people — see page 155. I don’t have this setting on, because it doesn’t fit well with my particular backup strategy. But I would certainly follow this advice if I experienced the “60 saves” problem. 

John McGhie explains the advantage of selecting “Always create backup copy” this way:

The way Word saves depends on your settings in Edit menu » Preferences » Save.

1)  If you have “always make backup” set to “off”, Word attempts to write to the open file. It should then release some of its associated temporary files. The “60 saves” bug is caused by Word running out of file handles. It requests 60 file handles on application start, which is supposed to last it for the whole session. But if any complex editing is done, Word creates several temporary files for each document. It should release these when you perform a full save, but it seems that the operating system is not discovering this and releasing the file handles, so Word hits the point where it cannot request any more file openings.

2)  If you have “Always make backup” set to “on”, Word is not attempting to write back to the open file. What it does is a write, rename, rename, delete. It first writes out a new file with a temporary name, then renames the previous backup file, then renames the existing file to “Backup of…” then renames the new file to the original file name, then deletes the backup file before the current one. At this point, it appears Word is more successful in releasing its temporary files, and so users can continue to save and edit a lot longer for any given file opening.

See also the notes under ‘Versioning — best avoided’, below. 

Screenshots, pasting directly into Word

Shift-Command-Control-4 will put a picture of the selection on the clipboard so you can paste it in place without going through the intermediate graphics file. To take a screenshot of a window automatically after performing this keyboard shortcut, hover over the window, press the spacebar to highlight the window, and click. 

[For inserting other types of images, i.e. external to Word, it’s best to paste via Edit menu » Paste Special.]

Space, non-breaking 

Non-breaking space: Option-spacebar.

Symbols and accented letters, inserting

Since Word 2004, you do not need to insert symbols only through Insert menu » Symbol. Now that Unicode fonts are available, you can find more through OS X’s character palette. 

If you have activated the character palette and a national/language flag is visible on the Finder’s (not Word’s) menu bar, pop down the flag menu and let go at “Show character palette”. In the left-hand panel, scroll to the characters you want, such as Latin or Accented Latin, then choose what you want from the information presented. Once you have selected a character, click the “Insert” button at the bottom right of the window. The symbol will be inserted in your Word document where your insertion point is.

[To activate the character palette: if a national/language flag is on the Finder’s menu bar, pop it down and see if “Show character palette” is on the menu; if so, do as above. If not, or if there is no flag in the menu bar, choose Apple menu » System Preferences » International. Click on the third tab (“Input menu”), then tick the box next to “Character Palette”. Then do as above.] 

After the OS X’s character palette has been activated, you can use it any time from the national/language flag, in any application.

Track changes / reviewing

If someone has sent a document that has Track Changes enabled, the “TRK” button on the status bar at the bottom of the active Word window will be active — that is, not greyed out. 

If the status bar is not visible, you should note whether changes are being tracked invisibly by: Tools menu » Track changes » Highlight changes... » de-select Track changes while editing. 

Further information on Tracking Changes, including ways to avoid problems, is on page 63.

Transferring documents to/from other computers, especially PCs

See Appendix A: The main “minimum maintenance” features of my documents (page 161), which includes tips for minimising problems with cross-platform transfers.

Versioning — best avoided

Experts in the MacWord MVP newsgroup strongly suggest that you should not use the Version feature. If anything damages the file, you lose the current and all prior versions at the same time. The Versions feature also greatly increases the chances of corruption of complex documents. 

It’s better to do a Save As to create a new file when you want to save a version, incrementing the number each time — to “v2”, “v3” et seq. Most of my strategic plans are frequently amended while we are developing them, so I increment to “v1a” et seq., or even “v1a2” and add my initials: “v1a2CH”. My colleagues do the same and confusion is reduced (no, not eliminated!). 

Web toolbar, to stop it appearing when clicking on TOC or other hyperlinks

If you have long documents in which you click on the page number in the Table of Contents to get to a topic, the Web toolbar appears. Usually you don’t want it to appear.

To get rid of the web toolbar, you have to install a macro, and you’ll probably put it in the Normal template. Here are the details:

For instructions on installing macros generally, go to: http://word.mvps.org/Mac/InstallMacro.html

Copy this into the new macro window when you get that far:

Sub ToggleWeb()

       With CommandBars("Web")

        .Enabled = Not .Enabled

       End with

End Sub

The macro “toggles” the toolbar, i.e. it turns the toolbar on the first time it runs and turns it off next time. Once you have installed the macro, choose Tools menu » Macro » Macros » scroll to “ToggleWeb” and click “Run”. Repeat if the toolbar does not disappear. Word will remember the setting and you will not see the toolbar again while this Normal template continues in use.

Windows of the same document — opening two or more

To have two or more windows of the one document visible on the screen (very useful with long documents, allowing more of the document to be visible than with half-screen splitting): choose Window menu » New window.

If you are used to copying text from one document to another by dragging, remember that you need to hold down the Option key when doing so in the same document — otherwise the text will be removed from its original location, not copied. 

Some retrograde features of Word 2001 and later — and some work‑arounds

“Automatically update” tickbox in “Modify style” window is dangerous

The “Automatically update” tickbox that appears in the Modify style window (Format menu » Style … » “Modify” button » Modify style window), if ticked, is extremely disruptive in most situations because thereafter it will alter all instances of the style every time a single instance of the style is manually changed (Shauna Kelly says “There is not enough aspirin on the planet to cure all the headaches this causes). If, for example, you reduce the font size of a heading in “Heading 1” style at the beginning of an appendix so it fits on one line, all instances of Heading 1 in the document will be changed; and if you later agree to change the template, all other documents attached to the template will be affected when opened.
 Beware, especially, documents from other computers that have styles with this item ticked. To check for this characteristic, go to Format menu » Style… » select the style » Modify… » de-select “Automatically update” » OK. 

“Automatically update” causes particular problems if you are using Word’s automatic numbering feature (see page 145). Each time “Automatically update” runs, it adds to the style table in the document all the styles from the attached template. If the styles already exist, it overwrites the existing ones. If any of those styles are associated with bullets or numbering, the link to the bullet or number format is broken by this operation. 

This feature can be useful, however, if you are fine-tuning a document’s styles as you go. As a further step, you may decide to deliberately link the document to a template, so that any modification to that template would be reflected in other attached documents — see page 103. But you will need to remember to cancel these settings once the need for them has disappeared. 

By default, Word’s “TOC” styles are set to automatically update whenever you modify them. I turn that property off too; it only takes a minute or two if ever I need to modify the format of a table of contents. 

The other type of automatic updating of styles that is usually unwanted is caused by ticking “Define styles based on your formatting” in Tools menu » AutoCorrect » “AutoFormat as you type” tab — see “Stopping Word from changing your definitions of styles” on page 114.

Bullets

Word can automatically apply bullets or numbers to lists. These two features are essentially the same thing, except that Word does not increment bullets.
 The process by which Word applies bullets or numbers is now very complex, and a consequence is that the electronic structure behind it can become confused by “pilot error”, leading to corruption of the document. 

As with other features of Word that can cause problems, especially in shared documents, I prefer the simplest approach:

•
If there are no other over-riding requirements, I use numbering rather than bullets only when I need to make a reference to a specific step in a list, such as “follow Step 3” — but of course there are some documents in which numbering has to prevail and unless the document is short, automatic numbering is virtually essential.

•
I use manually keyed bullets in preference to automatic bullets, to avoid invoking the mechanism that causes corruption. (The keying is Option-8 [tab], but for speed I have an AutoCorrect item that substitutes “Option-8 [tab key]” when I key “bb [tab key]” — see under “AutoCorrect ” on page 80.) 

•
If the document is going to other people in electronic form during development:

–
I number manually (as in this document) if there are few numbered lists in the document. 

–
Because it’s quite convoluted in Word for Windows to key bullets, I tell my Windows-based colleagues to copy one of the manual bullets and simply to paste it in where needed. Some have set up an AutoCorrect item. 

•
If the document will have limited electronic distribution during its development, will never leave the Microsoft environment and there are many bulleted lists, I use a sub-paragraph style that incorporates a bullet (style “sb”), and a sub-sub-paragraph style (“ssb”) with a different bullet. 

The definitions of styles “sb” and “ssb” are on page 169.

•
In any event, to minimise corruption when using Microsoft’s automated bullets I invariably apply bullets and numbering as part of a specific bulleted style (Format menu » Style » “Modify” button » “Format” pop-down » Numbering). The reason I never manually change Normal (or any other style) to applying automated bulleting is that it prevents me from making global changes at any time, as discussed on page 85. Further, problems can occur if you share documents containing automatic numbering. If individual users have different definitions for the various List of Templates (i.e., the electronic numbering structure) involved, the numbering breaks each time a different user opens the document. You can usually resolve this by not using Normal style in the document and ensuring that none of the styles that contain numbering in the document are based on it. 

Very good discussions of bullets and numbering, and “how-to” instructions that must be followed to the letter, are at:

www.shaunakelly.com/word/bullets/controlbullets.html
www.shaunakelly.com/word/numbering/OutlineNumbering.html

and:

http://word.mvps.org/FAQs/Numbering/WordsNumberingExplained.htm

See also under both these headings on page 145: “Numbered headings; outline numbering” and “Numbering, automatic”. 

Case format limitations

The keyboard shortcuts Shift-F3 or Command-Option-c (which is better, because you can key that combination with one hand) will cycle through the available case options. And you don’t need to select a word to change case — the insertion point only has to be in the word for the shortcut to work. However, there is a limitation to the shortcut:

•
If the selected text doesn’t end with a full stop or colon, the alternatives available when you successively apply the shortcut are lower, upper and title cases — that is, sentence case isn’t included among them. This isn’t very useful if you have moved a clause from the end of a sentence and you have extended that selection to include the previously capitalised first word in the sentence: now you have to resort to a two-stage process, applying the keyboard shortcut to both words in turn. 

•
If the selected text does end with a full stop or colon, sentence case is included among the keyboard shortcut options — but title case isn’t.

All the options can be applied (irrespective of whether a full stop or colon is included in the selection) via Format menu » Change case: sentence case, lower case, upper case, title case and toggle case. But using the menu is tedious. The keyboard shortcut limitation is an instance of Word being coded to be too smart for its own (=our) good. 

When you Option-drag text to apply the Change Case keyboard shortcut command to (say) a list of bullet points, the first application of that shortcut de-selects the text. 

Corruption in some Word 5 documents opened in later versions of Word

Some documents created in Word 5 and earlier, especially from a master Stationery document, contain file corruptions when opened in later versions of Word. Sometimes you will see a warning dialogue box, but often you won’t. One technique that will often show whether the file is corrupted is to click on and hold down the sliding square that moves up and down the right-hand scroll bar of the document. Moving your mouse up or down will show the number of the page that you are travelling past. If you see unusual numbers (e.g. starting at 105 when it’s a 20-page document) or the sequence of numbers jumps, the document is corrupted.

For a way to fix most corrupted documents, see “Corruption of documents” on page 127. 

Dates — common variants are not easy to invoke

In Word 5.1, it was quite easy to call up short and long dates, in either “updating” or “fixed” formats. In Word 2001, it’s easy enough to insert one type of date (for example, a self-updating long format date, if that’s what you have nominated as your default) via Insert menu » Date and time … » make selection from the box. But inserting other variations is mouse-intensive — and you have to check what the last type of date format was before you can confidently insert a date the next time. The keyboard shortcut Control-Shift-d only repeats the default option you selected (format and updated / not updated) and the type of date you are keying is not shown. Many people report that they find this very inconvenient and confusing, especially when they find that a date they thought to be fixed updates itself on re-opening the document.

To insert a “print date” (i.e., one that is automatically updated every time you print) or “save date” or “create date”, it’s necessary to choose Insert menu » Field » select Date and time in the Fields scroll box and make the desired date selection in the right-hand box.

A work-around to get rid of all this confusion is suggested in Appendix C: Making a toolbar with buttons for a variety of date formats (page 178). As with so many configurable things in Word, you have to decide whether the investment in time to make such a toolbar is worth it. Once you make such a toolbar, however, it’s very convenient to have — dates are no longer a problem. 

To convert date fields to text, select the date (if the insertion point is immediately after the date field you can use the Delete key) then Command-Shift-F9. 

De-splitting the document — controlling which half disappears

You can split and un-split a document’s display in two ways:

•
via the keyboard shortcut Command-Option-s, or

•
by double-clicking on the “Split bar” — the small horizontal bar (about 5 mm x 2 mm) above the vertical scroll bar — and double-clicking on it again when it’s in the middle of the screen (when it’s called the “Resize bar”).

I prefer the keyboard shortcut. It’s not just that I don’t use the mouse if I can use a shortcut; it all has to do with what happens when you want to double-click the Split Bar to get back to the full-screen view. If you key Command-Option-s to do this, the Split Bar will disappear and you can keep working exactly where you are. But if you click on the Split Bar to get back to the full-screen view, the text that remains visible is the text that was in the half that didn’t contain the insertion point. So you have to go hunting up and down to re-discover where you were working. 

Shift-F6 toggles between the insertion points in the two split halves of the screen. 

“Disc full — cannot save” (the “60 saves” bug)

In Word 2001, Word X and Word 2004
, after about 60 saves of a document, some users of Word get a “Disc full [or Disk full?] — cannot save …” warning, even though the hard disc isn’t full.
 

In Word 2001, some people concluded it was best to turn file sharing off; then the error would occur only after about 250 or so saves! But I’m a compulsive performer of Command-s every time I pause to think, and I’ve only experienced this problem perhaps five times in the past three years. I generally don’t have file sharing turned on, and on busy days I quit Word and re-open it to refresh its settings files — I did that two or three times during the day with Word 2001 but I now do it (usually) only once a day in Word 2004. 

The different extent to which users experienced the bug was said possibly to be related to the incidence of back-saving to older versions of Word or saving to RTF. Other suspect factors nominated by Microsoft are documents with multiple languages and running background third-party software (like Norton anti-virus, CopyPaste, SpellCatcher etc). 

The open file limit of OS X is involved, making it a very difficult problem. 

A fascinating but highly detailed explanation by Rick Schaut, a Microsoft employee, is at http://blogs.msdn.com/rick_schaut/archive/2004/05/19/135315.aspx — leading to this recommendation: “If you have a document that has headers and footers with page fields in them, do your editing in Normal view, and you’ll likely never hit the ‘Disk is full’ save error.” Hmm, I hardly ever work other than in Normal view, for reasons outlined on page 144, and my headers usually have page fields in them. 

This template may help

In 2003, Microsoft brought out a template that can be used as a work-around for this bug. It can be used provided you have already installed Visual Basic for Applications (VBA) from the “Value Pack” on the Office installation CD. If you install VBA after your version of Office has been updated (that is, not at the initial installation of Office), you will need to re-apply all updaters appropriate to the version. 

The template is downloadable from http://word.mvps.org/FAQs/WordMac/DiskFullError.htm
If you have an external hard disc, you should also be able to save the Word document to it (either from within Word or by dragging the image in the Finder). 

If that doesn’t work, try Edit menu » Preferences » Save » turn “Always make backup” to on (and confirm that the “setting from hell”, “Allow fast saves”, is off. Set “Save AutoRecover” to a period longer than 10 minutes (try 30). Then create a new document and copy everything except the very last paragraph mark into it, and save it under a new name. This manoeuvre should clear any corruption you may have in the document. You may wish to reset “Save AutoRecover” back to a shorter period.

Failing this, you may be able to copy consecutive parts of the document and paste them into a new blank document. If you have only done a little work since the last save and can afford to lose it, you may find it quicker to note and/or print the most recent changes and close without saving. 

Find / Replace problems in Word 2001

When you have pasted a term in the “Find” or “Replace with” field, often you can’t drag to select some of it; you have to click the insertion point in and arrow-key from there.

You can’t park the “Find/Replace” window so it’s largely off-screen (so that only a little more than the searched text is visible) — it moves back to the middle. 

The “Find/Replace” window will often obscure a found term if it partly overlies the document. If you don’t have room on the screen to park it off the document, you can split the screen (Command-Option-s) and park the “Find/Replace” window in (say) the upper view, then click in (say) the lower view; the window will stay where it is. 

A bug sometimes causes one or more additional (redundant or “ghost”) images of the “Find/Replace” window to appear in the document where it finds the text you want, blocking out the nearby text. To get rid of this ghost image, you have to use the scroll arrows to scroll the page up or down until the text overlain by the ghost image disappears from view, then scroll back to where you were. Then park the Find window on the screen outside the document window or in a split-screen window (see above).

The longstanding problem of found text in a table not being displayed on screen but above it still exists (you have to scroll up to get to it).

When you clear unwanted formatting or words from the Find or Replace window, then close the window, the formatting or words will return when you open the window again. This can cause difficulties if spaces are all that’s in the “Find” or “Replace” fields or a style or “whole words” option has been specified under them: I tend not to notice them the subsequent time. If you pause by clicking on the document (for example, to go to the front of the document to start a search you have just keyed in) the terms will similarly revert to the previous ones. You have to be particularly alert to this aspect before clicking Replace All.

Font colour — quickly changing a selection

In Word 2001’s default configuration, you can no longer specify the font colour by keyboard shortcut alone, as you could in Word 5.1a. 

You can allocate a keyboard shortcut to invoke the command “Font colour”, but this is limited to showing the [not black] colour last used on the Formatting palette — not very useful if you want to allocate more than one colour without having to mouse back to the Formatting palette. 

The problem can be solved with a little more trouble by incorporating a macro into a toolbar or via a keyboard shortcut, as described on page 185. 

Footnotes

Word inserts a space after the footnote reference number when it opens the footnote pane (View menu » Footnotes). If you just start typing after this space, the result is quite untidy, because the footnote number is contained within the left footnote text margin. The answer is to specify a style for footnotes that includes a hanging indent. If you do so, you will probably want to delete the space that follows the footnote number before keying a tab followed by the text of the footnote (although if you have specified generous spacing for the hanging indent you could leave the space and simply key in the tab).

The “Footnote Text” style in this document has a hanging indent, as shown in this screenshot: 

[image: image52.emf]
You can see the style’s specifications in this document by choosing Format menu » Style » scroll to “Footnote Text” in the scrolling window. Note that the specifications include “Raised by 3 pt” — this aligns the footnote text with the footnote reference number. 

If you want to make footnote reference number the same size as the footnote text, select the footnote and key Control-spacebar.
 In Normal view, you can select all the footnotes at once — but remember that this keystroke will remove character styles such as italics in the selected text.

When you are in a footnote and you want to return quickly to the body of the document and close the footnote pane, just double-click the footnote reference number to the left of the footnote. You can also use the keyboard shortcut Control-Shift-c to close the footnote pane. Although there is no default keyboard shortcut to open the footnote pane without also inserting a footnote number, it’s easy to make your own: see “Open (and close) footnote area” in the table on page 81.

Sometimes you may want to refer to the same entry in footnotes a second time — that is, by inserting the same reference number a second time. Word can do this in a way that allows the second reference number to be updated if the footnote subsequently acquires a different number as a result of changes to other footnotes in the document. Here are the steps:

•
Click where you want the reference located.

•
On the Insert menu » Cross-reference » in the “Reference type” pop-down menu, select “Footnote” » in the “For which” box, click on the note you want to refer to » in the “Insert reference to” pop-down menu, select “Footnote number (formatted)” » ensure the “Insert as hyperlink” box is ticked » Insert » Close.

Unlike ordinary footnote reference numbers, this new number doesn’t take you to the footnote itself when you click on it (an example is the second footnote numbered 45 on page 75). Instead, you’ll be taken to the to the original footnote reference number. When you click on that number, the footnote appears in the usual way. 

The reason for the different behaviour is that this second reference number is actually a formatted cross-reference.
 Its advantage is that if you add, delete or move a footnote, you can easily update the number. This will occur if you update all fields in the document key Command-a then F9. Or if you only want to update the cross-reference number and nothing else, just select it and press F9 (if you have trouble selecting the cross-reference number by itself, select any of the surrounding text along with it). 

[The F9 key is now taken by the OS: see the work-around on page 21.]

If the new footnote reference number appears coloured and/or underlined, see “Hyperlinks: removing the blue underlined formatting from web URLs and e‑mail addresses” on page 57. 

Some excellent advice, including on keeping the start of a footnote on the same page as its reference, is in http://word.mvps.org/FAQs/Formatting/FootnoteOnDiffPage.htm

If you find there is too much space between the footnote separator (horizontal line separating the footnote from text) and the first footnote, do this:

•
In Normal view, in the body text, click on a footnote reference number to reveal the footnotes area at the bottom of the window.
•
Pop down “All footnotes” and let go at “Footnote separator”.
•
Click the adjacent “Reset” button. If that doesn’t give you what you want, make sure the insertion point is still at the separator and key Command-Shift-n to apply “Normal” style (most people are happy with this; I don’t use Normal style, for reasons explained under “Use a body text style, not Normal, in long documents” on page 96, and instead apply style “bt”, my body text style — explained on page 97 — which has 10 points of leading). But you can apply any style to the footnote separator, or create a new one that has the spacing you want. 

Spaces inserted or deleted by “smart cut and paste”

Although “Smart cut and paste” greatly increases productivity by inserting and removing spaces when dragging or pasting text, there is a down-side: it will insert a space at the beginning of a line after a pasted or dragged paragraph mark. Often these redundant spaces aren’t noticeable on the screen. Before printing, it’s best to go through the document in due course with a Replace command (Find ^p[space], Replace with ^p). Appendix E: Checks before printing (page 183) has further details. 

If you follow the practice of putting a space before and after an em dash, you’ll find that when you delete a word following an em dash (and an en dash, but not a hyphen), the preceding space will be deleted as well by “Smart cut and paste”; and similarly the space after a word that precedes an em dash or en dash. Suggestions to pick these faults up before printing are also shown on page 183. 

“Smart cut and paste” is turned on and off by Edit menu » Preferences … » Edit » Use smart cut and paste.

Margins — changing the size of 

You can specify the size of margins by choosing Format menu » Document » Margins tab » amend left or right margin by using arrows or keying in values in the appropriate fields.

In Word 5.1a you could also do this in Print Preview. The advantage here is that where space is tight you can get a feel for how close you are to popping text over to the next page. In Word 2001 the feature is available in Page Layout view, albeit rather obscurely. To change the right-hand margin:

1.
Change to Page Layout view (Command-Option-p).

2.
On the document’s calibrated ruler, hover the I-beam above the right-hand tab: [image: image53.png]



3.
Leave the I-beam there until it changes to an arrow pointer and a yellow screen tip labelled “Right Indent” appears.

4.
Roll the mouse very slowly upwards. The pointer will change to a square and the screen tip label will change to “Right Margin”.

5.
Press the mouse button and drag the margin. If you hold down the Option key (either before or during the operation), the dimensions will show.

To change the left-hand margin is a pain. If you have superb eyesight and very fine mouse control, do this:

•
Do as in steps 1–4 above, but hovering the I-beam on the left-hand tab: [image: image54.png]



•
The following is the most position-sensitive operation I know of in any application: extremely slowly, roll the pointer up to about two pixels above where the two tabs point to each other (i.e., about two pixels above where the lines intersect in an “X”). The pointer will change to a square and the screen tip label will change to “Left Margin”. Without daring to move even one pixel, press the mouse button down, then drag the margin. If you hold down the Option key (either before or during the operation), the dimensions will show. 

Alternatively, do this in relation to the left-hand margin:

•
Drag the upper (first line indent) tab to the right to make more space: [image: image55.png].Y




•
Carry out steps equivalent to 3–5 above. 

•
Drag the upper (first line indent) tab to the left again, back to its original position.

Print Preview — losing the place on coming out of 

In some documents, when changing from Print preview to Normal or Page Layout view, the document does not go to the page last viewed. Command-Option-z may be helpful — it moves successively through the last four places where text was typed. 

Scrolling is too fast

If you don’t use a scroll mouse, Word 2001 can scroll at such a fast speed (e.g. if you have selected text and you’re dragging it because you want to move it) that it feels like you’re a novice ice-skater.

A useful feature to limit this problem is Word’s “AutoScroll”. From the Tools menu, choose Customise » click “Commands”. Select “All commands” in the left-hand (“Categories”) scroll box. In the right-hand scroll box (“Commands”), scroll down to “AutoScroll” and drag the word “AutoScroll” to a toolbar or menu. Click OK to close the Customize dialog box. Then click the AutoScroll button you made (or choose it from whatever menu you put it on). A little practice is needed to get used to it, but now you can scroll through the documents at controllable speed.

A better option is to get a two-button (or multi-button) mouse with a scroll wheel. Not only does this make scrolling in all sorts of contexts much easier, it allows you to right-click. Word is quite right-click-centric, and the one-mouse alternative (Control-click) is less convenient.

Spelling — ignoring one instance of mis-spelling

The spell-check pop-down menu (invoked by clicking once in the mis-spelled word, then Control-click — or right-button-click if you have a two button mouse) doesn’t have the option of “Ignore” — only “Ignore all”. You have to go to Spelling ... (on the same pop-down menu) to have the “Ignore” option.

Totalling columns and other series of numbers

In Word 5.1 a very useful capability was to total a series of numbers by selecting them and keying Command-[“equal” sign]. 

The capability is available in Word 2001 and Word 2004, though not on a default menu, from a “Tools Calculate” button. As in Word 5.1, it evaluates selected numbers as a mathematical expression and displays the result in the status bar (and the result is also in the clipboard, ready to be pasted where you want). You can select numbers by Option-dragging as well as by selecting paragraphs, cells or lines. The command is available via Tools menu » Customize » Commands tab [make sure “Normal” is in the “Appears in” pop-down window at bottom left] » click on Tools in “Categories” scroll-box » scroll to bottom of “Commands” scroll-box (because the items are not in alphabetical order) » click on Tools Calculate » drag to desired toolbar. See page 45 for notes on adding a button to a toolbar. 

For more information on Tools Calculate, see http://word.mvps.org/faqs/General/ToolsCalculate.htm

Word 2001 and Word 2004 also have a more powerful feature for numbers in tables via the Table menu » Formula — but if the column contains a blank cell, or a blank paragraph mark in a cell, the feature doesn’t work. 

Appendix A: The main “minimum maintenance” features of my documents

The concept of “minimum maintenance” arose early in the history of modern word processors, when people became aware of the time savings that could be achieved if they could avoid having to check a long document’s pagination and attend to the unintended consequences of other re-formatting before each printing. The potential time savings are huge — yet few people seem aware of how minimum maintenance is achieved. 

Essentially, the concept of minimum maintenance involves formatting the document in such a way that it does not have to be adjusted manually — for example, through checking and altering the pagination — if text is added or removed anywhere in the document. At its best, minimum maintenance allows you to simply hit the print button (or convert the document to PDF, or send it by e‑mail) whenever you want to, without needing to carry out any actions to specifically prepare the document. 

A document not formatted for minimum maintenance will typically have many hard page breaks — or, worse still, will have added blank paragraph marks at the bottom of pages to force paragraphs to the next page, or hard returns to force paragraphs to break at a particular place. If anything changes the length of text in the document, all hell breaks loose: for example, large gaps can appear in the text, chapters can start on the wrong page, headings can appear as the bottom line on the page. Or headings will be formatted as variants of Normal style, and won’t contain any formatting instructions — such as to glue themselves to the text that follows them. Every time the originator wants to print or send such a document, they will have to check the pagination throughout and move the hard page breaks around — for example, to force a page break before a heading that has ended up as the last line at the very bottom of a page so that the heading joins up with the text that begins on the next page.
 

I’ve found the worst situation to occur when a document not formatted for minimum maintenance has been adjusted manually to the satisfaction of the originator, and is viewed by other people on the originator’s network without any problem. But once the document is sent to a recipient off the network who has a different printer driver from the originator (whether on a Mac or Windows platform), problems will occur. Seemingly identical fonts can take up more/less space than in the original (sometimes only by tiny amounts), producing different pagination that can completely disrupt a manually paginated document. Such a difference may push the last line of print from one page to the next — but if a hard page break has been inserted after that line it will force the text that follows this line of print on to another new page, leaving the one line of print orphaned at the top of the page. 

Another example involves hanging indents that had been formatted manually by inserting tabs at the start of the second and subsequent lines, as shown in this screenshot (and yes, the verbiage throughout was as bad as their formatting):
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When viewed on another computer, the slightly different space occupied by the font (e.g. through having a different printer driver, or by being cross-platform) can cause the text to break up, as in the following screenshot (the tabs are the ones that were originally at the left-hand margin, as above):

[image: image57.png]OUTCOME: —+ WRDC HAS IMPLEMENTED - AND MAINTAINED EFFECTIVE, EFFICIENT
AND + -  ACCOUNTABLE MANAGEMENT PROCEDURES AND SYSTEMS THAT

~ = ENSURETHAT THE COMPANY CONDUCTS ACTIVITIES IN
ACCORDANCE WITH + —+ RELEVANT LEGISLATION AND POLICIES




The solution is to do a “Replace” command (Command-Shift-h in Word X and 2004, Command-h earlier) to replace tabs with nothing (achieved by putting ^t in the top (“Find What”) field and clicking the cursor into the bottom (“Replace with”) field, and clicking the Replace button as appropriate. Once the superfluous tabs have been eliminated, it’s easy to apply (or create) a style with an appropriately dimensioned hanging indent to restore the original appearance, or if it’s an isolated instance to modify the paragraph manually:

[image: image58.png]



The resulting “minimum maintenance” layout will keep the hanging “OUTCOME:” in place no matter what the computer or font:
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Minimum maintenance formatting therefore becomes especially important for people who send long documents to others who are not on the same computer networks or do not have identical printer drivers and peripherals. If such an originator is indifferent to the problem because “it looks OK on all our computers — it must be your computer’s fault”, then quickly changing the document to minimum maintenance formatting becomes a high priority for you — if only because your textual amendments will probably “break” some of the manual formatting of the originator, at least when they open up the document.
 

Exactly what minimum maintenance features you put in a document will depend on factors such as:

•
the uses to which you will be putting the document;

•
who you are likely to send it to;

•
what printer driver they have;

•
whether they are on the Windows platform or the Mac platform;

•
what fonts they have, irrespective of the platform; and 

•
how skilled they are (can they handle, or do they want to handle, Word’s “Comments” feature, for example?).

The document you are now reading is formatted for minimum maintenance as applicable to a document that’s intended to be always displayed electronically — almost the same as for documents intended to be printed or PDF’d, but not quite. You can investigate its formatting by choosing Format menu » Style and looking at the definitions of styles in the scroll box; by keying Command‑8 to show tabs etc; and by setting up a Style Area as shown on page 109. If you think you might change something that you shouldn’t, make a “Save As” copy on which to carry out your investigation. 

To avoid having to manually alter your formatting before printing or e‑mailing

	Feature
	Comment
	Page no.

	Numbers etc not split at ends of lines
	To avoid having, say, “$5” at the end of one line of text and “million” on the next, use a non-breaking space (Option‑Spacebar).

[Another instance: on certain types of documents where such things really matter, I use a non-breaking space to avoid having “I” (i.e., first person singular) as the last word on a line, especially if the “I” is starting a new sentence. In practice I do this just before preparing a PDF and only apply the non-breaking space to instances where an “I” is actually stranded — although some people always keys Option-Spacebar after “I”.]
	n/a

	No hard page breaks
	Only use them when the content requires that you always start a new page at that spot.
	161

	Tabs not used to indent paragraphs (either first line indent or hanging) 
	As described above. (The problem described there can arise on your own computer, not just other people’s — such as when you change margin size or modify styles.)
	162

	Headings formatted to keep with the next paragraph
	This saves having to put a hard break before them when headings appear at the bottom of a page.
	92

	Body text formatted with “leading” (i.e., a blank space of a specified size — pronounced “ledding”) above or below the paragraph, so that you do not put blank paragraph marks between paragraphs — see page 174. 

[Note: “bt” is the style applied to body text in this document.]
	Blank paragraph marks (that is, achieved by hitting the Return key twice to create a new paragraph) have several disadvantages, the most noticeable of which is to prevent headings from “gluing” themselves to following body text. Incorpor​ating space before or after a heading style saves having to put a hard break before any headings that end up at the bottom of a page, or having to manually add other corrective formatting.

If you include leading in the paragraph style for body text, rather than having blank paragraphs, then whenever you want to squeeze some text to fit it on a page it’s easy to select the paragraphs and nudge them closer, or further apart, by changing their leading. For more details, see page 174. 

I’m told that a further argument against having blank paragraphs is that they contribute to the number of crashes you can suffer. A paragraph mark is a container that holds about 250 properties of the document, and if it does not also contain text, the potential for trouble increases.
	96

	The paragraph that precedes a sequence of bulleted sub-paragraphs is formatted to keep with the first bullet point
	This prevents the colon at the end of the introductory text being the last character on the page. Often, if the bullet points take up only a line or two, I also apply this formatting to the first bullet point too, so that at least two bullet points follow the introductory text. But if the lead-in sentence or bullet points are long, I don’t apply the “keep with next” command, because it also inherently applies “keep lines together” to the paragraph.

Depending on how often you use bulleted lists in a particular document, you can either devise a special style or add manual formatting — best done with a button on a toolbar. If in doubt, always choose to use styles rather than manual formatting. 
	
109

	Table cells formatted not to split when going to the next page
	Done by selecting the whole table from the left margin and choosing Table menu » Table properties » “Row” tab » de-select “Allow rows to break across pages”. (It’s useful to know that “Keep lines together” and “Widow/orphan control” have no effect in table cells if “Allow rows to break across pages” is enabled, and “Keep with next” applies only between rows, not between paragraphs in a single row.)

Make sure the style for the text in the table does not include Widow/orphan Control.

For further information, see the article at http://word.mvps.org/FAQs/TblsFldsFms/KeepTableOn1Page.htm
	92, 109

	Almost all formatting applied with styles
	Allows document-wide modification at any time in the future, for reasons of space (pagination), aesthetics, or interchangeability between computers.
	85

	Table of contents updatable automatically
	By selecting from the left-hand margin next to the first line in the table and keying F9 or Shift-Option-Command–u (see the note on page 21). Must use styles that are headings — default or tailor-made.
	63

	Cross-references updatable automatically
	Need not be kept as fields in documents sent to others, since cross-references are easily converted to plain text — although they are not convertible back.
	20

	Headers updatable automatically
	For example, with document title, version number or date printed.
	139, 139, 178


To minimise problems on other people’s computers (Mac or PC)

See “Stopping other people’s styles over-riding yours when they receive your document” on page 116. 

If you want to keep the size of Word files to a minimum, see the notes on page 134.

In the criteria for minimum maintenance I also include minimisation of problems on other people’s computers (whether on the same platform or not). These features help, in addition to those in the table above:

	Feature
	Comment
	Topic is on page no. 

	For documents that will go to a PC: use fonts that behave almost identically on Mac and Windows.
	These are Times New Roman, Arial and Wingdings. 

The font situation in Word 2004 has changed radically, with cross-platform compatibility much improved: see page 137. 
	136

	Add the letters “.doc” to your file name.
	A correctly set up Windows operating system does not need these file extensions, but many Windows users don't know how to associate files with applications. As with OS X, when things start to go wrong, a file extension is a good idea: it can help when everything else fails.
	

	Don’t format text in Normal style.
	As discussed on page 96. (For example, the default Normal style in Word 97 is 10 point, whereas in other versions it’s 12 point. That produces major changes in pagination and appearance.)
	96

	Use non-default style names 
	Especially if you’re unsure how the other person’s computer has been configured. 
	96

	Avoid automatic bulleting and numbering. 
	Corruption occurs easily. Especially important if the text will be imported into certain non-Microsoft software.
	145, 153

	Avoid other features that tend to cause corruption. 
	See under the heading that follows this table: “To minimise document corruption”.
	

	If you are working cross-version as well as cross-platform, choose the lowest common set of functions and use only those.
	For example, don’t use floating tables, nested tables or border lines. Never use “floating” graphics or tables — in other words, check that all pictures, and all tables, are formatted as “in line with text”.
	

	If possible, select the printer on which you will ultimately be printing the document (even if not connected to the printer where you’re editing).
	This will show exactly where the page breaks will fall. (This won't help if you need to e‑mail the document to others.)
	

	Look at the effect of changing the printer metrics.
	Achieved by choosing Edit menu » Preferences » “Compatibility” » “Options” scroll box » scroll to “Use printer metrics to lay out document” » select or de-select it » OK.
	

	If you are e‑mailing the document to others, consider e‑mailing the document as an Adobe Acrobat PDF file.
	PDFs preserve the formatting as it appears on your computer.

You can even make a PDF of a document you have processed via Track changes » Compare documents if you want to show the changes but not apply Track Changes to a shared, active document. For more details, see page 63.
	

	Avoid the “Comments” feature
	Many people don’t know that Comments are present. They are a nuisance to remove. It’s better, and quicker, to include them in the text, especially using a distinctive style.

(This style, “comment para,cp”, is an example of one. Where a comment takes up less than a whole paragraph, I apply a character style, such as my “comment in text, ct” style). 
	125


Additional information is in a Microsoft Knowledge Base article number 302624, titled “WD2001: How to Prepare a Word for Mac Document for Use on a Windows-Based Computer”, at http://support.microsoft.com/default.aspx?scid=kb;en-us;302624

To minimise document corruption

Finally, I also like to minimise features that could cause document corruption in the short or longer term. These features help: 

	Feature
	Comment
	Page no. 

	Ask the recipient to make sure “Allow fast saves” is turned off.
	Only if the recipient will be working on the document. 

It’s also advantageous to turn on “Always Make Backup” in Edit menu » Preferences » Save. This makes a backup copy of the document as it existed when first opened for the current work session, and updates that backup each time you save. 
	31

	Avoid “Track Changes”
	Serious corruption problems can occur with Track Changes. I strongly prefer, as an alternative to Tracking Changes, making a “Save As” copy and doing a document comparison with my earlier document (Tools menu » Track Changes » Compare Documents) on this spare copy. It’s far better for all parties to do this — see the notes referenced in the next column.
	63, 65

	Avoid “AutoFit to contents” in tables; don’t cut and paste table cells when preparing the document. 
	This and other problematic aspects of tables are best avoided — see article on page 60. 
	60

	Minimise the number of bookmarks.
	Often documents that behave weirdly are much better after deleting mysteriously generated bookmarks. To remove unwanted bookmarks, choose Insert menu » Bookmark and delete the bookmarks (other than any you may have deliberately created) one by one. Check on the Hidden Bookmarks option and delete them, too. But make sure you don’t remove bookmarks that may be necessary for some hyperlinked cross-references to work (if you look at the visible bookmarks in this document, for example, you’ll find that some have logical names I’ve chosen — so you can infer they are there for a reason — and the hidden ones have been generated automatically and may be candidates for removing).
	

	Minimise pictures, OLE objects, complex headers and footers, outline numbered lists, and landscape sections in a portrait document.
	All these tend to cause corruption, in addition to those listed in this table and the previous table. 
	

	Use few section breaks.
	They tend to harbour corruption, much like the final paragraph mark in a document.
	59

	Don’t drag margins around in the document’s ruler.
	Instead, amend them via Format menu » Document. 
	

	Create keyboard shortcuts, commands and toolbars in templates other than the Normal template, where practicable. 
	Customising and editing of commands, keyboard shortcuts and toolbars will, in time, corrupt the Normal template.
	42


Appendix B: Specifications for some of my styles — especially to reduce the chances of changed appearance on other computers

The appearance of styles you have chosen may be changed quite radically when your document is opened on another computer — see page 116: “Stopping other people’s styles over-riding yours when they receive your document”. This topic is also discussed in Appendix A: The main “minimum maintenance” features of my documents. Discussions of other reasons for avoiding default styles when you share documents and you want to retain the appearance you have chosen are at http://word.mvps.org/FAQs/Numbering/WordsNumberingExplained.htm

Below are the specifications of my most commonly used styles for various types of body text. Comparable information on Heading 1 style is on page 94. 

	If you are studying this subject closely, you will find it useful to print out a list of styles in this document now: choose File menu » Print » pop down the menu that shows “Copies & pages” to “Microsoft Word” » next to “Print what”, pop down the menu that shows “Document” to “Styles” » if you want a PDF rather than a hard copy, click on the “PDF” button at bottom left and choose “Save as PDF” » Print.

A more detailed discussion of the styles listed here is in a separate document, titled “Ideas for style specifications in Word documents.doc”, available from http://word.mvps.org/Mac/Bend/BendWordToYourWill.html


	Style name
	Based on
(see note 1)
	Style for next para
	Font
	Paragraph settings

	Text styles:

	bt
(Stands for “body text” — but I don't use the full name, to distinguish it from the default style of that name)
	No style
(Important: see note 2)
	bt
	10.5 pt

I have used Arial since screen resolutions became higher on Mac laptops (i.e., displays became finer). 

Before that I used Times New Roman, in 11 point.

In Word 2001 and earlier I used Times, but Times New Roman should be used with later versions of Word.

Language: in my case, English (AUS)
(see note 3)
	Alignment: 
Flush left

Outline level:
body text

Space before (i.e., the leading above the paragraph): 
10 pts
(see “The advantages of including leading (blank space above or below) in styles” on page 174). Occasionally, for tighter work, I use 8 points.
Line spacing: 
at least 13 pt (this gives a more open appearance than “single”, making it easier to read on screen and on paper, and in 11 point takes up almost 20% less space than 12-point font with single line spacing.)

Widow/orphan control (this enables Word to split a paragraph across a page provided that at least two lines remain either side of the page break)

	footnote text
	bt
	footnote text
	Font 9 pt (10 if using Times New Roman for bt), raised by 3 pt to match the superscripting of the footnote reference number.
	"Hanging indent" paragraph formatting allows a tab to follow the footnote reference number, not a space — much neater: indent left 0 cm, hanging 0.53 cm, line spacing at least 11 pt, space before 6 pt.

Space before: 6 points.

	s

Stands for 
“sub-paragraph”

For use when bullets (Option‑8) or numbers are keyed in to minimize the chances of corruption arising from the use of automatic bullets
	bt
	s

Therefore, before you assign this style to the first sub-paragraph you are typing, you should place a “bt” paragraph mark below it
	
	Indent: Left 0.17 cm Hanging 0.47 cm

Space before: 
6 pts

	s continuation,sc

For use on the rare occasions when I can’t avoid splitting a sub-paragraph into two and style “ss” is inappropriate — i.e., it’s necessary to continue in the same sub-paragraph.
	s
	sc
	
	Indent: first line 0 cm

	ss

Stands for “sub-sub-paragraph”

For use when a [manually] bulleted sub-paragraph needs further division and an "en dash" (Option-hyphen), or a letter, is keyed in to minimize the chances of corruption arising from the use of automatic bullets
	s
	ss
Before you assign this style to the first sub-sub-paragraph you are typing, you should therefore place a “bt” paragraph mark below it
	
	Indent: Left 0.91 cm Hanging 0.47 cm

	ss continuation,ssc

For use in sub-sub-paragraphs, as for style “ssc”. I avoid it wherever possible.
	ss
	ssc
	
	Indent: first line 0 cm

	sb

Stands for 
“sub-paragraph, bulleted”

For use when you prefer a bullet to be incorpor​ated automatically into the style, despite the increased chance of document corruption
	bt
	sb
	
	Bulleted automatically
(see note 4)

Indents left 0.17 cm and hanging 0.47 cm, space before 6 pt, bulleted, Level 1, aligned at 0.99 cm, tab after 1.63 cm, indent 1.63 cm

( If you want to use this style (or other complex ones), just apply it in “Bend Word to Your Will” and copy the paragraph mark

	ssd

Stands for “sub-sub-paragraph, dash”

For use when an automatically bulleted sub-paragraph needs further division and an "en dash" or other character incorpor​ated into the style is preferred
	sb
	ssd
	
	Bulleted automatically
(see note 4)

Left indent 0.91 cm, hanging 0.47 cm. Tab 1.38 cm, List tab + not at 0.64 cm, bulleted + Level 1, aligned at 1.73 cm, tab after 2.37 cm, indent at 2.37 cm

See note above

	table text,tt

(this avoids the perils of Word’s “Table Style” collection — see page 61)
	bt
	table text
	Arial, 10 pt
	Line spacing: 
at least 12 pts

Spacing: 4 pts before, 2 pts after

Not widow/orphan control, to allow the underlying pagination to be more apparent

	table heading,th
	table text
	table text
	
	Spacing: 6 pts before, 4 pts after

Bold

Keep with next

Keep lines together

	comment para,cp
	no style
	bt
	See page 125. 
	


For my definitions that build on Word’s default heading styles, see the table on page 94 for “Heading 1,1” characteristics. The second paragraph after the table describes how to see the definitions of other headings in this document. For a summary of headings that do not generate entries in tables of contents, see page 85.

Notes

1.
Characteristics under the column headings “Font” and “Paragraph settings” are in addition to the characteristics of the “Based on” style shown in this column.

2.
Whenever possible, as in this document, I base the style “bt” on “no style”. Then I specify “bt” as: Arial (sometimes Times New Roman) 11 pt, English (AUS), flush left, line spacing at least 13 pt,
 space before 10 pt, widow/orphan control.


By not basing the style on Normal, a number of document stability advantages accrue (discussed elsewhere, including “Numbering, automatic” on page 145) and a recipient’s Normal style cannot over-ride yours. For more details, see pages 116 and 96.

To base style “bt” on “(no style)”, choose Format menu » Style » “Modify” button » “Based on” pop-down menu near top left of window.

To base style “bt” on Word’s default Normal style of Times New Roman 12 pt, flush left, single spacing and widow/orphan control, I would specify style “bt” as Normal + font 11 pt, English (AUS) (even if I have changed Normal to this), flush left, line spacing at least 13 pt, space before 10 pt, widow/orphan control.

3.
Assign the language that you use, and assign to Normal style as well. For documents used in Australia, I also change the language of Normal style to English (AUS) so that all spelling is checked from the same language, which prevents problems later. Choose Format menu » Style » scroll to and select Normal » “Modify” button » “Format” button » Language » English (AUS) » OK.

If you paste in text from another person’s computer, you should be aware that it may be formatted directly in another language — most probably English (US). The simplest way to correct this (thereby allowing Word to accept non-US words such as “centre”) is to key Command-a (“Select all”) » Tools menu » Language » scroll to your desired language » OK. (This happens so often in Australia that I have made a toolbar button to do this.)

4.
For a discussion of bullets and numbering, see page 152. For reasons why I don’t use Word’s default styles — in this case it would be ListBullet style — see pages 116, 161 and 165. I avoid Symbol font for bullets, because their size draws too much attention to them. The specifications for the bullets in Arial or Times New Roman font are eight levels down: choose (in this document) Format menu » Style » Modify » Format » Numbering » “Bulleted” tab » click on the “sb” frame » Customize » “Bullet” and “Font” buttons. 

The advantages of including leading (blank space above or below) in styles

Leading (pronounced “ledding”, from the days when the space was achieved by a strip of metal between the lines of type) is the blank space above or below a paragraph. Usually it’s specified in points. 

Word’s default paragraph style, Normal, does not have any leading, but other styles — especially heading styles — do. The default “Body Text” style has 6 points of leading after (below) the paragraph. 

Every one of the styles I have created incorporates leading, with the number of points carefully chosen to minimize (usually eliminate) manual formatting. 

There are several advantages to including leading in a style:

•
Headings “glue” themselves to subordinate text. Maybe you’ve seen a heading that has ended up on the bottom line of a page, with the subordinate text having slipped over to the next page. That’s caused by the spacing under the heading being inserted via a blank paragraph, achieved by hitting the Return key. Word’s headings are programmed to “glue” themselves to the following paragraph (usually the subordinate body text), but in this case the intervening blank paragraph does not have any “keep with next paragraph” instructions in it). So the heading stays behind as the last visible item on the page. Most people “fix” this by inserting a page break just before the heading — but if you are still adding text to the document before the page break, it will soon become a misplaced nuisance. 

Incorpor​ating space before or after a heading style (and if applicable before or after a body text style) ensures the simplest outcome: if a heading ends up at the bottom of the page it will automatically move to the next page. Hard page breaks other corrective manual formatting are not needed.

•
“Creeping” more or less text on to a page. If you are preparing a document for final publication in Word and you need to get more or less text or graphics on a particular page, you can “creep” text closer together, or space it out more, by:

–
selecting the paragraphs involved, keying Command-Option-m to bring up the paragraph window, and changing the value of the “points before” or “points after”; or

–
doing the same thing more quickly with toolbar buttons or keyboard shortcuts, as described on page 191. 

If you ever need to return these paragraphs to the characteristics of the underlying style (for example, if the pagination is subsequently changed, you can achieve this by selecting the paragraphs and keying Command-Option-q.

Some people say they don’t want to include leading because they have problems when compiling addresses, for example. That’s easily handled by keying “manual line breaks” or “newline” commands (Shift-Return) at the end of address lines (you can easily do a Find-and-Replace for this, too — the break is “^l” ( lower case “L”). Or you can use a style specific to addresses that doesn’t have any leading.

Leading above, or below, paragraphs?

John McGhie (in an article referenced on page 98) describes why he prefers having x points below (which Microsoft calls “after”) paragraphs, rather than above/before them: 

I always used to specify ONLY “Space Above” in Word. This is the easiest way to work, and always results in things being correctly spaced. If you use only space above, you never have to worry about creating dummy styles for paragraphs such as the last item of a list or the first item after a heading just to get the spacing right. I have seen users setting style sheets up with a “List first” a “List middle” and a “List Last” style. Can you imagine the confusion caused after someone slings a few paragraphs around during editing? 

However: there is a bug in Word’s pagination rules that means it does not suppress “Space Above” at the top of all pages. The rule should be that “extra leading” (“Space Above” to you and I) should always be suppressed following a page turnover. Every typesetter does this. But Word will suppress the space above only if Word causes the paragraph to move to the next page. If you do so (with a Page Break or by using a Page Break Before setting on the paragraph, or with a Section Break, or if you have Space Before set for the first paragraph of the document), Word will leave the space there.

So you get your top text margin bouncing up and down depending on whether Word has suppressed the space or not. It looks really ugly, and it’s pretty embarrassing to be caught with it as a professional. It’s sort of “Pagination 101”  :-)

The Compatibility Option “Suppress Space Before after a hard page or column break” doesn’t suppress the Space Before for paragraphs that follow a Section Break, or that have a Page Break Before setting, or for the first paragraph in the document; and as discussed earlier, you should avoid using hard page breaks at all costs; so this option is not really much help at all, except in the case of hard column breaks in multi-column documents such as flyers.

This pagination bug has been around since Word 6, and Microsoft can’t understand why we’re complaining. Because inexperienced users never notice, they never complain — although you can, by emailing mswish@microsoft.com. 

So I now specify only “Space Below” on all my body text and list paragraphs and set space above to zero. That way at least I get the page top even.

To avoid triggering the bug, do your pagination control using “Keep With Next”. This causes Word to move the paragraphs, and so Word correctly suppresses space above on the headings. It’s also much less work than filling the document with hard page breaks that you have to adjust every time you edit the document.

I agree with John, but because I’m in a different situation I put leading above/before, for the most part. 

Underlying the reasons for our different practices in Word are our different professional environments. John customarily prepares huge (>1000-page) technical documents used by others, which they do not touch (how lucky can you be?) and which are published electronically as PDFs straight out of Word — never in hard copy. For John, it’s very important to have the top line of text on a page align with that of the opposite page, and to ensure that two columns of text align on the one page. 

On the other hand, I customarily work on strategic planning documents (typically up to 200 pages) that are intensively developed by several (or many) people, under my over-all direction. After we finish our plans, we hand the Word documents over to a graphic designer, who pours the text in quickly because the document’s styles are friendly to Quark XPress® or Adobe InDesign®. The documents do not need the tops of pages or columns to be aligned as John’s do. 

Only occasionally do I modify my documents manually away from the underlying characteristics of their pure-styles-based format, and even then it’s usually only to nudge the values of the leading of some paragraphs up or down to make them fit on a particular page (page 191 shows how this is done quickly). 

An important consideration for me is that the content of my documents is developed collaboratively between many colleagues. At the beginning of their involvement in our projects, most have a hard time getting used to consistent formatting, whether styles-based or not; I therefore try to adopt practices that cause the least aggravation to them.
 If there are two ways of doing things in Word (and there usually are at least two), I’ll opt for what newcomers to efficient formatting consider more intuitively correct. And “Space Before” is one of them. Most have enough difficulty coping with the idea of having any leading at all!

Another factor is that my documents frequently have bulleted or numbered lists, and for the reasons mentioned by John above, I don’t want to have to apply a special body style with less “Space Below” in the paragraph that precedes a list style. 

Although John says leading above/before “always results in things being correctly spaced”, there is one downside, which only concerns me in documents formatted for publishing in Word (which, as I’ve said, is rare for me). It goes like this:   

•
If you have 10 points of leading above all your body text paragraphs, it stands to reason that all headings — even down to Heading 5 and Heading 6 — must have at least 10 points above them. Otherwise they will be closer to the paragraph above them than the paragraph that follows.

•
With higher-level headings, you need more leading above them because they must be more prominent; without this increased leading their fonts would need to be larger still, which does not look good. I find 16 points necessary above Heading 2; 14 points above Heading 3; and 12 points above Heading 4.

•
These amounts of leading give a look that is too open.

In documents formatted for publishing in Word, therefore, I often counter the “gappy” appearance by reducing the space underneath the headings. Because this leading is a function of the body text, not the heading, I achieve this via keyboard shortcuts that apply the particular level of heading then move the insertion point to the line below and reduce the leading above it. The values are four points in the case of Heading 3, and two points for lower-level headings. More details are on page 197. 

The document you are reading now does not have that treatment, because it is a constantly changing work-in-progress in which appearance is far less important than content.
 I don’t want to have to change the leading back, manually, every time I move body text paragraphs that follow a heading. However, if the document were finished, and going through a once-off “tidy-up” before publishing, it would be a different matter. 

The conclusion to all this? Think carefully before you decide whether to have leading above or below your paragraphs. There is no “one true way”; it will depend not only on how many people prepare the document, the structure and appearance of the document, and whether the document is “published” directly from Word/PDF or page layout software , but also on other factors relating to your accustomed work practices. 

Appendix C: Making a toolbar with buttons for a variety of date formats

In Word 5.1, it was quite easy to call up short and long dates, in either “updating” or “fixed” formats. In Word 2001 and onwards, it’s easy enough to insert one type of date (for example, a self-updating long format date, if that’s what you have nominated as your default) but inserting other variations is mouse-intensive — and you have to check what the last type of date format was before you can confidently insert a date the next time. 

I wanted to have six buttons on a toolbar that will insert dates in common Australian-usage formats, as follows:

1.
Long date, updating: today’s date in a long form (such as 1 June 2003) that will update every day (=”DATE”). The [d MMMM yyyy] format is one of the standard options available.

2.
Short date, updating: as for (1), but in a short form, namely 1/6/03. This [d/MM/yy] format is also one of the standard options available.

3.
Long date, fixed: as for (1), but the date will be inserted as text so it will not update.

4.
Short date, fixed: as for (3), but in the short form.

5.
Short date as for (4) but preceded by the short-form day (Mon 1/6/03), all fixed. This [ddd/MM/yy] option is not available from the standard choices, but it can be specified manually during preparation of the button; more details below.

6.
Alpha-numeric short date preceded by the short-form day (Mon 1 Jun 03), all fixed. This [ddd d MMM yy] option, like the date in (5), is not available from the standard choices, but it can be specified manually.

It’s a nit-picking business if you haven’t created macros before, but the effort is worth it. And this is quite a useful introduction to making macros, even if you don’t intend making any others. 

Dates in “updating” format

Buttons 1 and 2 initiate a macro that inserts their particular date field. 

Make the toolbar

First, make a new toolbar for the buttons you’ll be making and save the toolbar in the Normal template (or if you decided not to save customised toolbars in Normal, as discussed on page 42, in another template):

•
Show the toolbar that contains the custom button you want to store. 

•
Tools menu » Customize » Toolbars. 

•
Click New. 

•
In the Toolbar name box, type the name you want. 

•
In the Save in box, click the template or document you want to save the toolbar in, and then click OK. The new toolbar remains showing on the screen.

•
Do one of the following for each custom toolbar button you want to store: 

–
To move a button, hold down the Command key and drag the button to the new toolbar. 

–
To copy a button, hold down Option key and drag the button to the new toolbar.

•
To hide the toolbar, hold down Control key and click the toolbar, then clear the tick next to its name in the contextual menu.

Record the macro

Consult the instructions under “macros” in Word Help if need be. 

Open a blank new document, then choose Tools menu » Macro » Record new macro. Name the macro for the option in sub-paragraph 1 above “LongDateUpdating” and click on the “Toolbar” button. A window titled “Customize” will appear. Under the “Commands” tab, in the right hand box, is the name of the macro. Drag it to the new toolbar. The macro will now begin recording your actions. Choose Insert menu » Field. In the window that appears, select “Date and Time” in the left box and in the right box select “Date”. Make sure there is a tick against “Preserve formatting during updates”. Then click the Options button. The following window will appear. Scroll down and select “d MMM yyyy”, as shown, then click on “Add to field”:

[image: image60.emf]
The characters shown in the “Field codes” field (below) will be put into the macro when you click “Add”. (When making buttons 5 and 6, this is the place where you will manually alter the date format because it is not listed in the scrolling list.)
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Click OK. The date will appear in the blank document. 

Click the blue square to stop the macro recording.

Modify the button’s name

To save space on the new toolbar, the next task is to shorten its name. Hold down the Control key and click the button to open the Properties window. Type in a shorter name. I used the name “1 June 2003∆” — the “∆” (Option-j) indicating an upwards arrow, reminding me that this date automatically updates itself:
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Test the macro

Test that the macro works before you go further. If you need to look at what the macro has recorded, you can reveal this script by choosing Tools menu » Macro » Macros » select the particular macro » click “Edit”:

Sub LongDateUpdating()

'

' LongDateUpdating Macro

' Macro recorded 26 June 2002 by Clive Huggan

'

    Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldEmpty, Text:= _

        "DATE \@ ""d MMMM yyyy""", PreserveFormatting:=True

End Sub

Repeat this exercise for the short updating date (format 1/6/03). I named it as shown on the far left button above. The script is:

Sub ShortDateUpdating()

'

' ShortDateUpdating Macro

' Macro recorded 26 June 2002 by Clive Huggan

'

    Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldEmpty, Text:= _

        "DATE \@ ""d/M/yy""", PreserveFormatting:=True

End Sub

[To edit information in a field code in a document — for instance, to add or change field switches — first display the field code by clicking the field and keying Shift-F9 (see the note on page 21).]

This is what the button looked like:
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Dates in fixed format

There are two alternative ways of scripting the macros for buttons 3 and 4.

The first way is to perform the same operations as in (1) and (2) but follow them by recording macro operations for [Delete key], which selects the field, and Command-Shift-F9, which converts the displayed characters to text. The script for the long-format fixed date will be as follows, with the last three lines above “End Sub” doing these extra operations:

Sub LongDateFixed()

'

' LongDateFixed Macro

' Macro recorded 26 June 2002 by Clive Huggan
'

    Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldEmpty, Text:= _

        "DATE \@ ""d MMMM yyyy""", PreserveFormatting:=True

    Selection.TypeBackspace

    Selection.Fields.Unlink

    Selection.MoveRight Unit:=wdCharacter, Count:=1

End Sub

The second alternative is a more direct scripting of the macro. Create a macro as above (it can do anything you want) and replace its scripting with the following:

Sub LongDateFixed ()

'

' LongDateFixed Macro

' Macro recorded 3 July 2002 by John McGhie
'

    Selection.InsertDateTime DateTimeFormat:="dddd, d MMMM yyyy", _

        InsertAsField:=False, DateLanguage:=wdEnglishAUS, CalendarType:= _

        wdCalendarWestern, InsertAsFullWidth:=False

End Sub

When giving the names to the fixed-date buttons, I added the “ ¬ ” symbol (Option-L) to remind me of the fixed status. This is what the buttons looked like:

[image: image64.png]


   and [image: image65.png]



Dates in fixed non-standard format

The scripting of the “Mon 1/6/03¬” button was made by manually inserting “ddd d/MM/yy” as the date format (see the “Field Options” screenshot above, and the sentence above it). The script appears as follows:

Sub DayShortDateFixed()

'

' DayShortDateFixed Macro

' Macro recorded 26 June 2002 by Clive Huggan

'

    Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldEmpty, Text:= _

        "DATE \@ ""ddd d/M/yy""", PreserveFormatting:=True

    Selection.TypeBackspace

    Selection.Fields.Unlink

    Selection.MoveRight Unit:=wdCharacter, Count:=1

End Sub

The scripting of the “Mon 1 Jun 03¬” button was made by manually inserting “ddd d MMM yy” as the date format. The script appears as follows:

Sub DayAlphaNumDateFixed()

'

' DayAlphaNumDateFixed Macro

' Macro recorded 27 June 2002 by Clive Huggan

'

    Windows("Document3").Activate

    Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldEmpty, Text:= _

        "DATE \@ ""ddd d MMM yy""", PreserveFormatting:=True

    Selection.TypeBackspace

    Selection.Fields.Unlink

    Selection.MoveRight Unit:=wdCharacter, Count:=1

End Sub 
The final toolbar looked like this:
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Appendix D: Making buttons for formatting shortcuts

As I’ve become more used to re-configuring Word, I’ve increasingly got into the habit of making more toolbars and buttons to suit the needs of particular types of documents. Once you’ve made a few, it’s easy to adapt them. In my work, the time savings are enormous.

I cover making buttons on toolbars in various contexts in several places in these notes:

•
Copying some of the standard buttons from the Standard toolbar, Ruler and Formatting toolbar to two new toolbars, essentially to save space on screen and protect against consequences of the Normal template corrupting (described on page 41 onwards).

•
Creating buttons on toolbars to apply selected styles and formatting (page 109). 

•
Appendix C: Making a toolbar with buttons for a variety of date formats (page 178).

•
Appendix G: Automating standard comments via AutoText items on a toolbar (page 204). 

The following notes describe some of the other buttons I have prepared to increase my efficiency. Some of them incorporate simple macros, usually kindly provided by John McGhie, John McGimpsey, Jim Gordon, Paul Berkowitz and Bernard Rey, and usually via the microsoft.public.mac.office.word newsgroup after I have got into difficulties, since VBA is not my strong point. 

Making buttons isn’t a laborious process — in fact, after you’ve made a few it’s remarkably quick — and is certainly justified by the time you save if you use Word intensively. 

I prefer to put buttons on small toolbars so that I need only display the extra toolbars specifically required in a particular document. However, with some documents (especially the ones I send to colleagues) I attach customised toolbars to them, often with clarifying wording included on the buttons. Inexperienced users find this very useful for getting used to styles. Here’s an example of one that I send to colleagues attached to reports or plans we’re developing. It’s for a PC user, hence the wording of the right-hand viewing button as “Print layout” rather than “Page layout”:

[image: image67.emf]
But for my own use, just as often the toolbars are a feature of the template to which I’ve attached a document. If the toolbars are attached to the template, any document based on that template will have the toolbars available. (However, it’s often a moot point whether one derives a document from a template or not, because usually once a document calls the formatting from a template the template's role is finished.)

A sample of this toolbar, and others that I have developed, is available for copying from “Document with toolbar examples.doc”, which can be downloaded from http://word.mvps.org/Mac/Bend/BendWordToYourWill.html
The following buttons are representative examples of the ones I have devised to meet my needs — often with help, because I’m a raw amateur with VBA macros. Possibly some of your needs may overlap mine; more probably the following notes will help you to design your own buttons for different purposes. 

The following buttons, and macros where applicable, are available for copying from “Document with toolbar examples.doc”, which can be downloaded from http://word.mvps.org/Mac/Bend/BendWordToYourWill.html
Please note: The macros will trigger a macros virus warning (irrespective of whether there is a virus) if you have set your preferences to do this — 
see the notes on page 33. 

Making a new toolbar, button and macro

To make a new toolbar

To make a new toolbar for the buttons you’ll be making, and to save it:

•
Tools menu » Customize » Customize toolbars and menus » “Toolbars” tab. 

•
Click New. 

•
In the Toolbar name box, type the name you want (I precede mine with the initial of my first name so that I know, when looking at the Toolbars menu or the screen tip, that it’s one of mine). 

•
In the “Save in” box, click the template or document you want to save the toolbar in, and then click OK. The new toolbar remains showing on the screen.

To add a button to the toolbar

If you are basing a new button on an existing button, do the following: 

•
To move a button, hold down the Command key and drag the button to the new toolbar. 

•
To copy a button, hold down Option key and drag the button to the new toolbar.

To create a button for which an existing button does not exist: choose Tools menu » Customize » Customize toolbars and menus » Commands tab [make sure your desired template or document is in the “Appears in” pop-down window at bottom left] » Categories: [scroll to menu that applies] » [scroll to appropriate command]. Drag button to appropriate toolbar and drop it.

To record a macro  

	If you haven’t yet used macros, be aware that Office 2008 won’t have them

For document professionals and corporate entities that rely heavily on macros, this is a very serious shortcoming of Office 2008, and may prompt them to stay with Word 2004, or if they have an Intel-chipped Mac to run Word 2007 under Windows® using Parallels. But if you have not become used to creating these marvellous time-savers you may prefer not to start.

Some macro capability can be replaced by AppleScript: see the article ‘Moving from Microsoft Office VBA to AppleScript: MacTech’s Guide to Making the Transition’, a magnum opus written by Paul Berkowitz and several fellow Mac Office MVPs at www.mactech.com/vba-transition-guide/index-001.html 


It’s useful to consult the instructions under “macros” in Word’s Help.

A very good article on installing macros in MacWord (and which leads to other articles) is at: http://word.mvps.org/Mac/InstallMacro.html

Other very good articles, including ‘How to modify a recorded macro’ are at the foot of the article.

For an article titled “What do I do with macros sent to me by other newsgroup readers to help me out?”, see http://word.mvps.org/FAQs/MacrosVBA/CreateAMacro.htm

The latter article is about Word on the Windows platform, but Word on the Mac works much the same (use the Option key where the notes refer to the Alt key). For notes on installing a macro on Macs, see http://word.mvps.org/Mac/InstallMacro.html

To record a macro, choose Tools menu » Macro » Record new macro. Name the macro (no spaces are permitted) and click on the “Toolbar” button. A window titled “Customize” will appear. Under the “Commands” tab, in the right-hand box, is the name of the macro. Drag it to the new toolbar. The macro will now begin recording your actions.

To insert the script of a macro that’s already been written, Copy the script. Choose Tools menu » Macro » Macros » select any macro » click “Edit” » go to the end of the list of macro scripts » Command-v to paste » Command-q to leave the VBA editor and return to the document. 

To add a macro to the toolbar

Once you have recorded a macro or inserted a macro script, it’s easy to install it on a toolbar:

•
Tools menu » Customize » Customize toolbars and menus » Commands button.

•
At the bottom left, pop the menu to the template or document into which you want to save the macro (e.g., Normal).

•
In the “Categories” list on the left, scroll down to Macros and click.

•
In the “Commands” list on the right, scroll to the name of the macro you want.

•
Drag the macro name to the toolbar (or menu). Click OK. 

The macro will now be on the toolbar. Shorten the name of the button by right/Control-clicking the button and selecting “Properties”.

	To shorten mousing distances if you have a second screen

I have an LCD screen next to my PowerBook when I’m in any of my offices. One disadvantage of a second screen is that you have to make a lot of mouse movements to reach the toolbars on the PowerBook screen. To overcome that in Word, I created a second set of toolbars identical to those on the PowerBook once I had shaken down the toolbars and buttons I needed.* 

Word always positions the second set correctly — for example, the LCD display I hook up next to my PowerBook in one office is a 17-inch, and at the other office (connected to the same PowerBook, which I carry between offices) is a 20-inch screen. The toolbars open up correctly at the top and bottom of the screen every time!

After positioning the duplicated toolbars on the second screen, I recorded two macros — each on a new toolbar comprising one button. The first of these one-button toolbars (titled “Show tbar2”) opens the second set of toolbars (that is, makes them visible), closes itself and opens the other one-button toolbar (titled “Hide tbar2”). And vice versa. 

*
I also use a Kensington Turbo Mouse, which has a ball the size and weight of a billiard ball; it’s easy to “toss” (flick) the ball right across both screens. And not having to suspend your wrist and forearm in the air as with a “normal” mouse is a huge advantage that avoids repetitive strain.


Making your own toolbar icons

A button design principle

I don’t find many commonly available icons useful for my buttons — which is not surprising, since the button functions are highly specialised — so I either make my own graphical ones or use an abbreviated term in text. 

With graphical icons, I don’t make any attempt to make them intuitively understandable to others. The over-riding aim is for me to know at a glance what the icon is for. Take, for example, the icon for my button that adds two points of leading (space before) to a paragraph every time it’s clicked: [image: image68.emf]
The bar represents the paragraph and the “n” represents “unspecified number of points of leading” after the paragraph. The upward pointing arrow indicates the increase — that is, to add 2 points. 

But in actual use, I don’t look at this detail — since I know what the buttons do, I just look for the pink (warm colour = add) at the top of the icon. Or blue (cool colour = subtract). And similarly for the others:
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(The button in the middle puts a value of 6 points as leading after the paragraph — a value that I often use in tables etc where zero is the value in a style. I have a keyboard shortcut for this: Control-Option-Command-6.)

[The macros for these buttons are described on page 191.]

Labelling a button with text 

After recording the macro, the next task is to shorten its name to save space on the new toolbar. Hold down the Control key and click the button to open the Properties window. Type in a shorter name. An example — for a button that shows the template, if any, that the document is attached to — is “Tplt?” 

Labelling a button with pixels

If I can’t devise a short name for a button, I create my own button icon design with pixel editing. But that’s becoming more and more difficult as the necessary tools are dropped with each release of Word (grit your teeth and see the panel).

	Where did the icon editor go?
The simple icon editor that was a feature of Word 2001 was not included in Word X and Word 2004. However, you can paste in an icon created in a pixel editor or drawing application. 

You can use a third-party image editor to create a 20x20-pixel image directly into Word 2004 or, if you have access to Word 2001, do it there.

To paste the image into a button in Word X or Word 2004, read “Copy an image from a graphics program to a toolbar button or menu command” in Word’s Help. With the image on the clipboard, right/Control-click on the blank button » Properties » pop down the tiny triangular arrow near the top left » “Paste button image”.
When will this be fixed? Is the march of progress inexorable? In Word 2008, you can’t even do the above — you have to create the entire button on a toolbar in Word 2004 or earlier, then open Word 2008 and transfer the toolbar+button to its “real” parent toolbar via the Organizer. And any button that summons up a macro (as distinct from a built-in Word command) won’t work anyway in Word 2008. Aaaarrrggghhh! This is an appalling, compounded, unforgivable design lapse. 

That said, given the problems with images on buttons you may like to make use of some of mine. You’ll find them in “Document with toolbar examples.doc”, which is available for downloading free from http://word.mvps.org/Mac/Bend/BendWordToYourWill.html


Useful buttons and macros

These are the main types of buttons I currently have in addition to those shown on page 109. They bring out a valuable characteristic of Word — a powerful ability to be configured to one’s individual needs — which saves me a huge amount of time and allows me to keep my mind on the intellectual content of the paper I’m developing. 

For notes on installing a macro on Macs, see http://word.mvps.org/Mac/InstallMacro.html

View the document at 125 per cent   

The context for this button is on page 44. 

My default font for body text is usually Arial or Times New Roman 11-point — and, as in this document, I prefer the more open appearance on a 13-point line spacing rather than 12-point at single spacing. On my 17" and 15" PowerBooks, since Word 2004 introduced Apple’s ATSUI display, Arial font is best viewed at 125 per cent and Times New Roman at 140 per cent. Of course on other machines, and with other fonts, a different percentage will probably be best. For example, the PowerBooks released in 2005 have even finer resolutions and I find 140% best for Times New Roman. I park this button (identified by the text “125%”) to the right of the Zoom pop-down on my Standard toolbar, as shown here:

Default “Zoom” pop-down ( [image: image70.png]125% ¥) 125%



 ( My button, here, saves having to pop “Zoom” down

The macro (excluding the “~~~~~~”) is as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub viewOneHundredAndTwentyFivePercent()

'

' viewOneHundredAndTwentyFivePercent Macro

' Macro recorded 5 January 2004 by Clive Huggan
'

    ActiveWindow.ActivePane.View.Zoom.Percentage = 125

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

And similarly with a button for “140” or any other zoom setting.

Paste unformatted text / plain text  

The contexts for this button are on pages 116 and 130. 

This button pastes in text devoid of formatting other than the characteristics of the paragraph at the point at which it is pasted — that is, it carries out the equivalent of Edit menu » Paste Special » Unformatted text » OK. 

I use this so often to paste text from websites, PDFs and manually formatted documents from other people, I have also allocated a keyboard shortcut (Control-Option-Command-p, which I find easy to key, with “p” standing for “plain”, but some people may prefer a variant of the standard “v” for pasting). 

The button is labelled with text (I use “plain” rather than “unformatted” only to save space):
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The macro (excluding the “~~~~~~”) is as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub PasteSpecialPlainText()

'

' PasteSpecialPlainText Macro

' Macro recorded 22 April 2003 by Clive Huggan
'

    Selection.PasteSpecial Link:=False, DataType:=wdPasteText, Placement:=wdInLine, DisplayAsIcon:=False   ( in the editor, type this on the same line as the one above
End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

	In Word 2004, the macro recorder will not record anything involving Edit » Paste Special, so you will not be able to record the macro above. However, it will work if you paste it into the VBA editor. More information: http://word.mvps.org/Mac/PasteText.html


“No proofing” button 

This causes the spell-check to ignore selected words. I use it mainly when I don’t want red wiggly lines to occur under these words when others read the document on their computer (as in these macro scripts). The button is labelled with text:
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I also allocated the keyboard shortcut Control-Option-Command-n (for “no proofing”) since I use this quite often. The macro (excluding the “~~~~~~”) is as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub noProofing()

'

' noProofing Macro

' Macro recorded 14 June 2003 by Clive Huggan
'

    Selection.LanguageID = wdNoProofing

End Sub

In Word 2004 I had to change this, because the language options changed. ‘Selection LanguageID = wdNoProofing’ became:

    Selection.LanguageID = wdEnglishAUS
    Selection.noProofing = True

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Hide Web toolbar

See “Web toolbar, to stop it appearing when clicking on TOC or other hyperlinks” on page 151. 

Apply a preferred language to selected text

For most of my work, I prefer to use a variant of English, namely Word’s “English (Australian)”. I find I often receive text from colleagues that is in English (US), even though they also prefer to use English (Australian). Usually this occurs because of the way their computer has been set up. The problem is that Australian place names and other terms used only in Australia are immediately underlined in my document as being discrepant. My solution was to create a toolbar button to apply English (AUS) to text that I have selected (or Command-a to select all the document). 

After the macro does its work, words are marked as discrepant only if they do not conform to what’s in my English (AUS) dictionary. 

The button is labelled with text:

[image: image73.emf]
The macro (excluding the “~~~~~~”) is as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub ApplyEnglishAust()

'

' ApplyEnglishAust Macro

'

    Selection.LanguageID = wdEnglishAUS
End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Add or subtract two points of paragraph leading

These buttons are used to nudge paragraphs closer to or further from other paragraphs or design elements when positioning is important. (That’s one of several reasons why it’s far better to have leading (which is blank space, of a specified number of points, above or below paragraphs) as part of their style, so that you can amend the amount of leading easily — either via the Format menu » Paragraph command or via these buttons or keyboard shortcuts. You can’t do that if you have empty, no-leading, paragraph marks between paragraphs.)

It’s desirable that adding or subtracting leading is available both above and below paragraphs, to handle all situations (though it’s very unusual for me to use both in the same paragraph).

I therefore have buttons for four variants, each of which triggers a simple macro that adds/subtracts two points of leading every time it is clicked:
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Each button is labelled by pixels as described on page 188. 

The macro (excluding the “~~~~~~”) for adding two points to the existing leading before the paragraph is as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub AddTwoPointsBefore()

'

' AddTwoPointsBefore Macro

' adds 2 points of space before (above) the paragraph each time you click the button

' Macro written 16/03/00 by John McGhie
'

    Selection.ParagraphFormat.SpaceBefore = _

Selection.ParagraphFormat.SpaceBefore + 2

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

It’s easy to amend the value for the other three macros: just change the “Before” to “After” and “+ 2” to “- 2” (or to another number).

I use these macros quite often, so I have applied two sets of keyboard shortcuts:

•
adjusting the leading above the paragraph:

–
Control-Option-Command-[up arrow] to increase the leading by two points at a time

–
Control-Option-Command-[down arrow] to decrease the leading by two points

•
adjusting the leading below the paragraph:

–
Shift-Control-Option-[up arrow] to increase the leading by two points at a time

–
Shift-Control-Option-[down arrow] to decrease the leading by two points at a time

I put six points below a paragraph so often (e.g. in the last paragraph in a table cell, that I also have a button for doing that: [image: image78.png]



Control-Option-Command-6 is the keyboard shortcut I use for this. 

The macro for putting 6 points of leading after the paragraph  is:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub sixPointsAfter()

    Selection.ParagraphFormat.SpaceAfter = 6

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Prevent cells (rows) from breaking across the page

This macro ensures that a table cell that is too large (high) to fit in the remaining space on a page is moved automatically to the next page rather than allow it to be split in two.

To use it, select the cell from the left margin by double-clicking, then click the button. 

I labelled the button with text:
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The macro (excluding the “~~~~~~”) is as follows:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub noBreakInRow()

'

' noBreakInRow Macro

' Macro recorded 4/10/04 by Clive Huggan
'

    Selection.Tables(1).Rows.AllowBreakAcrossPages = False

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Font colour buttons

Quite often I want to apply a particular colour to some text that isn’t inherent in the style for the paragraph. To do that quickly, I use a macro invoked by one of these buttons I created:
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Each button is labelled by making a purpose-built icon, as described on page 188. 

I also apply keyboard shortcuts for the colours I use most: Control-Option-Command-r for red, for example.

The macro (excluding the “~~~~~~”) for applying blue is as follows:

Sub ColorTextBlue()

'

' ColorTextBlue Macro

' colours selected text blue

' Macro written 30 March 2003 by George Clark

Dim rng As Range

        Set rng = Selection.Range
        ' Only if text is selected

        If Len(rng.Text) > 0 Then

            rng.Font.ColorIndex = wdBlue

        End If

    End Sub

For other standard colours, replace the four instances of “blue” in the macro above with the name of the colour. 

For non-standard colours, in the third-last line remove “Index” and replace “wdBlue” with the colour’s RGB numbers (to obtain them, see panel). For example, indigo’s RGB numbers are 51, 51, 153 — so the third-last line would read rng.Font.Color = RGB(51, 51, 153)

	Getting the RGB colour values

You can obtain the RGB numbers for any colour by using the DigitalColor Meter application, which shows the values for wherever your pointer (cursor) is on the screen — whether the desktop, an icon, text or object.

To obtain the RGB numbers for a particular font colour in Word, select a character, make it bold so it’s more visible, then apply the colour via the Font command — it can be one of the standard colours in the pop-down colour palette, or chosen from the colour wheel accessible via “More colours”. (You would do similarly for a fill colour, e.g. in a table cell.) De-select the character. 

Go to the Applications folder » Utilities » DigitalColor Meter » pop down to “RGB as actual value, 8-bit”, which is what MS Office uses. Ensure the “Aperture size” slider is at the far left, to confine the sampling to one pixel. 

Now, move the pointer back to the character that has the colour you want. Be sure to have the pointer on the correct pixel, not a paler variant on the edge of the character. 

The RGB values will be shown. Write these down and type them into the macro in place of the numbers already in the parentheses in the “rng.Font.Color = RGB()” line. You may find it best to lock the pointer on to the chosen pixel while you do that — key Command-Shift-h; repeat to unlock.

After you’ve finished, don’t forget to remove the bold and colour from the character you used to sample the values.

This screenshot shows DigitalColor Meter settings for indigo. 
[image: image81.emf]
[In normal use you would see the colour-sample character, or part of it, in the display area on the left, but I wanted to show the size of the little square at minimum aperture size — so after locking on an indigo pixel I moved the pointer to a white area, making the little square more easily seen.]


Change the font of the Normal (or another) style

Variants of this macro allow me to change the font of a style. For example, I use Goudy font in some of my business correspondence, but it doesn’t display well on the screen. So I type the letter up in Times New Roman then change the font to Goudy via a button. 

These macros are easy to change in relation to the style you want to modify and the font you want to deploy.

This is the macro for changing the Normal style to Arial (exclude the “~~~~~~”):

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub NormalToArial()

'

' NormalToArial Macro

' Macro 6 March 2004 by JE McGimpsey
' Changes font of Normal style, hence all styles based on Normal, to Arial

'

    ActiveDocument.Styles("Normal").Font.Name = "Arial"

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

But I use it mainly to change my body text style (bt) and styles based on it, since for various reasons mentioned in Bend Word to Your Will I only rarely use Normal style and never base my styles on Normal:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub btToArial()

'

' btToArial Macro

' Macro 6 March 2004 by JE McGimpsey
' Changes font of bt style, hence all styles based on bt, to Arial

'

    ActiveDocument.Styles("bt").Font.Name = "Arial"

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

This is the toolbar I set up for most purposes (the buttons are labelled with text):
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When screen resolutions increased on Mac laptops (i.e., displays became finer), I changed style “bt” to Arial. As I opened up older documents I progressively changed them. Setting up a keyboard shortcut (Control-Option-Command-a) allowed me to make the change in an instant. 

Delete unwanted OLE_LINK bookmarks

Word sometimes sprays OLE_LINK bookmarks around where text has been copied or pasted. The bookmarks are benign, but totally unnecessary unless you are linking the pasted data to a source. If you have set Word’s preferences to make bookmarks visible for other purposes, they can be very irritating being visible. 

I find that sometimes having Adobe Acrobat running at the same time can cause them to be created, and it’s possible that some haxie applications or add-ons could do the same.
 

This macro gets rid of them. Use it with care — e.g. on a “Saved As” copy of the document — until you are sure it works correctly for you. Exclude the “~~~~~~”.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 

Sub Kill_OLE_Links()

Dim oBkMrk As Bookmark

If ActiveDocument.Bookmarks.Count > 0 Then

  For Each oBkMrk In ActiveDocument.Bookmarks

    If Left(ActiveDocument.Bookmarks(oBkMrk).Name, 8) = "OLE_LINK" Then oBkMrk.Delete

  Next oBkMrk

End If

End Sub

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 

For frequently used commands, a keyboard shortcut alone may suffice

Whether you use buttons or keyboard shortcuts, or both, depends entirely on your working preferences. If Word had a better way to let you prompt for the keyboard shortcuts I would probably use fewer buttons. As things stand, I only use keyboard shortcuts exclusively for commands or macros that I use frequently.

A keyboard shortcut to go to the table of contents from anywhere in the document

The keyboard shortcut that I use most of all in my long documents (including Bend Word to Your Will) is Control-Option-Command-c (but any other combination could be used, of course). It’s a very useful navigation action — as useful as Command-Home. It invokes a simple macro that takes me to a bookmark titled “Contents” (not case sensitive) that I insert to surround the word “Contents” that heads the table of contents.  This is the macro:

Sub GoToContents()

    '

' GoToContents Macro

' Macro recorded 26/3/05 by Clive Huggan

' Goes to a bookmark titled Contents, at the heading for the table of contents -- I invoke it by a keyboard shortcut, Control-Option-Command-c

'

    ActiveDocument.Bookmarks("Contents").Select

    Selection.MoveRight Unit:=wdCharacter, Count:=1

End Sub

As this macro is in my Normal template, I have access to this feature as soon as I bookmark the “Contents” heading in any new or received document. 

Once I have arrived at the table of contents, I usually immediately follow with Command‑f to find the subject I’m after.

Create the keyboard shortcut as described under ‘Changing keyboard shortcuts’ on page 69 (you’ll find “Macros” down at the bottom of the “Categories” list referred to, below the list of menus).

	I use the “Control-Option-Command” sequence often for my own customizations. That combination might seem complex, but in practice it simply amounts to holding down those three adjacent modifier keys in a row, using three or four of your fingers — whatever fits!


A keyboard shortcut to reduce the leading under headings 3, 4 and 5     

There are downsides to putting leading (blank space) above body text (style “bt” in my case) rather than below, and vice versa, as discussed on page 177. I use a macro, triggered by a keyboard shortcut, to eliminate the main downside by reducing the leading of the paragraph under a heading — that is, to reduce the gap between the heading and the body text below it from 10 points to 4 (Heading 3) or 2 (lower-level headings).
Shift-Control-Option-3 is the keyboard shortcut I configured to apply Heading 3 style, move the insertion point down to the first line of the body text below and reduce the body text paragraph leading from 10 to 4 points via this macro:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Sub heading3andReduceLeadingBelow()

'

' heading3andReduceLeadingBelow Macro

' Macro recorded 8/3/06 by Clive Huggan

'

    Selection.Style = ActiveDocument.Styles("Heading 3")

    Selection.MoveDown Unit:=wdLine, Count:=1

    With Selection.ParagraphFormat

        .SpaceBefore = 4

    End With

End Sub
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Similarly, the keyboard shortcut Shift-Control-Option-4 applies a Heading 4 style and 2 points to the body text below it; and comparably for Heading 5 style (if I ever need to apply Heading 6 I’ll do it manually). 

Because I use “nontoc” heading styles frequently for level 3 and below, I configured similar keyboard shortcuts, with Shift-Control-Option-Command as the modifiers, for those styles.

Appendix E: Checks before printing 

This looks for lost links in the table of contents and cross-references:

	Find … 
	Action
	Notes

	Error!
	Re-establish lost links by keying Command-a to select the entire document and pressing the F9 key (see the note on page 21).
	“Error!” is part of ““Error! Bookmark not defined”, which Word automatically inserts when a link in this document is lost.


These checks look for incorrectly added or deleted spaces caused by the “Smart cut and paste” feature, such as before the first letter of a new paragraph:

	Find … 
	Replace with …
	Notes

	^p [space]
	^p
	Picks up lines starting with a space, caused by the Smart cut and paste feature (Edit menu » Preferences » Edit) inserting space in front of moved text. If your document contains text for macros, which are indented by using spaces (as in this document), you will need to check every instance manually rather the “Replace all”.

	^$—
(= any letter 
+ Shift-Option-hyphen)
	Manually add space before the em dash
	Picks up deleted spaces preceding em dashes, caused by the Smart cut and paste feature.

	Ditto but Option-hyphen
	Ditto en dash
	Checks en dashes

	—^$
(= Shift-Option-hyphen 
+ any letter)
	Manually add space after the em dash
	Picks up deleted spaces following em dashes

	Ditto but Option-hyphen
	Ditto en dash
	Checks en dashes

	^#—
(= any digit 
+ Shift-Option-hyphen)
	Manually add space before the em dash
	Repeats the checks, this time for numbers

	Ditto but Option-hyphen
	Ditto en dash
	Checks en dashes

	—^#
(= Shift-Option-hyphen 
+ any letter)
	Manually add space before the em dash
	Picks up deleted spaces following em dashes

	Ditto but Option-hyphen
	Ditto but en dash
	Checks en dashes

	Spaces removed by “Smart cut and paste” feature in headers / footers: check manually
	
	


If you also want to disembolden the page numbers and leaders (e.g., dotted lines) in Level 1 and Level 2 entries in the table of contents, see “Table of contents, formatting of” on page 62.

Appendix F: Formatting of fractions using AutoCorrect

	In Word 2004, for ½, ¼ and ¾ fractions the procedure described overleaf is not needed, because the fractions you key in (e.g., 1/2) are replaced by a Unicode formatted fraction font.  But other fractions are not automatically replaced. For that you need to nominate Unicode fraction characters (which you can trigger via AutoCorrect, as described in step 2, below). Alternatively — especially if a suitable character doesn’t exist in the font you use — you can take the actions described in the following notes. That may be particularly advantageous if you exchange Word documents with other people, because if your text is in a font that isn’t on their computer they will not see what you do, but will see a [probably] meaningless character.

OS X’s Character Palette is very useful

Unfortunately, most fonts have only the most common fractions as characters, and Word is only geared to AutoCorrect those. However, many of the more recent fonts include a number of additional fractions. The best way to get to them is through the OS X Character Palette.

If you don’t have it turned on, go to Apple menu » System Preferences » International. On the Input menu page, check the box for Character Palette and the one for “Show input menu in menu bar”. The latter makes the Character Palette available from the menu bar. 

You may also want to check the boxes for specific languages. 

For more on the use of the Character Palette, see Mac Help in the Finder Help menu, search for the Character Palette and look at the topic “Typing special characters and symbols”. 


	Switching Word’s AutoCorrecting of fractions on and off

AutoCorrect alters commonly occurring fractions as mentioned above without being in the Tools menu » AutoCorrect list. So how can you switch it on and off? Elliott Roper, on the microsoft.public.mac.office.word newsgroup, showed how, in his inimitable way:

Type “1/2”. Note that a little blue bar appears and disappears as Word turns the 1/2 into a fraction character. If you hover the mouse over it, flames will belch from its number 3 engine. If you click on the picture of the pilot ejecting (OK, I’m getting carried away — the little black triangle that appears nearby) you get a little drop-down menu.

One of the items says “Don’t format your fraction” or something like it. Another says “Don’t format fractions in future” or similar.

You may ask why am I being so vague. Well, after turning off formatting fractions forever and deleting all the fractions, the menu never reappears. So I can’t get it back to check the wording. And I can’t turn autoformatting common fractions back on.

I’m not that distraught, because it is mildly silly, and I have a better way, which also gives me better range of fractions. I created a series  of explicit AutoCorrect entries like “2/3” and “1/5” which translate into pretty fractions. I did that by inserting the fraction into a scratch document using Mac OS X’s Character Palette, and while it was selected did a Tools menu » AutoCorrect and filled in the (x/y) shortcut for the x/y character I just inserted.

To turn the little sniveller back on, create a macro with this as the only executable statement

Options.AutoFormatAsYouTypeReplaceFractions = True


The Mac platform has some significant shortcomings in relation to fonts, which are evident in formatting of fractions. The following method works in a cross-platform environment. 

These notes describe how to format fractions in running text that look like the ones inserted by special “fraction fonts” — that is, typographically elegant fractions with a sloping fraction bar and appropriately sized and positioned numerals. Not having to use “fraction fonts” is convenient if you don’t have such fonts installed, and is especially useful if you send your documents to people who don’t have such fonts. 

To copy the fully formatted “1⁄2” fraction provided below and prepare it as an AutoCorrect entry takes only three minutes — and you only have to do it once, because from then on Word will automatically insert a fully formatted fraction via AutoCorrect. This fraction can be adapted for other values as you choose.

You can also insert less typographically elegant fractions — choose Help menu » Microsoft Word Help » “Search” button » type in “EQ field” and/or “How do I insert an equation?”. 

1. Formatting the characters

Note: The fraction bar is Shift-Option-1. 

For 7-point components suitable for 12-point Times New Roman text

In the next paragraph is a sample of 12 point Times New Roman on “At least 13 point” line spacing, all three characters in 7 point (“1” is raised 3 points; fraction bar is raised 2 points; “2” is not raised):

The quick brown fox  jumped over the lazy dog. The slow brown fox  tried to jump over about  21⁄2 lazy dogs. The slow brown fox woke up the lazy dogs. 
You can change this to Arial, or any other font, by clicking to the right of “2”, holding down the Shift key and pressing the left arrow key three times. (
You can simply select this ( “1⁄2” ( and go to step 2 (“Setting up the AutoCorrect entry”), or format a fraction as follows:

Type “1” followed by Shift-Option-1 (which is a fraction bar) and “2”. Key Shift-[left arrow] to select the “2”. Key Command-d, click the “font” tab and enter “7” in the “font size” field. Click “OK”. 

Left arrow to de-select the “2”. Shift-[left arrow] to select the fraction bar. Key Command-d, click the “font” tab and enter “7” in the “font size” field. Click the “Character spacing” tab and enter “2 pt” (raised) against “Position”. Click “OK”.

Repeat for the “1” character but raise it 3 points.

For 6-point components suitable for 11-point Times New Roman text

In the next paragraph is a sample of 11 point Times New Roman on “At least 13 point” line spacing (“1” in 6 point is raised 3 points; fraction bar in 7 point is raised 1.5 points; “2” in 6 point is not raised):

The quick brown fox  jumped over the lazy dog. The slow brown fox  tried to jump over about 21⁄2 lazy dogs. The slow brown fox  woke up the lazy dogs.
You can simply select this ( “1⁄2” ( and go to step 2 (“Setting up the AutoCorrect entry”), or format a fraction as follows:

Type “1” followed by Shift-Option-1 (which is a fraction bar) and “2”. Key Shift-[left arrow] to select the “2”. Key Command-d, click the “font” tab and enter “6” in the “font size” field. Click “OK”. 

Left arrow to de-select the “2”. Shift-[left arrow] to select the fraction bar. Key Command-d, click the “font” tab and enter “7” in the “font size” field. Click the “Character spacing” tab and enter “2 pt” (raised) against “Position”. Click “OK”.

Repeat for the “1” character but enter “6” as the font size and raise 3 points.

2. Setting up the AutoCorrect entry

Select the three formatted characters (if you do not have “Smart cut and paste” enabled (Edit menu » Preferences » Edit), you may also want to select a 12 or 11 point space after them).

Go to the Tools menu » AutoCorrect. 

In the right‑hand field, “1/2” will be present. Click the “Formatted Text” button above the right-hand field.

Click in the left‑hand (“Replace”) field and type in the term you want AutoCorrect to amend. I did not want to use “1/2”, because it’s likely that I will want to type those characters in other contexts, such as two alternative dates (1/2 March). And of course I couldn’t use “half”. I therefore allocated the term “hhalf” — with the “h” repeated, as I do with some of my AutoCorrect terms in the table on page 81. That’s only my personal convention; I find that it’s convenient to repeat the first letter to initiate many AutoCorrect terms.

Click the “Add” button, then the “OK” button. 

Now I only have to type “hhalf” and the formatted fraction is inserted immediately by AutoCorrect. 

I don’t use fractions often, so I opted to have only the one entry and to manually alter the “1/2” to “3/4” and so on. If I were using fractions more often I would prepare more examples by altering the formatted “half” fraction directly and allocating an AutoCorrect term for the new fraction. 

Appendix G: Automating standard comments via AutoText items on a toolbar

These notes show how to make buttons on a toolbar to quickly insert commentary notes (as described on page 125 — ‘“Comment” feature, a simple substitute for’) in the character style “comment in text,ct”. The notes on page 99 under “Paragraph styles and character styles — what’s the difference?” should also be read before going further.  

The toolbar and buttons I made looked like this: 

[image: image83.png]O C comments co...





The top button inserts this comment: ( Re-visit  ###
The second inserts this: ( Let’s discuss  ##
The others are an arrow plus two hashes, such as: ##  (
Clicking a button triggers a macro that inserts an AutoText entry with the required wording, including “#” characters (their purpose in reviewing documents is mentioned on page 125). 

The macro also places the insertion point ready to type in [further] text within the comment. 

Some background on making toolbars is on page 109, under “Creating buttons on toolbars to apply selected styles and formatting”. 

Step 1: Identify the text you want as an AutoText entry

Word lists a new AutoText entry (on the Insert menu) under a submenu titled with the style of the paragraph in which it is created. Therefore, you need to consider the style of the paragraph in which you are going to create the entry. I put comment-type AutoText entries in paragraphs in my customised body-text style “bt”, because that’s where my comments are always inserted.  If you prepare the new AutoText entry in a paragraph in Normal style or another default style, the pop-down menu on the AutoText toolbar or Insert menu » AutoText, the menu will show “All entries”. You can achieve this in a non-default style (such as “bt” in this document) by holding down the Shift key before operating the menu. 

If you later want to put the entry under the heading of another style, click in a paragraph of that style, prepare an identical entry as “New”, and answer Yes when asked if you want to re-define the entry (all it does is re-allocate the entry to that style).

So, with the above in mind, step 1 is to type in the words you want to have inserted as an AutoText entry.

Step 2: Make the AutoText entry

The arrows below are AutoCorrect items, produced as shown in the table on page 81.

Having typed the words that will be entered (such as “( Re-visit ##”) in the document, the next step is to select them. Apply the character style “comment in text,ct”, then choose the Insert menu » AutoText » New » name it with the fuller term following the abbreviation (spaces are allowed). 

By starting the entry name with an abbreviated term, I can quickly invoke a commonly used AutoText term by just typing the abbreviation and invoking AutoText as described on page 121. I don’t do that to invoke the following terms, but I have written the macros to operate on the abbreviations. 

	Abbreviation 
	Produces this in the character
style “comment in text,ct”

	ctrv, comment revisit
	( Re-visit ###

	ctdn, comment down arrow
	##  (

	ctla, comment left arrow
	(  ##

	ctna, comment no arrow
	##

	ctra, comment right arrow
	##  (

	ctup, comment up arrow
	(  ##

	clds, let’s discuss
	( Let’s discuss ##


Step 3: Make the macro

Tools menu » Macro » Record new macro » name consistently with the following (no spaces or non-Windows-acceptable punctuation): 

CommentDownBlank

CommentLeftBlank

CommentLetsDiscuss

CommentRevisit

CommentRightBlank

CommentUpBlank

» on toolbar:

•
save in desired template 

•
» drag to toolbar 

•
» record macro: 

–
type AutoText abbreviation, select with left arrow and shift key down, type Command-Option-v

–
arrow-key to where you want the insertion point to be

–
stop recording.

•
hold down Control key, click on button » Properties » re-name.



Contents
�	Although the notes are based on Word 2001 (now modified for Word 2004), some of my friends have found them useful for understanding other versions of Word. That’s because the file structure for all Mac and Windows® versions since Word 98 (Word 97 on the PC) has been the same; and the features and interface have been broadly similar since then. 


�	Word’s “Page Layout” view on the Mac is “Print Layout” view on PCs and in Word 2011. 


�	Some history: Susan Kare, who designed the Mac’s first icons (www.kare.com), based the icon for the Command key on a symbol used in Swedish camping grounds to denote “an interesting feature”. Somewhat earlier (I was only a boy at the time), Queen Elizabeth I often included this symbol in her wonderfully ornate signature. 


�	If you are using Safari, you may have to click on the circular arrow (“reload the current page”) button a couple of times at these pages.


�	I like this comment by Elliott Roper: “Word's help on the topic seems to have been carefully written by someone who did not understand the difference [between two features] and was too scared to ask”. And another: “Don't let Word's help get you down. It is a disorganised heap designed to frustrate and annoy until you get used to  its idiosyncratic ways. And then it is still a pain. The easy way to find something in there is to know the answer”. 


�	As Bob “CyberTaz” Jones puts it: “Inserting objects into a Word document is tantamount to injecting foreign bodies directly into your blood stream.  :-) There is much to learn and understand in order to do so effectively. And even seasoned professionals can find it trying at times. In fact, they'll often advise against using Word for the actual layout work if any number of graphic objects are required -- it's better handled by importing the text from Word into a page layout program document.”


�	The above figures for RAM allocation to Word are as recommended for Word 2001 (Word 98 needs less) by experts in the microsoft.public.mac.office.word newsgroup and have been shown consistently to solve many operating problems in Word. If you want to minimise problems in Word 2001 and you do not have 256 megabytes of physical RAM installed, buying more will be one of the best purchases you have made. As one member of the newsgroup said, “Word hungers for memory. The more you can feed it, the happier its bloated appetite is”. But you need to take care not to allocate so much memory to Word that other applications cannot work well; the amount you allocate should take account of the number of fonts you have installed (because fonts load into memory at start-up and stay there) and the number of applications running at the same time as Word — remember that if you do not quit an application (by choosing File menu » Quit or keying Command�q) but only close its window or document (by clicking the close box or keying Command�w), the application will still be running and will use up as much RAM as if you were working in it. 


�	This is discussed on page � PAGEREF _Ref449192296 \h ��161�.


�	If you have been using Word for a while, you can at least create a fresh-out-of-the-box Normal template, as if you had started up Word for the first time. Quit Word. Locate the Normal template by doing a search for “Normal” using Spotlight. Re-name it, temporarily — say to “Normal on [date]”. Don’t move it to another folder. Start Word up again, then quit. Word will have created the same Normal template as it did on the first occasion Word was started on your Mac. Locate it using Spotlight (like its predecessor, it’s named “Normal”) then re-name it — say to “Pristine Normal” or “Normal out of the box”. Back it up for long-term retention, e.g. to an external hard disc and a CD�ROM. Then change the name of the earlier Normal template (“Normal on [date]”) back to simply “Normal”. When you start Word up again, the application will have the same Normal template characteristics as before.


�	But beware: As Elliott Roper said, “B.F. Skinner would have called learning Word ‘Operant Conditioning with Variable Ratio Reinforcement’. There are so many little nooks and crannies, you learn it the same way you get addicted to poker machines.”


�	Live Word Count is exhausting to a laptop battery: it keeps the CPU going at about 70 per cent, even when you are doing nothing.  Turn it off and the CPU load drops back to about 10 per cent.


�	Here is John McGhie’s description: The paragraph mark is actually a “property container” that contains or references something like 250 different pieces of information.  You could think of it as a fairly large table with multiple columns of values. Many of the values are byte offsets to various other pieces of information. Whenever Word does anything to a paragraph, it has to re-knit all the offset pointers together into a woolly jumper [a highly technical term — “sweater” in the US].  If it doesn’t get it right, the document is now corrupt and none of it can be read. 


�	WYSIWYG = “What you see is what you get”.


�	If your document has ever had a macro, or — I’ve been told — has ever been attached to a template other than the Normal template, it will trigger this warning if you have set your preferences to be notified. 


�	Opinions on appropriate virus protection on the Mac vary. The most conservative is that Mac users should be as conscientious about viruses as Windows users, despite no viruses having been made for the Mac since OS X, the innate difficulty of writing them for the Unix environment, Apple Inc.’s ongoing development of security updates, and so on. However, a macro virus made for Microsoft Office/Word can be acquired by a Mac, have no effect on the Mac (though some can affect Word), but be sent out to a Windows computer with the document. There is also a small amount of evidence of document corruption occurring in Mac Word documents from viruses designed for Word on the Windows platform. If you take the conservative approach, the best way to minimise potential viruses is to have a high-security firewall in place; to set [frequently updated] anti-virus software to scan e�mail attachments and hard drives; not to run macros from people you don’t trust; and to enable the macro warning in Word’s settings. Note that the macro security setting is at the bottom of this list, not the top. Some people argue that the foregoing isn’t necessary, for various technical reasons. I don’t know; I have no expertise in this area. (For one useful discussion, do a Google newsgroup search, as described on page � PAGEREF NewsgroupSearch \h ��26�, on the microsoft.public.mac.office.word newsgroup for the subject ‘MAC virus’ (note the upper case) and author ‘McGhie’. John concludes with “I think virus-writing has now advanced to the point where it's a serious threat, even on a Mac”.) And as Microsoft MVP Jim Gordon said in Sept�ember 2008: “The one that crops up most often is an old one that affects Microsoft Word. Macro viruses are currently few and far between.… The rule is the same for phishing attacks and macro viruses. Don’t install anything without being 100% certain of the true source. Even then you’re not 100% safe from troubles.”


�	For that reason, if I e�mail a document that contains macros or is otherwise likely to trigger the macro warning, I always send an advance notification a little beforehand. Depending on the version of Windows, if the recipient has set the virus setting to “high” it may well have to be temporarily set lower; otherwise, the macros may be stripped out without the user being asked. 


�	Document corruption is mentioned in various places in these notes (accessible by doing a “Find” command for “corrupt”) and an article is referenced on page � PAGEREF _Ref442674012 \h ��132�.


�	I prefer a full keyboard, so my usual set-up, except when flying, is to put my PowerBook on a stand (the screen is then vertical at a very good height; the un-needed keyboard is at a 60-degree angle) and I hook up an aluminium Apple keyboard and a big Kensington trackball. 


�	A note for Word 2004: quite separately from this setting, there is a similar setting, “Auto-capitalize first letter of table cells”, in Word 2004. You can stop this by popping down the so-called “smart button” (it has a yellow lightning flash, and it’s accessible by scrolling over the little blue “underline” that appears at the beginning of the word once this action has occurred, then clicking, which shows the options) and selecting the “Stop …” option. Once you have done that, there is no option to restore the setting. 


�	For a discussion of templates, see page � PAGEREF _Ref447529666 \h ��106�. 


�	John McGhie recommends that to minimise the chances of corrupting the Normal template, ensure that only one document is open before customising; Save All and Quit after customising and before using; and work carefully and precisely, making only one change at a time until you become good at it. 


�	In Word 2004 I discovered I had to open Tools » Customize » Customize toolbars and menus. Ah, that’s progress I suppose …


�	Actually  it’s a script “C” (for Latin “capitulum”, chapter) crossed by one or two vertical lines.  


�	Word 2004: Tools menu » Customize » Customize toolbars and menus.


�	Not to be confused with Word’s other ruler, i.e. the calibrated [what word can you use here other than “ruler”?] that runs across the top of each document.


�	If you want to add a vertical separator line, see the note on page � PAGEREF VerticalSeparatorLine \h ��48�. 


�	Note that changes may be tracked invisibly without your knowing it, which is dangerous — see “� REF _Ref417285957 \h ��Track changes, turning off�” on page � PAGEREF _Ref440257055 \h ��68�.


�	You can get Word to place all new templates where you want them in future by specifying the location via Word menu » Preferences » File Locations. 


�	For a Word 98 installation, these files are in the Preferences folder but there is no Microsoft folder; and the version is “(8)”. 


�	Putting templates in the Microsoft User Data folder, as recommended, also means that if you have to re-install Word you won’t lose them. This is the only instance of “data” files being removed if you use the “Remove Office” tool on the installation CD.  Note: with Mac versions of Office, re-installing when you have problems is very rarely necessary and can give rise to other, deep-seated problems, especially if beforehand you have tried to manually remove Office (most commonly an Office Test Drive on a new Mac — an appalling implementation on Microsoft’s part). For solutions, see the MacWord MVP newsgroup (page � PAGEREF mpmow \h ��22� of these notes).  Finally, one caveat: Just before you install the next version of Offie, or if you need to re-install Offie, it may be best to temporarily remove the aliases and move the settings files back into their original place.  I suspect that even if that were not done, Word would simply replace the aliases with new “originals”, and would therefore not look further — but I have not had time to test this. In that event, you would still need to repeat the actions above.


�	Except for formatted AutoCorrect entries, which are stored in the Normal template. 


�	Command-h in Word 2001 and earlier.


�	The “header” is the text (if any) that runs across the top of all pages with — for example — the title of the publication, as in this document. The style named “Header” is a reserved built-in style, which Word uses automatically to format the text within the running headers.  By all means change the appearance of the “Header” style to the way you like it, but don't re-purpose that style for anything else — that is, don’t apply it in the main body of the document. Some people do this because they think “header” means “heading”. 


�	If you receive a document and aren’t sure which type of page number is in the document, click the page number: if it is suddenly surrounded by a little box, delete it and follow these notes instead.


�	Control-spacebar was allocated to Spotlight in OS 10.4. A work-around is discussed on page � PAGEREF _Ref530631251 \h ��113�. 


�	All but the last are configurable via Table menu » Properties (after selecting the table). Once you have turned them off, Word will be quite snappy — because it will no longer, for example, have to scroll the table to the power of the number of cells in it. 


�	Although it’s only necessary with very unusual documents, you can specify any style as a basis for compiling a table of contents. 


�	John McGhie’s comment: “A Word document internally is an indescribably complex rat’s nest of binary pointers.  Each tracked change sets a heap of extra pointers, to the beginning and end of the deleted text, and the beginning and end of the new text.  If those pointers occur within pointers… what you end up with is a document that is so complex that Word can’t unravel it.  It’s a limitation of the Word document format, which was designed for simpler times when computers were smaller and slower, and so were documents.”


�	Again, John McGhie’s comment: “Intrinsically, Tracked Changes results in extremely complex structures in the document, so you need to edit carefully with paragraph marks shown.  If you do not, you can end up corrupting the document. It is never a good idea to make changes within changes: if you do too much of this, document corruption becomes very likely.”


�	Word 2004 also has a “Paste Options” clipboard — accessed by a tiny blue icon that appears below newly pasted text. One of the options is “paste matching destination format”. Supposedly you can turn the paste options clipboard on and off via Word menu » Preferences » Edit, but on my copy I can’t. ( CH: Revisit — possibly I have instigated an undoable one-way modification # In any event, because it requires the mouse to be used, and is slower than a keyboard shortcut, I don’t use it.


�	However, the default wording of the menu item does reflect that (a) you can put this command on any menu in Word and (b) having clicked on it you will remove the next menu item that you select — it’s by no means confined to Work menu items. However, I’m not keen on forgetting how “dangerous” that can be, so I prefer to confine its use to the Work menu and to word it accordingly.


�	This is my (manually applied) version; I don’t use Word’s versioning system. 


�	In Word X, the Formatting palette has to be open for the Command-Shift-s keyboard shortcut to work — a crazy arrangement, since most people who use shortcuts don’t use the Formatting palette. This was corrected in Word 2004. 


�	You can exclude or include any style you want from being compiled in tables of contents (Insert menu » Index and Tables » Table of contents » make your selections » specify a new number in “Show levels” or nominate styles and their heading levels in “Options”. However, my different clients need so many variations that it’s simpler for me to control this factor via my “nontoc” styles. 


�	Double-clicking anywhere on a word (and dragging with your mouse down if selecting more than one word) is more efficient than carefully single-clicking in the correct place and dragging.


�	To prevent Word intervening in this way, see “� REF _Ref440623262 \h ��Stopping Word from changing your definitions of styles�” on page � PAGEREF _Ref438028254 \h ��119�.


�	The only exceptions I make are with my style “bt”, standing for “body text”, and frequently used sub-paragraph styles.  I could have titled style “bt” as “body text, bt”, but chose not to because in some displays — such as when customizing toolbars — the suffix is not visible. I did not want to have this style confused with Word’s default “Body Text” style, which if applied could potentially over-ride my style’s characteristics, as described on page � PAGEREF _Ref486929441 \h ��121�. 


�	Windows and Macintosh machines have different font sets as standard — see page � PAGEREF _Ref438474987 \h ��141�.  They automatically convert between each other, so provided you stick to Microsoft’s standard font set for one or the other, you should have no trouble.  If you use a non-standard font, you may find weird characters displayed on machines that do not have the font. 


�	As outlined on page � PAGEREF _Ref440624672 \h ��106�. 


�	In Word X, the Formatting palette has to be open for the Command-Shift-s keyboard shortcut to work. 


�	Anyone coming from Windows will find this difficult to get used to on the Mac, since Word on the PC creates a new document from a template when you click on the template. Word X and Word 2004 do not — all that opens is the template <mutter, mutter>.


�	Word ignores the template after initial creation of the document.  All styles from that point on are embedded locally in the document, unless you have “Automatically update styles on open” switched on in Tools » Templates and Add-ins, or unless you change the style and specify that the change will also occur in the template (Format menu » Style » Modify » Add to template.


�	Some changes to Normal toolbars are discussed in the section starting on page � PAGEREF _Ref450984127 \h ��45�. 


�	Some of the limitations of altering the default toolbars in the Normal template, and some work-arounds, were discussed on page � PAGEREF _Ref427127300 \h ��46�.


�	In Word 2004, you can’t do this to amend Normal style — the feature may have been removed because it was one of the main sources of document corruption. 


�	Even more often, I use a shortcut for stripping character formatting from text (e.g., originating on websites or manually formatted documents). It’s described on page � PAGEREF pastePlainText \h ��195�. 


�	Some of which, in relation to attaching styles, toolbars and macros to a template other than the Normal template, are outlined on page � PAGEREF _Ref464522860 \h ��109�. 


�	That is, upright or non-italic. 


�	In Word X, the Formatting palette has to be open for the Command-Shift-s keyboard shortcut to work. 


�	Control-spacebar was allocated to Spotlight in OS 10.4. A work-around is discussed on page � PAGEREF _Ref530631251 \h ��113�.


�	Control-spacebar was allocated to Spotlight in OS 10.4. A work-around is discussed on page � PAGEREF _Ref530631251 \h ��113�.


�	See page � PAGEREF _Ref3460548 \h ��180� for a discussion of leading (pronounced “ledding”) — the space above or below the paragraph — and the advantages of including leading in paragraph styles.


�	This is particularly noticeable with PC owners who have Word 97 — in this version, the default font size for Normal was re-defined to be 10 points. 


�	Because the “Automatically update” option is a property of the document, not the template. In other words, you can’t set Normal.dot to update styles automatically. 


�	If they are on Windows, make sure to add a “.dot” suffix to the file title of the template. Never send them a Normal template from Word on the Mac. (There are slight advantages to adding file suffixes in OS X — hence “.dot” to customized templates — but never add “.dot” to a Normal template on the Mac.)


�	I did design some, based on “no style”, and used them successfully, but I’ve since been persuaded by guru John McGhie that (a) support of features such as Outline Numbering is hard-wired into the code for the default heading styles and (b) I might be making the documents containing customised heading styles vulnerable to future modifications that Microsoft might build into Word’s default heading styles. And, certainly, not all of the advantages of using the built-in heading styles (see page � PAGEREF _Ref468810713 \h ��92�) were available to these styles. In other words, there are too many wonderful bells and whistles built into the default heading styles that it’s not worthwhile to build similar ones from scratch. Better, instead, to modify the defaults (font, font size, colour etc) to meet your requirements — and if there is any doubt about a colleague’s defaults over-riding your modifications, getting them to check out the Tools menu » Templates and Add-ins » de-select the “Automatically update styles on open” setting. 


�	Daiya Mitchell, one of the experts at the MacWord MVP newsgroup, takes this further: “My personal preference is to create a BaseFont style, which never gets applied to any styles, but exists solely to base everything else on, but separately.  I don’t like having cascading chains, because it confuses me, but I like being able to change the font at one swoop. This removes Normal from the equation entirely, so that I can mess about with everyday documents without worrying whether I am doing anything to my custom template.”


�	The “other half” of the glossary function is AutoCorrect.. AutoText is very similar to AutoCorrect. The difference is that AutoCorrect inserts text automatically when you key in the abbreviated term for the entry and follow it with a space or punctuation mark, but you have to initiate AutoText entries manually. However, behind the scenes, Word “converts” one to the other, depending on what it contains. AutoCorrect entries are converted to AutoText entries if they contain formatting. AutoText entries may be stored as AutoCorrect entries if they do not contain formatting.


�	If you want to put the AutoText entry into a template other than Normal that your document is attached to, instead choose Insert menu » AutoText » AutoText, then look at the bottom for the pop-down menu against “Look in”. Pop to the name of the template attached to the document.


�	Table menu » Insert » Table » Number of columns [insert a number]. Then specify AutoFit behaviour as: Initial column width Auto (don’t use “AutoFit to contents”). Then configure via Format menu » Borders and shading » Borders (don’t use the “Split cells” feature on the Table menu). Those two “don’ts” are to minimize potential corruption. 


�	Word’s Help defines a bookmark as: “A location or selection of text that you name for reference purposes. Microsoft Word marks the location with the name you specify. Bookmarks are more than placeholders — for example, you can use them to create and number cross-references.”


�	If the table of contents is on the first page, you only need to key Command-Home to get to the first page. But in my documents the table of contents is usually several pages in, so this bookmark saves having to scroll to the contents page. 


�	Of course, the word “Contents” that heads up the table of contents has to be in a style other than a Heading style — otherwise that word will be replicated in the table of contents itself. In this document I used style “nontoc 1”, the “nontoc” series having been designed to look the same as the Heading series but not to invoke a table of contents entry, but any style that ends up looking like a Heading 1 can be used.


�	Control-spacebar was allocated to Spotlight in OS 10.4. A work-around is discussed on page � PAGEREF _Ref530631251 \h ��113�.


�	More specifically, the final paragraph mark is followed by an invisible section break that contains a huge series of binary structures (linked lists and look-up tables) referenced by binary pointers for the properties of the whole document. They are what you’re excluding from the copy-and-paste, to be replaced by the properties of the document into which you paste the text. Similarly, when you have inserted sections within a document, the final paragraph mark for each section performs a similar function, albeit with fewer structures. That’s why it’s best not to use more section breaks than you need, because each one is a large container of complex properties.  Adding a section break is almost equivalent to adding another document within the first; it makes Word work harder.


�	The reason this is so effective is that round-tripping to HTML forces Word to re-express the document in a totally different object model.  In doing so, it discards anything it cannot understand, thereby removing the corruption. 


�	Having a localized variant of English is a huge benefit that Australian users of Word benefit from, especially because it includes Australian place-names. If I lived in New Zealand I would use the Australian dictionary and localize it via the Custom Dictionary by obtaining a list of NZ place names, editing them if necessary to make each word a separate paragraph, opening my custom dictionary and pasting them in. A Canadian might do likewise to the UK English dictionary (though I know some Canadians prefer to start from the Australian dictionary — its main sin is to prefer “ise” to “ize” indiscriminately, in conformity with the whims of a style-setting dictionary publisher in the 80s). And so on for people in other English-speaking countries, who usually do not want US English spelling. This arrangement is less trouble than giving the “OK” to every place name etc as it first comes up, with the attendant risk that the wrong spelling might get into your custom dictionary. 


�	If you use the Style Area feature, you can’t use Document Map because they claim the same space to the left of the document (but you can choose Window menu » New Window and have one window with the Document Map and the other with Style Area).


�	More specifically: if Document Map finds such a line of text and does not find an outline level property in its style (because if it did find one, that would indicate the line was already styled as a heading), it will reset the outline level property on the paragraph (as normally achieved by Format menu » Style » Modify » Format » Paragraph » “Indents and spacing” tab » Outline level) — instead of applying a Heading style.


�	If you get caught this way, the best way to fix the styles after Document Map has had its wicked way would be to click in each piece of affected text and key Command-Option-q to restore the paragraph properties of the underlying style. If it isn’t clear which text has been affected, see “� REF _Ref464878060 \h ��Checking whether a style has been manually modified or not�” on page � PAGEREF _Ref464878079 \h ��119�.


�	By “header” I’m referring to the text that can be made to run across the top of all pages, as in this document. Many people say “header” when they mean “heading”; in this case it’s important to be clear on this point. 


�	If you want to re-start numbering at page 1 after the document’s preliminary pages, you would need one section break to re-start the numbering and you would click in the first page of the new section before formatting the header(s) with StyleRef. For further information, do a Google search for “StyleRef” in the Word newsgroup. 


�	Courier New has been dropped from the list with Word 2004. 


�	Times New Roman in Word 2004, which I understand has the same number of Unicode characters as in the PC version, contains about four times the number that Times has. The Unicode character set in Arial on the PC is absolutely huge; on the Mac it is less complete, but is still large. John McGhie pointed out a workaround for Mac users to install the full PC Arial font: you can find it by Googling a posting on the microsoft.public.mac.office.word newsgroup (see page � PAGEREF Google \h ��27�). The subject is: “Document Format changes in Word 2004”, the date 19 November 2004. 


�	However, if you want, for example, to restart footnote numbering by chapters, to have a “different first page”, or to re-start page numbers at “1” after the page containing the table of contents, you will need to include at least one section break.


�	If on the other hand you want a section heading rather than chapter heading to appear in the field in the header, you would nominate, say, Heading 2. StyleRef will then display the words of the first heading formatted in Heading 2 style.


�	For example, if you used Heading 5 style for this purpose you would set the Options in Insert » Index and tables » Table of contents so that the table of contents only gathers up headings of levels 1 to 4.


�	Called “Print Layout” in PC Word. 


�	Personally I find too many non-printing characters, such as spaces, distract from the meaning of text, but I seem to be out of step with most people on this. 


�	Pasting numbered paragraphs from one document into another is always high-risk; it’s best to paste unformatted (Edit menu » Paste Special » Unformatted) and apply style-based numbering afresh.


�	“Automatically Update styles on Open” is available only for attached templates, not for the Normal template, which is a global template.


�	To be techo, here is the detail from John McGhie: Each paragraph simply contains a “pointer” —  a hexadecimal number that is the byte offset from the top of the file — of a row in a look-up table.  The table row (at the end of the document, not displayed, and situated below the last paragraph mark) contains the actual formatting instructions for the list.  


�	Word 2004 is less prone, but the problem has not yet been completely fixed.


�	For an explanation of the cause, see under “� REF _Ref471195855 \h ��Saving documents, strategies for�” on page � PAGEREF _Ref471195835 \h ��155�. 


�	Control-spacebar was allocated to Spotlight in OS 10.4. A work-around is discussed on page � PAGEREF _Ref530631251 \h ��113�.


�	Another, better solution is to bookmark the footnote and create a hyperlink to it — but some people have been unable to get this to work, and nobody has been able to establish why. 


�	The situation gets worse if the text is formatted in two columns. If you use “Keep With Next” to hold a heading to the next paragraph,  Word will automatically suppress any space above the heading when it flips the heading to the next page, resulting in both columns starting at the same distance from the top of the page. However, if the heading has been forced manually to the next page via a page break, the space above the heading is retained, making the heading start lower down than the adjacent column of text, which looks awful.


�	I’ve found that in these circumstances the originator is usually astonished that there has been any problem at all. In explaining the causes to PC users, I particularly emphasise the significance of having different printer drivers, display cards and font configurations rather than the fact that I am viewing the document on a Mac; most people will unthinkingly “blame the Mac” because as far as they perceive, that’s the most obvious difference. Some will persist in that view even when I have shown the same problem when I have put the document on my PC laptop running Windows. 


�	Don’t make it “exactly” — that will bring problems with visibility of graphics. 


�	Widow/orphan control retains at least two lines of text either side of a page break when Word splits a paragraph to continue to the next page. You should remove widow/orphan control from styles that you use in tables (in this document, that style is “table text”), and in heading styles. 


�	I avoid this possibility wherever possible by doing a “Save As” on the as-yet-unformatted document and formatting the new document for publication; then I return to the previous (unformatted) document if there are subsequent changes. But if the changes aren’t extensive, that’s when I’m tempted to update both documents. But assessing which option will save most time in the long run is like betting on horses, is it not?


�	That’s why, for example, I don’t incorporate a “page break before” in my definition of the style for Heading 1, even though I always put a Heading 1 on a new page. 


�	That’s also why some pages of Bend Word to Your Will have large areas of white space at the bottom.


�	In Word 2001, create a button on a new toolbar that’s attached to a new document (not the Normal template). Then hold the Control key down and click on the button » Properties » pop down the tiny triangular arrow near the top left » “Edit button image” » select the colour (or “Erase” if a default image is present) and click away. Then open the document in Word 2004 and transfer the button to its “real” parent toolbar via the Organizer. 


�	John McGhie says that Acrobat, or any other application that wants to receive Rich Text, causes Word to bookmark the source rather than copy directly to the clipboard. He says he believes Word does this because it can place material on the clipboard in about eight different formats, so it waits to see which one the recipient application requests, then manufactures it on the fly.





